Solve this interesting problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1479    Accepted Submission(s): 423

Problem Description
Have you learned something about segment tree? If not, don’t worry, I will explain it for you.
Segment Tree is a kind of binary tree, it can be defined as this:
- For each node u in Segment Tree, u has two values: Lu and Ru.
- If Lu=Ru, u is a leaf node. 
- If Lu≠Ru, u has two children x and y,with Lx=Lu,Rx=⌊Lu+Ru2⌋,Ly=⌊Lu+Ru2⌋+1,Ry=Ru.
Here is an example of segment tree to do range query of sum.

Given two integers L and R, Your task is to find the minimum non-negative n satisfy that: A Segment Tree with root node's value Lroot=0 and Rroot=n contains a node u with Lu=L and Ru=R.

 
Input
The input consists of several test cases. 
Each test case contains two integers L and R, as described above.
0≤L≤R≤109
LR−L+1≤2015
 
Output
For each test, output one line contains one integer. If there is no such n, just output -1.
 
Sample Input
6 7
10 13
10 11
 
Sample Output
7
-1
12
 
Source
 
解题:搜索
 
 #include <bits/stdc++.h>
using namespace std;
typedef long long LL;
const LL INF = 0x3f3f3f3f3f3f3f3f;
LL X,Y,ret;
void dfs(LL L,LL R) {
if(R >= ret || L < ) return;
if(L == ) {
ret = min(ret,R);
return;
}
if(R - L + > L) return;
dfs(*L - R - ,R);
dfs(*L - R - ,R);
dfs(L,*R - L);
dfs(L,*R - L + );
} int main() {
while(~scanf("%I64d%I64d",&X,&Y)) {
ret = INF;
dfs(X,Y);
printf("%I64d\n",ret == INF?-:ret);
}
return ;
}

最新文章

  1. 编写Windows服务疑问1:操作过程
  2. 5.3监听请求:使用eclipse的tcp/ip工具(端口转换)
  3. 使用国内 maven 镜像 代替国外 mirror
  4. FileUpload1上传控件
  5. 使用一般处理程序HTTPHandler下载文件
  6. xmlns=&quot;http://schemas.xmlsoap.org/wsdl/&quot;,这是什么意思,我只知道:xmlns:xx=....,
  7. java去除重复的字符串和移除不想要的字符串
  8. android和javascript之间相互通信实例分析
  9. JS判断,今天所在季度,第几周, 季度的第几周,年度第几周
  10. JavaNIO缓冲区
  11. node实现一个WEBSOCKET服务器
  12. Java框架数据库连接池比较 [转贴 2010-3-20 9:57:51]
  13. CentOS系统下搭建tomcat服务器
  14. zabbix3.2监控mysql
  15. Jupyter notebook安装扩展插件
  16. 第二次作业——分布式版本控制系统Git的安装与使用
  17. 关于JavaScript的操作
  18. python3 get/post/使用代理/自定义header/自定义Cookie
  19. spring+mybatis的插件【shardbatis2.0】+mysql+java自定义注解实现分表
  20. 用Vue-cli生成vue+webpack的项目模板怎么设置为vue1.0版本?

热门文章

  1. vue svg的使用
  2. OO第三单元总结——JML规格设计
  3. 利用Python对文件进行批量重命名
  4. Spring MVC学习总结(7)——Spring MVC整合Ehcache缓存框架
  5. 洛谷——P2822 组合数问题
  6. echarts 柱状图和饼状图动态获取后台数据
  7. HDU 4332 Contest 4
  8. what&amp;#39;s new in vc2015
  9. Oracle 12c agent install for windows
  10. 如何获取Assets的路径