题目地址

https://pta.patest.cn/pta/test/16/exam/4/question/665

5-3 Pop Sequence   (25分)

Given a stack which can keep MM numbers at most. Push NN numbers in the order of 1, 2, 3, ..., NN and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if MM is 5 and NN is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): MM (the maximum capacity of the stack), NN (the length of push sequence), and KK (the number of pop sequences to be checked). Then KK lines follow, each contains a pop sequence of NN numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

  

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO
/*
评测结果
时间 结果 得分 题目 编译器 用时(ms) 内存(MB) 用户
2017-07-08 15:55 答案正确 25 5-3 gcc 3 1
测试点结果
测试点 结果 得分/满分 用时(ms) 内存(MB)
测试点1 答案正确 15/15 2 1
测试点2 答案正确 3/3 2 1
测试点3 答案正确 2/2 2 1
测试点4 答案正确 2/2 3 1
测试点5 答案正确 1/1 2 1
测试点6 答案正确 2/2 1 1 */
#include<stdio.h>
#define MAXLEN 1000 /*下面这段代码只能拿18/25分
int main()
{
int i,j,m,n,k,last,flag,temp;
scanf("%d %d %d",&m,&n,&k);
for (i=0;i<k;i++){
flag=1;
last=0;
for(j=0;j<n;j++){
scanf("%d",&temp);
if (temp-last>m) flag=0;
last=temp;
}
if(flag==0) printf("NO\n");
else printf("YES\n"); }
}
*/ struct stack{
int data[MAXLEN];
int top;
int max;
}; struct stack workstack; int GetTop(struct stack stc)
{
if(stc.top>=0) return stc.data[stc.top];
else return 0;
} int Push(struct stack *stc,int item)
{
if (stc->top==MAXLEN-1) return 0;
else {
stc->data[++(stc->top)]=item;
// printf("--PUSH %d,%d\n",stc->data[(stc->top)],stc->top);//test
return 1;
}
} int Pop(struct stack *stc)
{
if(stc->top<0) return 0;
else{
// printf("--POP %d,%d\n",stc->data[(stc->top)],stc->top);//test
return stc->data[(stc->top)--];
}
} int main()
{
int i,j,m,n,k,numforpush,errorflag,temp;
scanf("%d %d %d",&m,&n,&k);
workstack.max=m;
for (i=0;i<k;i++){
errorflag=0;
numforpush=1;
workstack.top=-1;
for(j=0;j<n;j++){
scanf("%d",&temp);
if (errorflag==1) continue;
// printf("--GET %d\n",temp);//test
while(workstack.top<workstack.max-1 && numforpush<=n && GetTop(workstack)!=temp){
// printf("--IN WHILE workstack.top=%d,max=%d,numforpush=%d\n",workstack.top,workstack.max,numforpush);//test
Push(&workstack,numforpush);
numforpush++;
} if(GetTop(workstack)==temp){
Pop(&workstack);
}
else{
errorflag=1;
} }
if(errorflag==1)
printf("NO");
else
printf("YES");
if(i!=k-1) putchar('\n');
} }

最新文章

  1. [python]设计模式
  2. Struts2 拦截器配置以及实现
  3. python中的monkey-patching
  4. Oracle临时表
  5. 用SQL语句,删除掉重复项只保留一条
  6. Corporative Network_并查集
  7. kettle创建资源库
  8. autoSvn
  9. C语言--流程控制
  10. Broadcast详解
  11. sql中的split方法
  12. 【BZOJ3627】【JLOI2014】路径规划 分层图
  13. crmplugin项目加入key文件
  14. java单点登录原理与简单实现
  15. TCP断开那些事
  16. Python格式化字符
  17. 【GIS】Mapbox-json配置
  18. NETSHARP微信开发说明
  19. Django popup示例
  20. 美团外卖iOS App冷启动治理

热门文章

  1. OC的单例模式
  2. 使用kubeadm安装kubernetes v1.14.1
  3. 编程挑战JavaScript进阶篇(慕课网题目)
  4. css实现行内文字垂直居中
  5. iOS开发XML解析
  6. EEPROM介绍
  7. 【数据分析 R语言实战】学习笔记 第六章 参数估计与R实现(下)
  8. Ubuntu14.04 LTS安装 OpenCV-3.0.0-rc1 + QT5.4.1
  9. Chrome开发者工具关于网络请求的一个隐藏技能
  10. CocosCreator工程内的命名