Flip Game
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 37201   Accepted: 16201

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each
round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:

  1. Choose any one of the 16 pieces.
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example:



bwbw

wwww

bbwb

bwwb

Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:



bwbw

bwww

wwwb

wwwb

The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the
goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

Source

Northeastern Europe 2000



一个4*4的矩阵,每个格子要么是黑色,要么是白的,目标是将全部的格子颜色统一,每次可以翻转一个格子,黑变白,白变黑,翻转的同时该格子的周围上下左右也会变颜色(有的话),问最少的步数,由题意易知每个格子最多翻转1次,最多的步数也就是16,状态就是有2的16次方种,枚举每一个可能的步数,每个格子可以翻转或者不翻转,

在达到枚举的步数时,判断一下颜色是否相同,总的思路就是一行一行枚举,一个一个尝试

#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
#include<queue>
#include<algorithm>
using namespace std;
bool map[6][6],flag;
int step;
int dx[5]={0,0,0,1,-1};
int dy[5]={1,-1,0,0,0};
bool is()
{
for(int i=1;i<=4;i++)
for(int j=1;j<=4;j++)
{
if(map[i][j]!=map[1][1])
return false;
}
return true;
}
void flip(int r,int c)
{
for(int i=0;i<5;i++)
{
int x=r+dx[i];
int y=c+dy[i];
map[x][y]=!map[x][y];
}
}
void dfs(int r,int c,int s)
{
if(s==step)
{
flag=is();
return ;
}
if(flag||r==5) return ;//一行一行进行枚举
flip(r,c);//如果r,c进行翻转,步数加一
if(c<4)
dfs(r,c+1,s+1);
else
dfs(r+1,1,s+1);
flip(r,c);//如果r,c处不翻转,就枚举下一个,flip要再用一次
if(c<4)
dfs(r,c+1,s);
else
dfs(r+1,1,s);
}
int main()
{
char c;
memset(map,false,sizeof(map));
flag=false;
for(int i=1;i<=4;i++)
for(int j=1;j<=4;j++)
{
cin>>c;
if(c=='b')
map[i][j]=true;
}
for(step=0;step<=16;step++)
{
dfs(1,1,0);
if(flag) break;
}
if(flag) cout<<step<<endl;
else cout<<"Impossible"<<endl;
return 0;
}

最新文章

  1. MySql操作
  2. php 5.3新增的闭包语法介绍function() use() {}
  3. Nodejs 之Ajax的一个实例(sql单条件查询&amp;并显示在Browser端界面上)
  4. HTML &lt;base&gt; 标签 为页面上的所有链接规定默认地址或默认目标
  5. Sublime Text怎么在切分两行视口内显示同一个文件
  6. ruby中http请求方法整理
  7. javascript权威指南笔记--javascript语言核心(六)
  8. 安装ArchLinux BIOS
  9. Hbase对hive的支持没有hdfs的好的原因 及hbase什么时候使用 及rowkey设计技巧
  10. linux enable命令学习
  11. Android-版本与api对应关系图
  12. R0:前瞻
  13. php学习之道:php中soap的使用实例以及生成WSDL文件,提供自己主动生成WSDL文件的类库——SoapDiscovery.class.php类
  14. nginx知识点简单回顾
  15. 基于vue,打印机打印暂且处理
  16. pwnable.tw dubblesort 分析
  17. 使用selenium时,使用从系统启动浏览器与通过自动化驱动方式启动浏览器控件ID不一样解决方法
  18. PairWork-电梯调度程序结对编程
  19. OpenJudge 求重要逆序对数
  20. NPM的正确使用方式

热门文章

  1. html5——动画案例(无缝滚动)
  2. ie 浏览器下ajax请求来自缓存的解决方法
  3. nexus3的安装和使用
  4. Linux下的find命令
  5. C#学习笔记_10_设计模式&amp;继承&amp;多态
  6. 【LeetCode Weekly Contest 26 Q2】Longest Uncommon Subsequence II
  7. mybatis源码阅读-初始化过程(七)
  8. 怎么去掉Word文字下面的波浪线
  9. DOM对象属性(property)与HTML标签特性(attribute)
  10. [bzoj3676]回文串[后缀数组+Manacher]