Description

If a and d are relatively prime positive integers, the arithmetic sequence beginning with a and increasing by d, i.e., aa + da + 2da + 3da +
4d, ..., contains infinitely many prime numbers. This fact is known as Dirichlet's Theorem on Arithmetic Progressions, which had been conjectured by Johann Carl Friedrich Gauss (1777 - 1855) and was proved by Johann Peter Gustav Lejeune Dirichlet
(1805 - 1859) in 1837.

For example, the arithmetic sequence beginning with 2 and increasing by 3, i.e.,

2, 5, 8, 11, 14, 17, 20, 23, 26, 29, 32, 35, 38, 41, 44, 47, 50, 53, 56, 59, 62, 65, 68, 71, 74, 77, 80, 83, 86, 89, 92, 95, 98, ... ,

contains infinitely many prime numbers

2, 5, 11, 17, 23, 29, 41, 47, 53, 59, 71, 83, 89, ... .

Your mission, should you decide to accept it, is to write a program to find the nth prime number in this arithmetic sequence for given positive integers ad, and n.

Input

The input is a sequence of datasets. A dataset is a line containing three positive integers ad, and n separated by a space. a and d are relatively prime. You may assume a <= 9307, d <= 346,
and n <= 210.

The end of the input is indicated by a line containing three zeros separated by a space. It is not a dataset.

Output

The output should be composed of as many lines as the number of the input datasets. Each line should contain a single integer and should never contain extra characters.

The output integer corresponding to a dataset adn should be the nth prime number among those contained in the arithmetic sequence beginning with aand increasing by d.

FYI, it is known that the result is always less than 106 (one million) under this input condition.

Sample Input

367 186 151
179 10 203
271 37 39
103 230 1
27 104 185
253 50 85
1 1 1
9075 337 210
307 24 79
331 221 177
259 170 40
269 58 102
0 0 0

Sample Output

92809
6709
12037
103
93523
14503
2
899429
5107
412717
22699
25673
#include <iostream>
#include <cmath>
using namespace std;
bool ss(int x)
{
if(x < 2)
return 0;
else
{
for(int i = 2; i <= sqrt((float)x); i++)
if(x % i == 0)
return 0;
return 1;
}
} int main()
{
int a, d, n;
while (cin>>a>>d>>n)
{
if (a==d&&d==n&&n==0)
{
return 0;
}
int i, count = 0;
for (i = a; count < n; i += d) {
if (ss(i))
{
count++;
}
}
cout<<i-d<<endl;
}
return 0;
}

最新文章

  1. Shelve Instance 操作详解 - 每天5分钟玩转 OpenStack(38)
  2. 第11章 .NET Remoting
  3. 【转】GeoHash核心原理解析
  4. 查看oracle SID
  5. Maven Installation
  6. 使用 http://httpbin.org/ 验证代理地址
  7. ue4玄学画面设置实现
  8. 获取token之后,再调用匿名方法
  9. jstl 中 &lt;c:foreach&gt; 多级循环
  10. JavaScript函数(二)
  11. 1.3创建项目「深入浅出ASP.NET Core系列」
  12. ArcGIS 卷帘效果
  13. oracle 9i/10gR2所有版本下载地址
  14. FastAdmin 的前端环境怎么安装?
  15. std::sort运行出core(segment fault)
  16. APP H5页面显示优化
  17. iOS:文件归档和解归档的详解和使用
  18. ios学习杂记
  19. OC报错,after command failed: Directory not empty
  20. display:flex 布局之 骰子

热门文章

  1. 框架,表格,表单元素,css基础以及基本标签的结合
  2. 【转】什么是P问题、NP问题和NPC问题
  3. C - Queue at the School
  4. maven使用杂记
  5. Android应用优化之代码检测优化
  6. TensorFlow-LSTM序列预测
  7. Promise API 简介
  8. wordpress插件推荐
  9. Android GoogleMap 谷歌地图从零开始
  10. Sublime Text3 插件记录