描述
Background

The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey

around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board,
but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem

Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
输入
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26.
This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
输出
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits
all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.

If no such path exist, you should output impossible on a single line.
样例输入

3
1 1
2 3
4 3

样例输出

Scenario #1:
A1 Scenario #2:
impossible Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

题目大意:给定棋盘长和宽,一马从左上角开始,问能否遍历棋盘,如果能,输出字典序最小的路径,如果不能,输出“impossible”

这道题很像马走日(我的博客里有),只是要输出路径,还要字典序最小的,所以要注意这匹马优先选择的走法,其他没什么难度

代码如下:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int k,m,n,w[8]={-1,1,-2,2,-2,2,-1,1},u[8]={-2,-2,-1,-1,1,1,2,2};//注意这里的优先选择路径
int a[1001][2];
int v[100][100];
bool check(int x,int y)
{
if(x>=1&&x<=m&&y>=1&&y<=n&&!v[x][y])
return 1;
return 0;
}
void find(int x,int y,int s)
{
int i;
if(k==0)
{
a[s][0]=x;
a[s][1]=y;
if(s==m*n)
{
k=1;
return;
}
}
for(i=0;i<8;i++)
if(check(x+w[i],y+u[i]))
{
v[x][y]=1;
find(x+w[i],y+u[i],s+1);
v[x][y]=0;
}
}
int main()
{
int i,j,p;
scanf("%d",&p);
for(i=0;i<p;i++)
{
k=0;
scanf("%d%d",&m,&n);
find(1,1,1);
printf("Scenario #%d:\n",i+1);
if(k==0)
printf("impossible\n\n");
else
{
for(j=1;j<=m*n;j++)
printf("%c%d",a[j][1]+64,a[j][0]);
printf("\n\n");
}
}
}

难度不大,注意细节

最新文章

  1. WPF学习之路(二) XAML
  2. C# 委托和Lambda---基础
  3. TargetProcess公司敏捷开发历程-开发实践篇
  4. HDFS的Java客户端操作代码(HDFS的查看、创建)
  5. String的equals方法和==
  6. Less的内置函数
  7. git Remote: HTTP Basic: Access denied Git failed with a fatal error.
  8. 基准对象object中的基础类型----列表 (四)
  9. AndroidS软件代码提示
  10. react之异步请求数据,render先行渲染报错,未拿到数据
  11. 《mysql必知必会》学习_第10章_20180731_欢
  12. LeetCode(19):删除链表的倒数第N个节点
  13. dSploitzANTI渗透教程之启动zANTI工具
  14. C 指针使用误区
  15. linux-一篇文章完成lnmp环境的编译安装
  16. 国外10个ASP.Net C#下的开源CMS
  17. Qt5 界面中文乱码问题
  18. Java==与equals方法的区别
  19. PHP的htmlspecialchars、strip_tags、addslashes解释
  20. Comparison of programming paradigms

热门文章

  1. 转 最近5年183个Java面试问题列表及答案[最全]
  2. buerdepepeqi 的模版
  3. Channel 9视频整理【3】
  4. Hadoop Authentication
  5. Linux 安装 Nvidia 驱动出现的黑屏各种问题和解决方式
  6. QTableWiget的简单使用
  7. 【题解】有标号的DAG计数3
  8. 【C++】几个简单课本例题
  9. 01_elementUI tree 插件 去图标
  10. Python 处理Excel内的数据(案例介绍*2)