Rescue


Time Limit: 2 Seconds      Memory Limit: 65536 KB


Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must
kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

Input

First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL
has to stay in the prison all his life."

Sample Input

7 8 

#.#####. 

#.a#..r. 

#..#x... 

..#..#.# 

#...##.. 

.#...... 

........

Sample Output

13

广度优先搜索找最短时间。

看代码凝视吧

#include <stdio.h>
#include <queue>
#include <string.h>
using namespace std;
struct node
{
int x,y,time;//x,y方格的位置。time当前全部的时间
friend bool operator<(node a,node b)//优先队列依照时间大小排序
{
return a.time>b.time;
}
};
priority_queue<node>s;
char map[205][205];//地图
int m,n,vis[205][205],escape,dir[4][2]={0,1,0,-1,1,0,-1,0};//vis标记,dir表示四个方向
bool judge(int x,int y)//推断当前位置时候能够走
{
if(x>=0&&y>=0&&x<n&&y<m&&!vis[x][y]&&map[x][y]!='#')
return true;
else
return false;
}
int tonum(int x,int y)//把对应的道路,警卫换算成时间
{
if(map[x][y]=='x')
return 2;
else
return 1;
}
void bfs(int x,int y)//广度优先搜索
{
node temp,temp1;
temp.time=0,temp.x=x,temp.y=y;
vis[x][y]=1;
s.push(temp);//把temp入队列
while(!s.empty())
{
temp=s.top(),s.pop();
temp1=temp;
if(map[temp.x][temp.y]=='a')//提前结束循环,由于用的优先队列。所以当前找到的肯定是最小的
{
escape=temp.time;
break;
}
for(int i=0;i<4;i++)
{
int xx=temp.x+dir[i][0];
int yy=temp.y+dir[i][1];
if(judge(xx,yy))
{
vis[xx][yy]=1;//当前位置已浏览 标记为1
temp.x=xx,temp.y=yy,temp.time=temp.time+tonum(xx,yy);
s.push(temp);//更新队列
}
temp=temp1;//由于才推断了一个方向。所以还须要temp1保持上次的位置
}
}
}
int main()
{
while(scanf("%d %d",&n,&m)!=EOF)
{
escape=0;
memset(vis,0,sizeof(vis));
memset(map,0,sizeof(map));
for(int i=0;i<n;i++)
scanf("%s",map[i]);
for(int i=0;i<n;i++)
for(int j=0;j<m;j++)
if(map[i][j]=='r')
{
bfs(i,j);
break;
}
if(escape)
printf("%d\n",escape);
else
printf("Poor ANGEL has to stay in the prison all his life.\n");
while(!s.empty())//一定要记得清队列。 。刚刚wa了一次
s.pop();
}
}

最新文章

  1. redis-cli中那些或许我们还不知道的一些实用小功能
  2. NodeJs - 序列化
  3. Java中的数组操作进阶
  4. 键盘--android 隐藏系统键盘
  5. ASP.NET MVC5 入门
  6. 基于Linux的oracle数据库管理 part1( 准备及linux基础 )
  7. poj 3608 旋转卡壳求不相交凸包最近距离;
  8. Android数据库信息显示在listview上
  9. CC版本添加 LUCI
  10. JavaScript代码规范和性能整理
  11. 深入了解Android蓝牙Bluetooth——《基础篇》
  12. Python伊始——From Boring to Amazing
  13. vscode c++ cmake template project
  14. Mybatis关联一对多映射不能查询出所有的数据的问题
  15. 2.静态AOP实现-装饰器模式
  16. mybatis学习系列四--mybatis generator逆向工程
  17. 【洛谷】1600:天天爱跑步【LCA】【开桶】【容斥】【推式子】
  18. Android高级控件(下)
  19. Split Array into Consecutive Subsequences
  20. Android异步载入学习笔记之四:利用缓存优化网络载入图片及ListView载入优化

热门文章

  1. inline-block元素垂直对齐
  2. 刷题总结——Genghis Khan the Conqueror (hdu4126)
  3. How to use rowspan and colspan in tbody using datatable.js?
  4. react当中两种获取表单数据的方法
  5. 提高Java开发效率,Idea必装的几款插件
  6. idea如何设置类头注释和方法注释(带注释模板)
  7. hdu 1423 最长上升递增子序列
  8. Vijos P1404 遭遇战
  9. error LNK2001: unresolved external symbol __imp__WSAStartup@8 SOCKET(转)
  10. macro expand error