Nice boat

Time Limit: 30000/15000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 335    Accepted Submission(s): 159

Problem Description
There is an old country and the king fell in love with a devil. The devil always asks the king to do some crazy things. Although the king used to be wise and beloved by his people. Now he is just like a boy in love and can’t refuse any request from the devil.
Also, this devil is looking like a very cute Loli.



Let us continue our story, z*p(actually you) defeat the 'MengMengDa' party's leader, and the 'MengMengDa' party dissolved. z*p becomes the most famous guy among the princess's knight party. 



One day, the people in the party find that z*p has died. As what he has done in the past, people just say 'Oh, what a nice boat' and don't care about why he died.



Since then, many people died but no one knows why and everyone is fine about that. Meanwhile, the devil sends her knight to challenge you with Algorithm contest.



There is a hard data structure problem in the contest:



There are n numbers a_1,a_2,...,a_n on a line, everytime you can change every number in a segment [l,r] into a number x(type 1), or change every number a_i in a segment [l,r] which is bigger than x to gcd(a_i,x) (type 2).



You should output the final sequence.
 
Input
The first line contains an integer T, denoting the number of the test cases.

For each test case, the first line contains a integers n.

The next line contains n integers a_1,a_2,...,a_n separated by a single space.

The next line contains an integer Q, denoting the number of the operations.

The next Q line contains 4 integers t,l,r,x. t denotes the operation type.



T<=2,n,Q<=100000

a_i,x >=0

a_i,x is in the range of int32(C++)
 
Output
For each test case, output a line with n integers separated by a single space representing the final sequence.

Please output a single more space after end of the sequence
 
Sample Input
1
10
16807 282475249 1622650073 984943658 1144108930 470211272 101027544 1457850878 1458777923 2007237709
10
1 3 6 74243042
2 4 8 16531729
1 3 4 1474833169
2 1 8 1131570933
2 7 9 1505795335
2 3 7 101929267
1 4 10 1624379149
2 2 8 2110010672
2 6 7 156091745
1 2 5 937186357
 
Sample Output
16807 937186357 937186357 937186357 937186357 1 1 1624379149 1624379149 1624379149
 
Author
WJMZBMR
 
Source
 
Recommend
 


代码例如以下:
#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
#include <queue>
#include <stack>
#include <string>
#include <iostream>
#include <set>
using namespace std;
const int MAX= 1e5+10;
const int inf = 0x3f3f3f3f;
const int MOD = 1e9+10;
const double eps= 1e-8;
typedef long long LL ;
typedef vector<int> vec;
typedef vector<vec> mat; LL gcd(LL a,LL b) {
return b==0?a:gcd(b,a%b);
} LL ans[MAX<<2],col[MAX<<2],a[MAX]; inline void push_up(int o) {
if(col[o<<1]==col[o<<1|1]) col[o]=col[o<<1];
}
inline void push_down(int o) {
if( col[o]!=-1) {
col[o<<1]=col[o<<1|1]=col[o];
col[o]=-1;
}
return ;
}
void build(int L,int R,int o) {
col[o]=-1;
if(L==R) {
col[o]=a[L];
return ;
}
int mid=(L+R)>>1;
build(L,mid,o<<1);
build(mid+1,R,o<<1|1);
push_up(o);
} void modify1(int L,int R,int o,int ls,int rs,LL x) {
if(ls<=L&&rs>=R) {
col[o]=x;
return ;
}
push_down(o);
int mid=(L+R)>>1;
if(ls<=mid) modify1(L,mid,o<<1,ls,rs,x);
if(rs>mid) modify1(mid+1,R,o<<1|1,ls,rs,x);
push_up(o);
}
void modify2(int L,int R,int o,int ls,int rs,LL x) {
if(ls<=L&&rs>=R&&col[o]!=-1) {
if(col[o]>x) {
col[o]=gcd(col[o],x);
}
return ;
}
push_down(o);
int mid=(L+R)>>1;
if(ls<=mid) modify2(L,mid,o<<1,ls,rs,x);
if(rs>mid) modify2(mid+1,R,o<<1|1,ls,rs,x);
push_up(o);
}
LL Query(int L,int R,int o,int k) {
if(L==R) {
return col[o];
}
push_down(o);
int mid=(L+R)>>1;
if(k<=mid) return Query(L,mid,o<<1,k);
else return Query(mid+1,R,o<<1|1,k);
}
int main() {
//freopen("in.txt","r",stdin);
int cas,n,op,ls,rs,m;
LL x;
scanf("%d",&cas);
while(cas--) {
scanf("%d",&n);
for(int i=1;i<=n;i++) scanf("%I64d",&a[i]);
build(1,n,1);
scanf("%d",&m);
for(int i=0;i<m;i++) {
scanf("%d %d %d %I64d",&op,&ls,&rs,&x);
if(op==1) {
modify1(1,n,1,ls,rs,x);
}
else modify2(1,n,1,ls,rs,x);
} for(int i=1;i<=n;i++) {
// if(i==1) printf("%I64d",Query(1,n,1,i));
printf("%I64d ",Query(1,n,1,i));
}
printf("\n");
//printf(" ");
}
return 0;
}

最新文章

  1. js从数组中随机取出不同的元素
  2. servlet--转向forward与重定向
  3. Solr4.8.0源码分析(22)之SolrCloud的Recovery策略(三)
  4. jQuery ui 利用 datepicker插件实现开始日期(minDate)和结束日期(maxDate)
  5. Copy xml 文件
  6. hdu1069(dp)
  7. CSV文件解析工具
  8. (简单) POJ 1511 Invitation Cards,SPFA。
  9. 如何解决“BPM导入组织架构出现问题导致系统无法登陆”
  10. DevOps之唠叨话
  11. JGUI源码:DataTable固定列样式(20)
  12. 详解原生JS回到顶部
  13. deepin配置Oracle JDK
  14. Luogu P3600 随机数生成器(期望+dp)
  15. WPF Image控件的绑定
  16. MySQL实现排名并查询指定用户排名功能
  17. 力扣(LeetCode)461. 汉明距离
  18. jdk8-lambda表达式的使用
  19. ssm整合各配置文件
  20. LD_PRELOAD的偷梁换柱之能

热门文章

  1. 01-hibernate注解:类级别注解,@Entity,@Table,@Embeddable
  2. 准备你的Adempiere开发环境(2)- 安装
  3. MVC中Area的另一种用法
  4. linux释放内存命令
  5. 使用PHP创建一个REST API(Create a REST API with PHP)
  6. Redis(三):windows下Redis的安装配置以及注意事项
  7. spring 多个数据库之间切换
  8. Hbase系列-Hbase简介
  9. 在drop user之前,建议获取该用户的依赖情况
  10. zoj 1109 Language of FatMouse(字典树)