https://www.luogu.org/problem/show?pid=2865

题目描述

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

贝茜把家搬到了一个小农场,但她常常回到FJ的农场去拜访她的朋友。贝茜很喜欢路边的风景,不想那么快地结束她的旅途,于是她每次回农场,都会选择第二短的路径,而不象我们所习惯的那样,选择最短路。 贝茜所在的乡村有R(1<=R<=100,000)条双向道路,每条路都联结了所有的N(1<=N<=5000)个农场中的某两个。贝茜居住在农场1,她的朋友们居住在农场N(即贝茜每次旅行的目的地)。 贝茜选择的第二短的路径中,可以包含任何一条在最短路中出现的道路,并且,一条路可以重复走多次。当然咯,第二短路的长度必须严格大于最短路(可能有多条)的长度,但它的长度必须不大于所有除最短路外的路径的长度。

输入输出格式

输入格式:

Line 1: Two space-separated integers: N and R

Lines 2..R+1: Each line contains three space-separated integers: A, B, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)

输出格式:

Line 1: The length of the second shortest path between node 1 and node N

输入输出样例

输入样例#1:

4 4
1 2 100
2 4 200
2 3 250
3 4 100
输出样例#1:

450

说明

Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)

边可以重复走

严格次短路

A* 算法求第二短

#include<queue>
#include<cstdio>
#include<cstring>
#define N 5001
#define M 200001
using namespace std;
int n,s,t;
int dis1[N];
bool vis[N];
int front[N],to[M],nxt[M],val[M],tot;
struct node
{
int num,dis;
bool operator < (node p) const
{
return dis+dis1[num]>p.dis+dis1[p.num];
}
}now,nt;
void add(int u,int v,int w)
{
to[++tot]=v; nxt[tot]=front[u]; front[u]=tot; val[tot]=w;
to[++tot]=u; nxt[tot]=front[v]; front[v]=tot; val[tot]=w;
}
void init()
{
int m,u,v,w;
scanf("%d%d",&n,&m);
while(m--)
{
scanf("%d%d%d",&u,&v,&w);
add(u,v,w);
}
}
void spfa()
{
memset(dis1,,sizeof(dis1));
queue<int>q;
dis1[n]=;
vis[n]=true;
q.push(n);
int now;
while(!q.empty())
{
now=q.front();
q.pop();
vis[now]=false;
for(int i=front[now];i;i=nxt[i])
if(dis1[to[i]]>dis1[now]+val[i])
{
dis1[to[i]]=dis1[now]+val[i];
if(!vis[to[i]])
{
q.push(to[i]);
vis[to[i]]=true;
}
}
}
}
void Astar()
{
if(dis1[]>1e9)
{
printf("-1");
return;
}
int cnt=,last=-;
priority_queue<node>q;
now.num=;
now.dis=;
q.push(now);
while(!q.empty())
{
now=q.top();
q.pop();
if(now.num==n)
{
cnt++;
if(cnt> && now.dis!=last)
{
printf("%d",now.dis);
return;
}
else last=now.dis;
}
for(int i=front[now.num];i;i=nxt[i])
{
nt.num=to[i];
nt.dis=now.dis+val[i];
q.push(nt);
}
}
printf("-1");
}
int main()
{
init();
spfa();
Astar();
}

最新文章

  1. OleDb Source component 用法
  2. import pysam 出错解决办法
  3. 使用delphi+intraweb进行微信开发5—准备实现微信API,先从获取AccessToken开始
  4. HDU5853 Jong Hyok and String(二分 + 后缀数组)
  5. IIS 7.5 + asp.net MVC4 设置路由处理URL请求
  6. ecshop退出登录会清空购物车的bug优化,最完美解决方法
  7. Android安全相关书籍汇总
  8. JDOM
  9. js setInterval和clearInterval 的使用
  10. ASE中的主要数据库
  11. LeetCode 543. Diameter of Binary Tree (二叉树的直径)
  12. XCode使用技巧
  13. [转] How Bill Gates read books
  14. Linux 6.8 源码安装MySQL8.0
  15. GTF文件
  16. csu oj 1344: Special Judge
  17. scala变量类型和性质
  18. metasploit framework(四):生成payload
  19. [FreeMind] 绘制思维时遇到的常见问题解决办法
  20. Beta阶段——Scrum 冲刺博客第二天

热门文章

  1. 团队协作第八周个人PSP
  2. sql update limit1
  3. Generating a PDF in Codeigniter using mPDF
  4. .net 简体转换繁体实例,繁体转换简体 Encode.dll、下载
  5. alpha阶段个人总结(201521123034陈凯欣)
  6. open-stf 安装篇(linux)
  7. 使用gdb查看栈帧的情况, 没有ebp
  8. zoj3209-Treasure Map
  9. BZOJ 1491 社交网络(最短路)
  10. datepicker约束开始时间和结束时间