题目背景

题目描述:

每天,农夫 John 的N(1 <= N <= 50,000)头牛总是按同一序列排队. 有一天, John 决定让一些牛们玩一场飞盘比赛. 他准备找一群在对列中为置连续的牛来进行比赛. 但是为了避免水平悬殊,牛的身高不应该相差太大. John 准备了Q (1 <= Q <= 180,000) 个可能的牛的选择和所有牛的身高 (1 <= 身高 <= 1,000,000). 他想知道每一组里面最高和最低的牛的身高差别.

输入:

第1行:N,Q

第2到N+1行:每头牛的身高

第N+2到N+Q+1行:两个整数A和B,表示从A到B的所有牛。(1<=A<=B<=N)

输出:

输出每行一个数,为最大数与最小数的差

题目描述

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

一个农夫有N头牛,每头牛的高度不同,我们需要找出最高的牛和最低的牛的高度差。

输入输出格式

输入格式:

Line 1: Two space-separated integers, N and Q.

Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i

Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

输出格式:

Lines 1..Q: Each line contains a single integer that is a
response to a reply and indicates the difference in height between the
tallest and shortest cow in the range.

输入输出样例

输入样例#1:
复制

6 3
1
7
3
4
2
5
1 5
4 6
2 2
输出样例#1: 复制

6
3
0
线段树维护区间 max min 即可
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstdlib>
#include<cstring>
#include<string>
#include<cmath>
#include<map>
#include<set>
#include<vector>
#include<queue>
#include<bitset>
#include<ctime>
#include<deque>
#include<stack>
#include<functional>
#include<sstream>
//#include<cctype>
//#pragma GCC optimize("O3")
using namespace std;
#define maxn 500005
#define inf 0x3f3f3f3f
#define INF 9999999999
#define rdint(x) scanf("%d",&x)
#define rdllt(x) scanf("%lld",&x)
#define rdult(x) scanf("%lu",&x)
#define rdlf(x) scanf("%lf",&x)
#define rdstr(x) scanf("%s",x)
typedef long long ll;
typedef unsigned long long ull;
typedef unsigned int U;
#define ms(x) memset((x),0,sizeof(x))
const long long int mod = 1e9 + 7;
#define Mod 1000000000
#define sq(x) (x)*(x)
#define eps 1e-3
typedef pair<int, int> pii;
#define pi acos(-1.0)
//const int N = 1005;
#define REP(i,n) for(int i=0;i<(n);i++)
typedef pair<int, int> pii;
inline ll rd() {
ll x = 0;
char c = getchar();
bool f = false;
while (!isdigit(c)) {
if (c == '-') f = true;
c = getchar();
}
while (isdigit(c)) {
x = (x << 1) + (x << 3) + (c ^ 48);
c = getchar();
}
return f ? -x : x;
} ll gcd(ll a, ll b) {
return b == 0 ? a : gcd(b, a%b);
}
ll sqr(ll x) { return x * x; } /*ll ans;
ll exgcd(ll a, ll b, ll &x, ll &y) {
if (!b) {
x = 1; y = 0; return a;
}
ans = exgcd(b, a%b, x, y);
ll t = x; x = y; y = t - a / b * y;
return ans;
}
*/ ll qpow(ll a, ll b, ll c) {
ll ans = 1;
a = a % c;
while (b) {
if (b % 2)ans = ans * a%c;
b /= 2; a = a * a%c;
}
return ans;
} int n, m;
struct node {
int l, r;
int maxx, minn;
}tree[maxn]; void pushup(int rt) {
tree[rt].maxx = max(tree[rt << 1].maxx, tree[rt << 1 | 1].maxx);
tree[rt].minn = min(tree[rt << 1].minn, tree[rt << 1 | 1].minn);
} void build(int l, int r, int rt) {
tree[rt].l = l; tree[rt].r = r;
if (l == r) {
int x; rdint(x); tree[rt].maxx = tree[rt].minn = x;
return;
}
int mid = (l + r) >> 1;
build(l, mid, rt << 1); build(mid + 1, r, rt << 1 | 1);
pushup(rt);
} int query1(int L, int R, int rt) {
if (L <= tree[rt].l&&tree[rt].r <= R) {
return tree[rt].maxx;
}
int mid = (tree[rt].l + tree[rt].r) >> 1;
int ans = -inf;
if (L <= mid)ans = max(ans, query1(L, R, rt << 1));
if (mid < R)ans = max(ans, query1(L, R, rt << 1 | 1));
return ans;
} int query2(int L, int R, int rt) {
if (L <= tree[rt].l&&tree[rt].r <= R) {
return tree[rt].minn;
}
int mid = (tree[rt].l + tree[rt].r) >> 1;
int ans = inf;
if (L <= mid)ans = min(ans, query2(L, R, rt << 1));
if (mid < R)ans = min(ans, query2(L, R, rt << 1 | 1));
return ans;
} int main()
{
//ios::sync_with_stdio(0);
rdint(n); rdint(m);
build(1, n, 1);
while (m--) {
int a, b; rdint(a); rdint(b);
cout << query1(a, b, 1) - query2(a, b, 1) << endl;
}
return 0;
}

最新文章

  1. td在relative模式下,IE9不显示border
  2. Android——手机内部文件存储(作业)
  3. 高层次综合(HLS)-简介
  4. Ubuntu关闭图形界面
  5. 1509: [NOI2003]逃学的小孩 - BZOJ
  6. 第十一篇、RxSwift
  7. poj 1654 Area(多边形面积)
  8. db4o官方停止支持及面向对象数据库的一些感想
  9. WndPric的使用方法
  10. Tango_with_django_17笔记
  11. tastypie Django REST framework API [Hello JSON]
  12. NLog在MVC中使用
  13. 完整CentOS搭建OpenVPN服务详细教程
  14. View体系之属性动画
  15. [LeetCode] 96. Unique Binary Search Trees(给定一个数字n,有多少个唯一二叉搜索树) ☆☆☆
  16. 项目报错:Caused by: java.lang.ClassNotFoundException: Didn&#39;t find class &quot;...&quot;on path: DexPathList
  17. python---django中orm的使用(1)
  18. Ubuntu登录Windows Server 2008r2 密码总是错误与NLA验证
  19. BZOJ.2194.快速傅立叶之二(FFT 卷积)
  20. Android 升级脚本updater-script 的函数简单介绍

热门文章

  1. 发RTX通知
  2. PDM/CDM中进行搜索
  3. List的使用1(两张表或者一张表的自身关系)
  4. Python的IDE:Eclipse+PyDev配置
  5. iOS 给Main.storyboard 添加button 事件《转》
  6. iter创建一个可以被迭代的对象
  7. 【总结整理】关于ArcGIS中拓扑的理解
  8. php中定义数组的方法
  9. Redis了解
  10. pentaho和spark-sql对接