http://acm.hdu.edu.cn/showproblem.php?pid=4763

Theme Section

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2129    Accepted Submission(s): 997

Problem Description
It's time for music! A lot of popular musicians are invited to join us in the music festival. Each of them will play one of their representative songs. To make the programs more interesting and challenging, the hosts are going to add some constraints to the rhythm of the songs, i.e., each song is required to have a 'theme section'. The theme section shall be played at the beginning, the middle, and the end of each song. More specifically, given a theme section E, the song will be in the format of 'EAEBE', where section A and section B could have arbitrary number of notes. Note that there are 26 types of notes, denoted by lower case letters 'a' - 'z'.

To get well prepared for the festival, the hosts want to know the maximum possible length of the theme section of each song. Can you help us?

 
Input
The integer N in the first line denotes the total number of songs in the festival. Each of the following N lines consists of one string, indicating the notes of the i-th (1 <= i <= N) song. The length of the string will not exceed 10^6.
 
Output
There will be N lines in the output, where the i-th line denotes the maximum possible length of the theme section of the i-th song.
 
Sample Input
5
xy
abc
aaa
aaaaba
aaxoaaaaa
 
Sample Output
0
0
1
1
2

就是找到一个 类似 EAEBE 这样的结构, 其中找到 E 最长为多少

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm> using namespace std;
#define INF 0x3f3f3f3f
#define N 1000007 char s[N];
int Next[N]; void FindNext()
{
int i=, j=-;
int len = strlen(s); Next[] = -; while(i<len)
{
if(j==- || s[i]==s[j])
Next[++i] = ++j;
else
j = Next[j];
}
} bool KMP(int Start, int End)
{
int i=, j=Start;
/// i 是子串的开始, j 是母串的开始
/// 0~Start-1 是子串, Start~End-1 是母串,在母串中查找是否含有子串 while(i<Start && j<End)
{
while(i==- && (s[i]==s[j] && i<Start))
i++, j++; if(j==Start)
return true;
i = Next[i];
}
return false;
} int main()
{
int t;
scanf("%d", &t);
while(t--)
{
scanf("%s", s); FindNext(); int len = strlen(s); int j = len; while(Next[j]>)
{
/// next[j] 是最大前缀,就是母串的开始位置
/// 因为前缀也是后缀, 所以用总长度减后缀就是母串结束的位置
if(KMP(Next[j], len-Next[j])==true)
break;
j = Next[j];
} printf("%d\n", Next[j]);
}
return ;
}

最新文章

  1. 关于DOS与cmd(windows系统)
  2. Apache Server Status主机状态查看
  3. SQL Server 查出未提交事务(长事务)SQL
  4. iOS开发——高级技术&amp;通讯录功能的实现
  5. linux查看python安装路径,版本号
  6. Fat-tree 胖树交换网络
  7. Oracle数据库学习第一天
  8. 数据结构中La表的数据合并到Lb表中
  9. 无法打开物理文件mdf,操作系统错误 5:&amp;quot;5(拒绝訪问。)&amp;quot;
  10. iOS 相册和网络图片的存取
  11. python绘制图形(Turtle模块)
  12. (转载)CSS3与页面布局学习总结(三)——BFC、定位、浮动、7种垂直居中方法
  13. C# -Asp.Net.SignalR.Core之Hub
  14. revit二次开发addin文件
  15. entity framework core 2.0 &amp; sqlite 配置教程
  16. mybatis批量更新数据参考
  17. 3月19 HTML静态网页的制作
  18. spring boot 入门一 构建spring boot 工程
  19. Systemd mysql,nginx,php启动配置文件
  20. window server 搭建git服务器

热门文章

  1. check_http检查http服务
  2. IOS6新特性之下拉刷新&lt;UIRefreshControl&gt;
  3. all any some
  4. webrtc 开发之前必须了解的东西
  5. 索引与like优化
  6. A* 算法详解
  7. 在UNITY中按钮的高亮用POINT灯实现,效果别具一番风味
  8. word2003设置页码不从第一页开始的方法
  9. Golang之(if)流程控制
  10. MacOs安装mysql与修改root密码