LOOPS

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 125536/65536 K (Java/Others)

Total Submission(s): 4636    Accepted Submission(s): 1862

Problem Description
Akemi Homura is a Mahou Shoujo (Puella Magi/Magical Girl).



Homura wants to help her friend Madoka save the world. But because of the plot of the Boss Incubator, she is trapped in a labyrinth called LOOPS.




The planform of the LOOPS is a rectangle of R*C grids. There is a portal in each grid except the exit grid. It costs Homura 2 magic power to use a portal once. The portal in a grid G(r, c) will send Homura to the grid below G (grid(r+1, c)), the grid on the
right of G (grid(r, c+1)), or even G itself at respective probability (How evil the Boss Incubator is)!

At the beginning Homura is in the top left corner of the LOOPS ((1, 1)), and the exit of the labyrinth is in the bottom right corner ((R, C)). Given the probability of transmissions of each portal, your task is help poor Homura calculate the EXPECT magic power
she need to escape from the LOOPS.








 
Input
The first line contains two integers R and C (2 <= R, C <= 1000).



The following R lines, each contains C*3 real numbers, at 2 decimal places. Every three numbers make a group. The first, second and third number of the cth group of line r represent the probability of transportation to grid (r, c), grid (r, c+1), grid (r+1,
c) of the portal in grid (r, c) respectively. Two groups of numbers are separated by 4 spaces.



It is ensured that the sum of three numbers in each group is 1, and the second numbers of the rightmost groups are 0 (as there are no grids on the right of them) while the third numbers of the downmost groups are 0 (as there are no grids below them).



You may ignore the last three numbers of the input data. They are printed just for looking neat.



The answer is ensured no greater than 1000000.



Terminal at EOF




 
Output
A real number at 3 decimal places (round to), representing the expect magic power Homura need to escape from the LOOPS.


 
Sample Input
2 2
0.00 0.50 0.50 0.50 0.00 0.50
0.50 0.50 0.00 1.00 0.00 0.00
 
Sample Output
6.000
 
—————————————————————————————————————————————————————————————————————————————
本题为概率dp的入门题,题目的意思是计算从(1,1)到(r,c)的期望。
题目给出了个r*c的矩阵,在每个点,你都可能不动或向下或向右移动,概率分别为p1,p2,p3,每步消耗2。
我们设dp[i][j]为从(i,j)到(r,c)的期望;
首先很容易知道dp[r][c]=0;
其他各个点为dp[i][j]=2+p1[i]j[]*dp[i][j]p2[i][j]*dp[i][j+1]+p3[i][j]*dp[i+1][j])
移项后即dp[i][j]=(2+p2[i][j]*dp[i][j+1]+p3[i][j]*dp[i+1][j])/(1-p1[i][j]);




代码如下:




#include<iostream>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
double p1[1005][1005],p2[1005][1005],p3[1005][1005],dp[1005][1005];
int main()
{
int r,c;
while(~scanf("%d%d",&r,&c))
{
for(int i=1;i<=r;i++)
for(int j=1;j<=c;j++)
scanf("%lf%lf%lf",&p1[i][j],&p2[i][j],&p3[i][j]);
dp[r][c]=0;
memset(dp,0,sizeof(dp));
for(int i=r;i>0;i--)
for(int j=c;j>0;j--)
{
if(i==r&&j==c)
continue;
if(p1[i][j]==1)//p1为1,原地不动该点期望为0;
{
dp[i][j]=0;
continue;
}
dp[i][j]=(2+p2[i][j]*dp[i][j+1]+p3[i][j]*dp[i+1][j])/(1-p1[i][j]);
} printf("%.3f\n",dp[1][1]);
}
return 0;
}

最新文章

  1. OBST(Optimal Binary Tree最优二叉搜索树)
  2. Android:理解Fragment
  3. 动态加载、移除、替换JS和CSS
  4. 20145236 《Java程序设计》课程总结
  5. Git的常用命令的使用方法和解释
  6. Spring注解和配置方式
  7. Visual Studio
  8. the service mysql56 was not found in the Windows services的解决办法
  9. bzoj1662: [Usaco2006 Nov]Round Numbers 圆环数
  10. [flask 优化] 由flask-bootstrap,flask-moment引起的访问速度慢的原因及解决办法
  11. hive数据类型及其数据转换
  12. 微信H5页面 会被软键盘顶起来
  13. SSRS表达式里引用.net dll
  14. 【worker】js中的多线程
  15. 移动端真机调试终极利器-BrowserSync(使用方法)
  16. CSS--使用伪选择器制作箭头图标
  17. JAVA基础知识总结:十七
  18. 江西财经大学第一届程序设计竞赛 H题 求大数的阶乘
  19. CSS3 :nth-child(n)使用注意
  20. 【ExtJs】 ExtJs4.2 基本表单组件的使用

热门文章

  1. 分页导航jsp
  2. oracle老是出现监听错误
  3. python文件的只读,只写操作
  4. dp-最长公共子序列
  5. Windows内置系统账户:Local system/Network service/Local Service 区别
  6. hdoj1114 Piggy-Bank(DP 完全背包)
  7. day5:vcp考试
  8. SQL2008清空日志文件
  9. git 常用命令笔记
  10. Maven 学习笔记(一) 基础环境搭建