1104. Sum of Number Segments (20)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CAO, Peng

Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence {0.1, 0.2, 0.3, 0.4}, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3,
0.4) (0.3) (0.3, 0.4) (0.4).

Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 105. The next line contains N positive numbers in the sequence, each no more than
1.0, separated by a space.

Output Specification:

For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.

Sample Input:

4
0.1 0.2 0.3 0.4

Sample Output:

5.00

直接计算每个数出现了几次
公式:i*(n-i+1)
#include <iostream>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>
#include <stdlib.h> using namespace std;
int n;
double x;
int main()
{
double ans;
scanf("%d",&n);
for(int i=1;i<=n;i++)
{
scanf("%lf",&x);
ans+=x*i*(n-i+1);
}
printf("%.2f\n",ans);
return 0;
}

最新文章

  1. 新手,Visual Studio 2015 配置Boost库,如何编译和选择,遇到无法打开文件“libboost_thread-vc140-mt-gd-1_63.lib“的解决办法
  2. ORACLE rowid切分大表
  3. AngularJS——grunt神器的安装
  4. iOS 基于UIWebView的应用特点
  5. loj 1013(LCS+记忆化搜索)
  6. 【BZOJ 3476】 线段树===
  7. Delphi WEB APP DEBUGGER是如何使用的
  8. has leaked ServiceConnection com.baidu.location.LocationClient
  9. 【 D3.js 入门系列 --- 9.6 】 生产的包图
  10. C# 3.0相比C# 2.0增加的功能
  11. 201521123010 《Java程序设计》第8周学习总结
  12. flask-日料网站搭建
  13. isolate demo
  14. JAVA中通过Jaxp操作XML文件基础
  15. Windows添加.NET Framework 3.0 NetFx3 失败 - 状态为:0x800f0950
  16. 第一个VS2015 Xaramin Android项目(续)
  17. linux 替换 sed命令 转载
  18. spring boot 配置双数据源mysql、sqlServer
  19. 常用数据库驱动名称以及URL
  20. hdu6199 gems gems gems dp+博弈

热门文章

  1. 查看linux系统某宏的定义(另类)
  2. php实现aes加密类
  3. Atitit.软件仪表盘(7)--温度监测子系统--电脑重要部件温度与监控and警报
  4. nginx源代码分析--GDB调试
  5. solr 简单搭建 数据库数据同步(待续)
  6. 管道相关函数(1)-pipe
  7. 每日英语:China Grapples With Genetically Modified Foods
  8. 使用JSTL的xml:parse标签(或者说x:parse)出现异常NoSuchMethodError,找不到doc的setter method
  9. Eclipse “cannot be resolved to a type” error
  10. hive 中与mysql 中函数同名不同意的方法记录