Train Problem I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 20521    Accepted Submission(s): 7712

Problem Description
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one
railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train
B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the
trains can get out in an order O2.

 
Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample
Input.
 
Output
The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of
the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
 
Sample Input
3 123 321
3 123 312
 
Sample Output
Yes.
in
in
in
out
out
out
FINISH
No.
FINISH
Hint
Hint
For the first Sample Input, we let train 1 get in, then train 2 and train 3.
So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.
In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.
Now we can let train 3 leave.
But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.
So we output "No.".
 
Author
Ignatius.L

栈的水题一道。就直接对进出栈进行模拟。和之前做的那道题类似,用来练练STL还是不错的,直接用STL水过。

http://blog.csdn.net/whjkm/article/details/38455291 能够看看之前的那道题。

用来vector 和 stack容器。用vector来存储字符串;

#include <cstdio>
#include <cstring>
#include <string>
#include <iostream>
#include <stack>
#include <vector>
using namespace std;
int main()
{
int n,i,j;
string str1,str2;
while(cin>>n>>str1>>str2)
{
stack<int>s;
vector<string>v;
for(i=0,j=0;i<n&&j<n;i++)
{
s.push(str1[i]);//把元素进栈
v.push_back("in");//压进vector容器
while(s.top()==str2[j])//进行匹配
{
if(!s.empty())
{
s.pop();
v.push_back("out");
}
j++;
if(s.empty()) break;
}
}
if(j==n)
{
printf("Yes.\n");
for(i=0; i< v.size();i++)
cout<< v[i] <<endl;
printf("FINISH\n");
}
else
printf("No.\nFINISH\n");
}
return 0;
}



最新文章

  1. 你所不知道的setTimeout
  2. 11月8日上午Jquery的基础语法、选取元素、操作元素、加事件、挂事件及移除事件
  3. python 类以及单例模式
  4. zoj 3725 - Painting Storages(动归)
  5. poj 2774 Long Long Message 后缀数组基础题
  6. PHP中文函数顺序排列一数组且其序数不变
  7. Groovy Spock环境的安装
  8. MFC开发上位机到底用Dialog结构还是文档结构?
  9. 从编辑距离、BK树到文本纠错
  10. Java连接数据库之SQLServer
  11. SSH整合时多表关联查询出现Javassist增强失败
  12. 洛谷P3600 随机数生成器(期望dp 组合数)
  13. Cyclic Components CodeForces - 977E(DFS)
  14. python对ftp进行操作
  15. 再次编译 arm toolchains
  16. sqlserver 2008 开启CLR
  17. 于erlang依赖的linux调优
  18. BZOJ4756:[USACO]Promotion Counting(线段树合并)
  19. VMware两台虚拟机之间文件共享
  20. ibatis 中#和 $ 符号的区别

热门文章

  1. Spring JavaConfig实例
  2. Java垃圾回收精粹 — Part3
  3. System.Threading.Tasks并发和异步代码使用
  4. [Android Memory] 使用 Eclipse Memory Analyzer 进行堆转储文件分析
  5. 从CVPR 2014看计算机视觉领域的最新热点
  6. django.db.utils.OperationalError: (1071, &#39;Specified key was too long; max key length is 767 bytes&#39;);
  7. nose的测试报告
  8. 多种非接触卡 ATQA 字节说明
  9. [置顶] JDK工具(零)--简要介绍JDK1.6自带的42个工具
  10. ExtJS ComboBox 录入智能提示