题目链接:

http://poj.org/problem?id=1564

题目:

Sum It Up
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 5839   Accepted: 2984

Description

Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t = 4, n = 6, and the list is [4, 3, 2, 2, 1, 1], then there are four different sums that equal 4: 4, 3+1, 2+2, and 2+1+1.
(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.

Input

The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x 1 , . . . , x n . If n = 0 it signals the end of the input; otherwise, t will be a
positive integer less than 1000, n will be an integer between 1 and 12 (inclusive), and x 1 , . . . , x n will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and
there may be repetitions.

Output

For each test case, first output a line containing `Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line `NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated
in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number
must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distinct; the same sum cannot appear twice.

Sample Input

4 6 4 3 2 2 1 1
5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0

Sample Output

Sums of 4:
4
3+1
2+2
2+1+1
Sums of 5:
NONE
Sums of 400:
50+50+50+50+50+50+25+25+25+25
50+50+50+50+50+25+25+25+25+25+25

Source

这个题目是典型的dfs。。

我认为基本的就是反复的数字不须要进行搜索了。由于已经搜索过了。否则会反复。。

当不满足条件时返回上一臣调用处。。

所以代码为:

#include<cstdio>
#include<cstdlib>
const int maxn=100+10;
int a[maxn],b[maxn];
int t,n,ok;
void dfs(int i,int j,int sum)
{
int k;
if(sum>t)
return;
if(sum==t)
{
printf("%d",b[1]);
for(k=2;k<j;k++)
printf("+%d",b[k]);
printf("\n");
ok=1;
return;
}
for(k=i;k<=n;k++)
{
b[j]=a[k];
dfs(k+1,j+1,sum+a[k]);
while(a[k]==a[k+1])
k++;
}
} int main()
{
int sum;
while(scanf("%d%d",&t,&n)!=EOF)
{
if(t==0&&n==0) return 0;
sum=0;
for(int i=1;i<=n;i++)
{
scanf("%d",&a[i]);
sum=sum+a[i];
}
printf("Sums of %d:\n",t);
ok=0;
if(sum<t)
{
printf("NONE\n");
continue;
}
else
dfs(1,1,0);
if(!ok)
printf("NONE\n");
}
return 0;
}

最新文章

  1. sql条件为空查询全部,不为空按条件查询以及多条件筛选查询。
  2. C++中 OOP相关的类型转换
  3. CSS 伪类 (Pseudo-classes)
  4. (Tree) 101. Symmetric Tree
  5. 高可用性、负载均衡的mysql集群解决方案
  6. SSAS:菜鸟笔记(一)基本思路及操作
  7. Git 版本管理
  8. Linux新手学堂 Crontab命令的语法
  9. 树莓派,使用opencv调用自带的摄像头
  10. php 单例设计模式 example
  11. 运行时修改TimerTask的执行周期
  12. Oracle 存储过程实例
  13. 隐藏tabBar页面跳转后会再布局一次,
  14. [Locked] Paint House I &amp; II
  15. mysql启动停止,一台服务器跑 多个mysql数据库
  16. 用友U8客户端连接不上服务器全攻略
  17. apache的用户认证
  18. HTTP响应头信息(Response Headers)与请求头信息(Request Headers)
  19. 字符串MD5加密运算
  20. 基于JavaMail向邮箱发送邮件

热门文章

  1. 解决Sqlserver 2008 R2在创建登录名出错&quot;此版本的 Microsoft Windows 不支持 MUST_CHANGE 选项。 (Microsoft SQL Server,错误: 15195)&quot;
  2. connect-proxy rpm文件的安装
  3. [Unity-6] GameObject有时候渲染不出来
  4. Missing styles. Is the correct theme chosen for this layout? Use the Theme combo box above the layou
  5. php之phpstorm入门
  6. Hibernate(四)结构-基础语义和事务
  7. JDBC一(web基础学习笔记七)
  8. Oracle体系结构一(学习笔记)
  9. servlet实现文件上传,预览,下载和删除
  10. Oracle单实例启动多个实例