Light Bulb


Time Limit: 1 Second      Memory Limit: 32768 KB

Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers Hh and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

Sample Input

3
2 1 0.5
2 0.5 3
4 3 4

Sample Output

1.000
0.750
4.000

Author: GUAN, Yao
Source: The 6th Zhejiang Provincial Collegiate Programming Contest

二分法作为分治中最常见的方法,适用于单调函数,逼近求解某点的值。但当函数是凸性函数时,二分法就无法适用,这时三分法就可以“大显身手”~

如图,类似二分的定义Left和Right,mid = (Left + Right) / 2,midmid = (mid + Right) / 2;

如果mid靠近极值点,则Right = midmid;否则(即midmid靠近极值点),则Left = mid;

模版如下:

int Cale(int  ){

}

int Solve(int left ,int right){
int mid,midmid;
while(left<right){
mid=(left+right)/;
midmid=(mid+right)/;
if(Cale(mid) > Cale(midmid))
right=midmid;///////假设求最大值
else
left=mid;
}
return left;
}

如图,人左右走动,求影子L的最长长度。根据图,很容易发现当灯,人的头部和墙角成一条直线时(假设此时人站在A点),此时的长度是影子全在地上的最长长度。当人再向右走时,影子开始投影到墙上,当人贴着墙,影子长度即为人的高度。所以当人从A点走到墙,函数是先递增再递减,为凸性函数,所以我们可以用  三分法 来求解。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath> using namespace std; const double eps=1e-; double H,h,D,ans; double Cal(double l){
return l+D*(h-l)/(H-l);
} int main(){ //freopen("input.txt","r",stdin); int t;
scanf("%d",&t);
while(t--){
scanf("%lf%lf%lf",&H,&h,&D);
double left=,right=h,mid,midmid;
while(right-left>=eps){
mid=(left+right)/;
midmid=(mid+right)/;
if(Cal(mid)>Cal(midmid))
right=midmid;
else
left=mid;
}
printf("%.3lf\n",Cal(left));
}
return ;
}

最新文章

  1. java面向对象_static关键字
  2. 【Android开发】 第一课 环境搭建教程
  3. @PostConstruct与@PreDestroy
  4. Cannot modify header information - headers already sent by
  5. phpexcel导入excel文件报the filename xxx is not recognised as an OLE file错误。
  6. php-fpm配置优化
  7. 查看hive中某个表中的数据、表结构及所在路径
  8. elasticsearch red status fix 红色状态修复
  9. Adapterview和adapter的联系
  10. “《编程珠玑》(第2版)第2章”:A题(二分搜索)
  11. loj548 「LibreOJ β Round #7」某少女附中的体育课
  12. MPLS的模拟学习过程
  13. 制作Win10 U盘版移动便携系统
  14. 在 ASP.NET Core 中发送邮件遇到的坑_学习笔记
  15. python 模块二(os,json,pickle)
  16. sqoop使用经验总结及问题汇总
  17. java连接oracle数据库使用SERVICE NAME、SID以及TNSName不同写法
  18. 使用hibernate与mysql时数据不能插入的原因及解决办法
  19. ldap objectclass
  20. TCGA系列--fusion

热门文章

  1. 【BZOJ】【1415】【NOI2005】聪聪和可可
  2. 数学图形(1.2)Sin曲线
  3. 第四章 CopyOnWriteArraySet源码解析
  4. C#调用C++ memcpy实现各种参数类型的内存拷贝 VS marshal.copy的实现 效率对比
  5. Observer 观察者模式 MD
  6. Web项目添加Maven支持
  7. 手把手教你Android手机与BLE终端通信--连接,发送和接收数据
  8. .NET MVC自定义错误处理页面的方法
  9. WordPress 后台评论如何自定义搜索条件
  10. Python基础语法学习整理