CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing
christmas presents to send to their girlfriends. It is believed that
chain bracelet is a good choice. However, Things are not always so
simple, as is known to everyone, girl's fond of the colorful decoration
to make bracelet appears vivid and lively, meanwhile they want to
display their mature side as college students. after CC understands the
girls demands, he intends to sell the chain bracelet called
CharmBracelet. The CharmBracelet is made up with colorful pearls to show
girls' lively, and the most important thing is that it must be
connected by a cyclic chain which means the color of pearls are cyclic
connected from the left to right. And the cyclic count must be more than
one. If you connect the leftmost pearl and the rightmost pearl of such
chain, you can make a CharmBracelet. Just like the pictrue below, this
CharmBracelet's cycle is 9 and its cyclic count is 2:


Now CC has brought in some ordinary bracelet chains, he wants to
buy minimum number of pearls to make CharmBracelets so that he can save
more money. but when remaking the bracelet, he can only add color pearls
to the left end and right end of the chain, that is to say, adding to
the middle is forbidden.

CC is satisfied with his ideas and ask you for help.

InputThe first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.

Each test case contains only one line describe the original ordinary
chain to be remade. Each character in the string stands for one pearl
and there are 26 kinds of pearls being described by 'a' ~'z' characters.
The length of the string Len: ( 3 <= Len <= 100000 ).OutputFor each case, you are required to output the minimum count of pearls added to make a CharmBracelet.Sample Input

3
aaa
abca
abcde

Sample Output

0
2
5 kmp求循环节。
推荐博客:https://www.cnblogs.com/chenxiwenruo/p/3546457.html

注意题目要求至少循环两次。所以判断条件需要写出来


 #include<stdio.h>
#include<string.h>
int n,Next[],T,plen;
char p[]; void prekmp() {
plen=strlen(p);
int i,j;
j=Next[]=-;
i=;
while(i<plen) {
while(j!=-&&p[i]!=p[j]) j=Next[j];
if(p[++i]==p[++j]) Next[i]=Next[j];
else Next[i]=j;
}
} int main() {
//freopen("out","r",stdin);
scanf("%d",&T);
while(T--) {
scanf("%s",p);
prekmp();
//printf("%d**\n",Next[plen]);
int l=plen-Next[plen];
if(plen%l==&&plen/l>) printf("0\n");
else printf("%d\n",l-plen%l);
}
}
 

最新文章

  1. 如何同时打开两个excel
  2. NPOI 格式设置2—时间,千分位,繁体,小数位
  3. vmware linux top si高以及网卡队列、软负载相关优化
  4. h5固定表头公共样式
  5. 彻底解决_OBJC_CLASS_$_某文件名&quot;, referenced from:问题转
  6. javascript 原生方法监听DOM结构改变事件
  7. C#核心基础--类(2)
  8. Java 8 VM GC Tunning Guild Charter 9-b
  9. 查看局域网内某个ip的mac地址
  10. 无需转化直接使用ESD映像文件安装系统简明教程
  11. android中使用setVideoURI()播放视频
  12. 「OC」 继承
  13. 高并发场景之RabbitMQ篇
  14. unity3D:游戏分解之角色移动和相机跟随
  15. centos7 系统安装问题汇总
  16. Swift - CALayer的contents属性动画
  17. 如何使用 t-sql 更新数据库中日期字段的部分数据(年?月?日?时?分?秒?)
  18. 理解B+树算法和Innodb索引
  19. toxiproxy 安装试用
  20. jquery 事件:2

热门文章

  1. PDM/CDM中进行搜索
  2. junit4新框架hamcrest的assertThat
  3. Latex 多个参考文献的引用
  4. SSH框架搭建步骤
  5. linux设置自动获取IP地址
  6. jQuery-图片的放大镜显示效果(不需要大小图)
  7. solr replication原理探究
  8. day17 12.复习
  9. Luogu 3629 [APIO2010]巡逻
  10. rpm bug