题目描述

输入输出格式

输入格式:

输入文件第一行是一个正整数n,表示树有n个结点。第二行有n个数,第i个数表示di,即树的第i个结点的度数。其中1<=n<=150,输入数据保证满足条件的树不超过10^17个。

输出格式:

输出满足条件的树有多少棵。

输入输出样例

输入样例#1:
复制

4
2 1 2 1
输出样例#1: 复制

2
首先不知道prufer序列的可以学一下;
https://blog.csdn.net/update7/article/details/77587329
知道以后,其实就是依据该序列来还原树;
prufer的长度为n-2,所以全排列为(n-2)!;
考虑重复排列;
那么:

然后分解质因数即可;
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstdlib>
#include<cstring>
#include<string>
#include<cmath>
#include<map>
#include<set>
#include<vector>
#include<queue>
#include<bitset>
#include<ctime>
#include<deque>
#include<stack>
#include<functional>
#include<sstream>
//#include<cctype>
//#pragma GCC optimize(2)
using namespace std;
#define maxn 200005
#define inf 0x7fffffff
//#define INF 1e18
#define rdint(x) scanf("%d",&x)
#define rdllt(x) scanf("%lld",&x)
#define rdult(x) scanf("%lu",&x)
#define rdlf(x) scanf("%lf",&x)
#define rdstr(x) scanf("%s",x)
typedef long long ll;
typedef unsigned long long ull;
typedef unsigned int U;
#define ms(x) memset((x),0,sizeof(x))
const long long int mod = 1e9;
#define Mod 1000000000
#define sq(x) (x)*(x)
#define eps 1e-11
typedef pair<int, int> pii;
#define pi acos(-1.0)
//const int N = 1005;
#define REP(i,n) for(int i=0;i<(n);i++)
typedef pair<int, int> pii; inline int rd() {
int x = 0;
char c = getchar();
bool f = false;
while (!isdigit(c)) {
if (c == '-') f = true;
c = getchar();
}
while (isdigit(c)) {
x = (x << 1) + (x << 3) + (c ^ 48);
c = getchar();
}
return f ? -x : x;
} ll gcd(ll a, ll b) {
return b == 0 ? a : gcd(b, a%b);
}
int sqr(int x) { return x * x; } /*ll ans;
ll exgcd(ll a, ll b, ll &x, ll &y) {
if (!b) {
x = 1; y = 0; return a;
}
ans = exgcd(b, a%b, x, y);
ll t = x; x = y; y = t - a / b * y;
return ans;
}
*/ int n;
ll d[200];
ll ct[200]; void sol(int x, int k) {
int dv = 2;
while (x > 1) {
if (x%dv == 0) {
ct[dv] += k; x /= dv;
}
else dv++;
}
} int main() {
// ios_base::sync_with_stdio(0); cin.tie(0); cout.tie(0);
n = rd(); int tot = 0;
for (int i = 1; i <= n; i++) {
rdllt(d[i]);
if (d[i] > 1)tot += (d[i] - 1);
}
if (n == 1) {
if (!d[1])cout << 1 << endl;
else cout << 0 << endl;
return 0;
}
if (tot != n - 2) { cout << 0 << endl; return 0; }
for (int i = 2; i <= n - 2; i++) {
sol(i, 1);
}
for (int i = 1; i <= n; i++) {
for (int j = 2; j < d[i]; j++) {
sol(j, -1);
}
}
ll ans = 1;
for (ll i = 1; i <= n; i++) {
for (ll j = 1; j <= ct[i]; j++)ans *= i;
}
printf("%lld\n", ans * 1ll);
return 0;
}

最新文章

  1. 【ajax 提交表单】多种方式的注意事项
  2. 微信JS SDK Demo 官方案例[转]
  3. nyoj 49 开心的小明
  4. Stage3D学习笔记(六):旋转动画效果
  5. .NET平台和开发.
  6. 频繁模式挖掘中Apriori、FP-Growth和Eclat算法的实现和对比
  7. Spring Boot会员管理系统——处理文件上传
  8. Undefined attribute name (placeholder)
  9. 前后台得到WEB应用的名称
  10. Django_简介
  11. CentOS7查看systemctl 控制的服务的相关配置
  12. Jmeter(三十二)_搭建本地接口自动化环境
  13. 递归与非递归打印乘法口诀表--Scala(指令式、函数式思维练习)
  14. Hibernate学习笔记2.5(Hibernate核心开发接口和三种状态)
  15. MYSQL用户操作管理大杂烩
  16. fcntl 改变描述符属性
  17. Mysql学习---SQL语言的四大分类
  18. Python 时间推进器-->在当前时间的基础上推前n天 | CST时间转化标准日期格式
  19. SPAF模板
  20. 【luogu P3275 [SCOI2011]糖果】 题解

热门文章

  1. CentOS Firewall简单使用
  2. 1&amp;nbsp;任务管理&amp;nbsp;&amp;nbsp;--转载于电子工程世界
  3. 通过class类获取类的成员变量和构造函数信息
  4. cocos2d-x 初探helloWorld
  5. 1.sql简介
  6. 截取utf8中文字符串
  7. (函数)实现strstr函数
  8. 分享一个好用的功能强大的节点树jQuery插件
  9. ASP.NET 5 Middleware, Or Where Has My HttpModule Gone?
  10. jquery表单数据验证扩展方法