1003. Emergency (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked
on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in
and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected
by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.

All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output

2 4

题目的意思要求求出最短路的个数,和点的权值最大的值

#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>
#include <queue> using namespace std;
const int maxn=1e9;
struct Nod
{
int value;
int next;
int weight;
}edge[505*2];
int head[505];
int tot;
void add(int x,int y,int z)
{
edge[tot].value=y;
edge[tot].weight=z;
edge[tot].next=head[x];
head[x]=tot++;
}
int vis[505];
int d[505];
int num[505];
int res[505];
int w[505];
int n,c1,c2,m;
struct Node
{
int pos;
int dis;
Node(){};
Node(int pos,int dis)
{
this->pos=pos;
this->dis=dis;
}
friend bool operator <(Node a,Node b)
{
return a.dis>b.dis;
}
};
void Dijkstra(int st)
{
priority_queue<Node> q;
q.push(Node(st,0));
memset(vis,0,sizeof(vis));
memset(num,0,sizeof(num));
memset(res,0,sizeof(res));
for(int i=0;i<=500;i++)
d[i]=1e9;
d[st]=0;num[st]=1;res[st]=w[st];
while(!q.empty())
{
Node term=q.top();
q.pop();
if(vis[term.pos])
continue;
vis[term.pos]=1;
for(int i=head[term.pos];i!=-1;i=edge[i].next)
{
int y=edge[i].value;
if(d[y]>term.dis+edge[i].weight)
{
num[y]+=num[term.pos];
res[y]=res[term.pos]+w[y];
d[y]=term.dis+edge[i].weight;
q.push(Node(edge[i].value,d[y]));
}
else if(d[y]==term.dis+edge[i].weight)
{
num[y]+=num[term.pos];
res[y]=max(res[y],res[term.pos]+w[y]);
}
}
}
} int main()
{
scanf("%d%d%d%d",&n,&m,&c1,&c2);
for(int i=0;i<n;i++)
scanf("%d",&w[i]);
int x,y,z;
memset(head,-1,sizeof(head));
tot=0;
for(int i=1;i<=m;i++)
{
scanf("%d%d%d",&x,&y,&z);
add(x,y,z);
add(y,x,z);
}
Dijkstra(c1);
printf("%d %d\n",num[c2],res[c2]);
return 0;
}

最新文章

  1. iOS版本更新的App提交审核发布流程
  2. JDK、JRE、JVM
  3. 标签栏使用Demo二
  4. HDU 5115 Dire Wolf 区间dp
  5. Loadrunner监控Centos
  6. 解决EnableVisualStyles Bug
  7. Java TreeMap 源码解析
  8. Qt 子窗口内嵌到父窗口中(无边框附体show即可)good
  9. (转载)javascript实现弹出对话框
  10. JS学习之路,菜鸟总结的注意事项及错误更正
  11. python 3.6 +pyMysql 操作mysql数据库
  12. slice,substring,substr的区别
  13. *&amp;p理解
  14. Winfrom中的几种传值方式
  15. 【作业一】Android开发环境以及开发前的准备
  16. phpstudy安装redis
  17. Solr搜索结果说明 (转)
  18. django中celery的使用
  19. 【Python】海贼王取名字
  20. JAVA数据结构--冒泡排序

热门文章

  1. 百度地图和高德地图坐标系的互相转换 四种Sandcastle方法生成c#.net帮助类帮助文档 文档API生成神器SandCastle使用心得 ASP.NET Core
  2. 自制MVC框架基础插件介绍
  3. DEDECMS 添加栏目图片
  4. C# Interview Questions:C#-English Questions
  5. DDR3调试总结
  6. BZOJ 3000(Big Number-Stirling公式求n!近似值)
  7. makefile之目录搜索&自动依赖
  8. Flask系列:数据库
  9. django模板{%for%}中的forloop的应用
  10. 最纯粹的直播技术实战02-Camera的处理以及推流