Domino Effect
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12147 Accepted: 3046
Description Did you know that you can use domino bones for other things besides playing Dominoes? Take a number of dominoes and build a row by standing them on end with only a small distance in between. If you do it right, you can tip the first domino and cause all others to fall down in succession (this is where the phrase ``domino effect'' comes from). While this is somewhat pointless with only a few dominoes, some people went to the opposite extreme in the early Eighties. Using millions of dominoes of different colors and materials to fill whole halls with elaborate patterns of falling dominoes, they created (short-lived) pieces of art. In these constructions, usually not only one but several rows of dominoes were falling at the same time. As you can imagine, timing is an essential factor here. It is now your task to write a program that, given such a system of rows formed by dominoes, computes when and where the last domino falls. The system consists of several ``key dominoes'' connected by rows of simple dominoes. When a key domino falls, all rows connected to the domino will also start falling (except for the ones that have already fallen). When the falling rows reach other key dominoes that have not fallen yet, these other key dominoes will fall as well and set off the rows connected to them. Domino rows may start collapsing at either end. It is even possible that a row is collapsing on both ends, in which case the last domino falling in that row is somewhere between its key dominoes. You can assume that rows fall at a uniform rate.
Input The input file contains descriptions of several domino systems. The first line of each description contains two integers: the number n of key dominoes (1 <= n < 500) and the number m of rows between them. The key dominoes are numbered from 1 to n. There is at most one row between any pair of key dominoes and the domino graph is connected, i.e. there is at least one way to get from a domino to any other domino by following a series of domino rows. The following m lines each contain three integers a, b, and l, stating that there is a row between key dominoes a and b that takes l seconds to fall down from end to end. Each system is started by tipping over key domino number 1. The file ends with an empty system (with n = m = 0), which should not be processed.
Output For each case output a line stating the number of the case ('System #1', 'System #2', etc.). Then output a line containing the time when the last domino falls, exact to one digit to the right of the decimal point, and the location of the last domino falling, which is either at a key domino or between two key dominoes(in this case, output the two numbers in ascending order). Adhere to the format shown in the output sample. The test data will ensure there is only one solution. Output a blank line after each system.
Sample Input 2 1
1 2 27
3 3
1 2 5
1 3 5
2 3 5
0 0
Sample Output System #1
The last domino falls after 27.0 seconds, at key domino 2. System #2
The last domino falls after 7.5 seconds, between key dominoes 2 and 3.
Source Southwestern European Regional Contest 1996

到每个点的最短路就是推到这个点的最短时间

处理边就用(dis[i]+dis[j]+w)/2更新最大值

然后比较最大值和每个dis里的最大值,大于说明就是在边上推到了结束,否则就是在这个最大值的点上结束的。

特判n=1的点。。。

输出 真的 恶心

为什么 .1lf 就WA .1f 就AC

#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
using namespace std; const int MAXN=505;
const int INF=1<<28; int n,m; struct Edge{
int next,to,w;
}e[MAXN*MAXN];
int ecnt,head[MAXN];
inline void add(int x,int y,int w){
e[++ecnt].next = head[x];
e[ecnt].to = y;
e[ecnt].w = w;
head[x] = ecnt;
} bool vis[MAXN];
int dis[MAXN];
int baned[MAXN];
struct Node{
int id,w;
bool operator<(const Node &rhs) const{
return w>rhs.w;
}
};
void dij(){
priority_queue<Node> Q;
vis[1]=0;
for(int i=2;i<=n;i++)
dis[i]=INF,vis[i]=0;
for(int i=1;i<=n;i++)
Q.push(Node{i,dis[i]});
for(int i=1;i<=n;i++){
Node top;
do{
top=Q.top() ;
Q.pop();
}while(vis[top.id]);
int mnid=top.id,mn=top.w;
vis[mnid]=1;
for(int i=head[mnid];i;i=e[i].next){
int v=e[i].to ;
if(dis[v]>mn+e[i].w){
dis[v]=mn+e[i].w ;
// baned[v]=mnid;
Q.push(Node{v,dis[v]});
}
}
}
} int main(){
int cnt=1;
while(cin>>n>>m){
// memset(baned,0,sizeof(baned));
if(!n) return 0;
ecnt=0;
for(int i=1;i<=n;i++) head[i]=0;
for(int i=1;i<=m;i++){
int x,y,w;
cin>>x>>y>>w;
add(x,y,w);
add(y,x,w);
}
dij();
double mx=0.0;
double single_mx=-INF;
int mxid;
for(int i=1;i<=n;i++) {
if(single_mx<dis[i]){
single_mx=dis[i];
mxid=i;
}
}
int l=0,r=0;
for(int i=1;i<=n;i++){
bool flag=0;
if(dis[i]==INF) continue;
for(int j=head[i];j;j=e[j].next){
int v=e[j].to ;
// if(i==baned[v]) continue;
if(dis[v]==INF) continue;
flag=1;
if((1.0*(dis[i]+dis[v]+e[j].w)/2.0)>mx){
mx=(double)(1.0*(dis[i]+dis[v]+e[j].w)/2.0);
l=v<i?v:i;
r=v>=i?v:i;
}
}
}
printf("System #%d\n",cnt++);
if(n==1){
printf("The last domino falls after 0.0 seconds, at key domino 1.\n\n");//
continue;
}
if(mx<=single_mx){
// The last domino falls after 27.0 seconds, at key domino 2.
printf("The last domino falls after %.1f seconds, at key domino %d.\n",mx,mxid);
}else{
// The last domino falls after 7.5 seconds, between key dominoes 2 and 3.
printf("The last domino falls after %.1f seconds, between key dominoes %d and %d.\n"
,mx,l,r);
}
printf("\n");
} }

最新文章

  1. Redhat Linux安装JDK 1.7
  2. (转)php-curl响应慢(开发微信授权登陆时碰到的问题)
  3. html总集
  4. gdb简明手册
  5. C# Windows service 开发笔录
  6. Website Speed Optimization Guide for Google PageSpeed Rules
  7. 调皮的MySQL服务 请你不要再躲猫猫
  8. SSO之CAS单点登录详细搭建教程
  9. Unsupervised Learning: Use Cases
  10. Js冒泡事件和捕获事件
  11. Nyoj 虚拟的城市之旅(bfs)
  12. Golang 入门系列(十一)Go语言实现webapi
  13. 使用AForge.NET Framework打开摄像头并截图 C#
  14. css3动画:transition和animation
  15. Mac 下编译安装 php-5.6
  16. nginx 403 forbidden
  17. 【Excel】读取CSV文本
  18. java学习手册
  19. Intent的作用和表现形式简单介绍
  20. refused to Connection

热门文章

  1. [Python]IndentationError: unindent does not match any outer indentation level
  2. [題解](單調隊列/水)luogu_P3088擠奶牛
  3. 自己写的Grid组件,第二版
  4. 086 Partition List 分隔链表
  5. nodejs 学习(2) 中间件
  6. django-form and fields validation
  7. 09通过winfrom实现简单的播放音、视频
  8. ubuntu键盘映射
  9. Android - Zxing实现二维码的扫描与生成
  10. Selenium私房菜系列5 -- 第一个Selenium RC测试案例