时间限制:1 秒

内存限制:32 兆

特殊判题:否

提交:266

解决:189

题目描述:

Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycles are the physical, emotional, and intellectual cycles, and they have periods of lengths 23, 28, and 33 days, respectively. There is
one peak in each period of a cycle. At the peak of a cycle, a person performs at his or her best in the corresponding field (physical, emotional or mental). For example, if it is the mental curve, thought processes will be sharper and concentration will be
easier. 

Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will
be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine
the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give
the number of days to the next occurrence of a triple peak.

输入:

You will be given a number of cases. The input for each case consists of one line of four integers p, e, i, and d. The values p, e, and i are the number of days from the beginning of the current year at which the physical, emotional, and intellectual cycles
peak, respectively. The value d is the given date and may be smaller than any of p, e, or i. All values are non-negative and at most 365, and you may assume that a triple peak will occur within 21252 days of the given date. The end of input is indicated by
a line in which p = e = i = d = -1.

输出:

For each test case, print the case number followed by a message indicating the number of days to the next triple peak, in the form:

Case 1: the next triple peak occurs in 1234 days.

Use the plural form "days'' even if the answer is 1.

样例输入:
0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1
样例输出:
Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.
来源:
2009年北京大学计算机研究生机试真题

思路:

我的思路是,对三个周期,每次最小那个天数的加一个周期,直到三个周期重合。

本题还可用中国剩余定理求解,具体自己上网搜吧,很多相关文章。

九度上能过的在POJ上没过,原来给的起始天数可能已经超过了d时间开始的第一个重合周期了,要将起始天数恢复到d之前才行。

代码1是九度上能过的C代码,代码2是POJ上能过的C++代码。

代码1:

#include <stdio.h>

int min(int a[3])
{
int m = 0;
if (a[1] < a[0])
m = 1;
if (a[2] < a[m])
m = 2;
return m;
} int equal(int a[3])
{
if (a[0] == a[1] && a[1] == a[2])
return 1;
return 0;
} int main(void)
{
int i;
int a[3], cycle[3]={23, 28, 33};
int d;
int k = 0;
int res; while (scanf("%d%d%d%d", &a[0], &a[1], &a[2], &d) != EOF)
{
if (a[0] == -1 && a[1] == -1 && a[2] == -1 && d == -1)
break;
k ++; do {
i = min(a);
a[i] += cycle[i];
if (a[i] >= d+21252)
{
res = 21252;
break;
}
if (equal(a) && a[0]>d)
{
res = a[0]-d;
break;
}
} while (1); printf("Case %d: the next triple peak occurs in %d days.\n", k, res);
} return 0;
}
/**************************************************************
Problem: 1142
User: liangrx06
Language: C
Result: Accepted
Time:0 ms
Memory:912 kb
****************************************************************/

代码2:

#include <iostream>
using namespace std; int min(int a[3])
{
int m = 0;
if (a[1] < a[0])
m = 1;
if (a[2] < a[m])
m = 2;
return m;
} int equal(int a[3])
{
if (a[0] == a[1] && a[1] == a[2])
return 1;
return 0;
} int main(void)
{
int i;
int a[3], d, cycle[3]={23, 28, 33};
int k, res; k = 0;
while (cin >> a[0] >> a[1] >> a[2] >> d)
{
if (a[0] == -1 && a[1] == -1 && a[2] == -1 && d == -1)
break; for (i=0; i<3; i++)
{
while (a[i] > d)
a[i] -= cycle[i];
} do {
i = min(a);
a[i] += cycle[i];
if (a[i] >= d+21252)
{
res = 21252;
break;
}
if (equal(a) && a[0]>d)
{
res = a[0]-d;
break;
}
} while (1); cout << "Case "<< ++k << ": the next triple peak occurs in ";
cout << res << " days." << endl;
} return 0;
}
/**************************************************************
Problem: 1142
User: liangrx06
Language: C++
Result: Accepted
Time:10 ms
Memory:1520 kb
****************************************************************/

最新文章

  1. C# 开发windows服务的一些心得
  2. 黑马程序员——【Java高新技术】——案例:交通灯管理系统
  3. csuoj 1115: 最短的名字
  4. TJU 4087. box
  5. 《head first java 》读书笔记(二)
  6. Why it is good practice to declare loggers private, static, and final?
  7. 开源 免费 java CMS - FreeCMS2.1 会员站内信
  8. 【转】用户空间使用i2c_dev--不错
  9. yii操作数据库(AR)
  10. mysql各种日志对应的配置项
  11. 解决struts2中UI标签出现的问题: The Struts dispatcher cannot be found
  12. Arduino 各种模块篇 motor shield
  13. UIButton图片文字控件位置自定义(图片居右文字居左、图片居中文字居中、图片居左文字消失等)
  14. U盘PE无人值守安装centOS6
  15. ruby klb.rb irb
  16. JMeter 不同线程组间变量传递
  17. Ubuntu16.04 创建和使用虚拟环境
  18. 4.TableLayout、回调接口
  19. MD5在线加密的应用
  20. ArcGIS案例学习笔记-栅格数据分区统计(平均高程,污染浓度,污染总量,降水量)

热门文章

  1. [virtualbox] virtualbox 安裝 ubuntu,但 virtualbox 卻無法執行 ubuntu 的快速鍵,解法方式
  2. ASP.NET路由应用及IIS配置(非MVC)
  3. java mail Received fatal alert: handshake_failure java 无法发送邮件问题 java 发送qq邮件(含源码)
  4. codevs——1700 施工方案第二季
  5. k8s之ingress及ingress controller
  6. mac apache配置虚拟主机
  7. Caused by: java.io.FileNotFoundException: rmi_keystore.jks (没有那个文件或目录)
  8. Dubbo zookeeper 初探
  9. 如何直接打开使用locate等查找到的文件
  10. 百度地图 创建 自定义控件(vue)