Magical Forest

Time Limit: 24000/12000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 135    Accepted Submission(s): 69

Problem Description
There is a forest can be seen as N * M grid. In this forest, there is some magical fruits, These fruits can provide a lot of energy, Each fruit has its location(Xi, Yi) and the energy can be provided Ci. 



However, the forest will make the following change sometimes: 

1. Two rows of forest exchange. 

2. Two columns of forest exchange. 

Fortunately, two rows(columns) can exchange only if both of them contain fruits or none of them contain fruits. 



Your superior attach importance to these magical fruit, he needs to know this forest information at any time, and you as his best programmer, you need to write a program in order to ask his answers quick every time.
 
Input
The input consists of multiple test cases. 



The first line has one integer W. Indicates the case number.(1<=W<=5)



For each case, the first line has three integers N, M, K. Indicates that the forest can be seen as maps N rows, M columns, there are K fruits on the map.(1<=N, M<=2*10^9, 0<=K<=10^5)



The next K lines, each line has three integers X, Y, C, indicates that there is a fruit with C energy in X row, Y column. (0<=X<=N-1, 0<=Y<=M-1, 1<=C<=1000)



The next line has one integer T. (0<=T<=10^5)

The next T lines, each line has three integers Q, A, B. 

If Q = 1 indicates that this is a map of the row switching operation, the A row and B row exchange. 

If Q = 2 indicates that this is a map of the column switching operation, the A column and B column exchange. 

If Q = 3 means that it is time to ask your boss for the map, asked about the situation in (A, B). 

(Ensure that all given A, B are legal. )
 
Output
For each case, you should output "Case #C:" first, where C indicates the case number and counts from 1.



In each case, for every time the boss asked, output an integer X, if asked point have fruit, then the output is the energy of the fruit, otherwise the output is 0.
 
Sample Input
1
3 3 2
1 1 1
2 2 2
5
3 1 1
1 1 2
2 1 2
3 1 1
3 2 2
 
Sample Output
Case #1:
1
2
1
Hint
No two fruits at the same location.

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<set>
#include<vector>
#include<map>
#include<math.h>
#include<time.h>
#include<string.h>
using namespace std;
const double pi=acos(-1.0);
#define LL __int64
#define N 100005
const int M=26;
struct node
{
int x,y;
bool operator<(const node&a)const
{ //结构体内重载运算符
if(x!=a.x)
return x<a.x;
return y<a.y;
}
}tmp;
/*
bool operator<(const node&a,const node&b)
{
if(a.x!=b.x) //结构体外重载运算符
return a.x<b.x;
return a.y<b.y;
}*/
map<int,int>u,v; //把题目所给坐标映射为范围较小的坐标 [0,...]
int cntx,cnty; //相应坐标值
map<node,int>p; //把新的坐标和能量C建立映射关系
int main()
{
int W,n,m,k,T;
int i,c,x,y,cas=1;
scanf("%d",&W);
while(W--){
scanf("%d%d%d",&n,&m,&k);
cntx=cnty=0;
for(i=0;i<k;++i){
scanf("%d%d%d",&x,&y,&c);
if(u[x]==0)
u[x]=cntx++;
if(v[y]==0)
v[y]=cnty++;
tmp.x=u[x];
tmp.y=v[y];
p[tmp]=c;
}
int q,a,b,t;
scanf("%d",&T);
printf("Case #%d:\n",cas++);
while(T--){
scanf("%d%d%d",&q,&a,&b);
if(q==1){
t=u[a];
u[a]=u[b];
u[b]=t;
}
else if(q==2){
t=v[a];
v[a]=v[b];
v[b]=t;
}
else{
tmp.x=u[a];
tmp.y=v[b];
cout<<p[tmp]<<endl;
}
}
}
return 0;
}

最新文章

  1. ajaxFileUpload上传文件没反应
  2. 实战1--应用EL表达式访问JavaBean的属性
  3. 设置div居中
  4. Create your first isolated Python environment
  5. Fortran编译多个文件(转载)
  6. Java作业
  7. 如何提高jQuery的性能
  8. 阿里云ECS服务器被DDoS无解,请问我该何去何从?
  9. javascript 控制台输出 图片 console.log 真强大 真佩服你们的创造力
  10. 图片上传插件用法,JS语法【三】
  11. 关于css禁止文本复制属性
  12. IDLE常用快捷键汇总(转)
  13. TTL与非门电路分析
  14. Python之加环境变量
  15. 剑指offer(27)字符串的排列
  16. AJPFX简述:MetaTrader 4移动交易平台
  17. ViewPager系列之 仿魅族应用的广告BannerView
  18. Dicom图像解析
  19. Git(四)Git的分支管理
  20. 开始Admob广告盈利模式详细教程

热门文章

  1. C# 接口命名规范
  2. Java—RequestMapping相关用法
  3. CSS——行高
  4. C#调用Win32 api时的内存操作
  5. Python 发送邮件、加密 day5
  6. openstack——neutron网络服务
  7. 后台取前台input标签值方法
  8. Mapreduce代码疑点(1)
  9. Django-----中间件Cookie
  10. 高三感想+跨年感想+OI回忆录