With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

For example, 3 games' odds are given as the following:

 W    T    L
1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1*3.0*2.5*65%-1)*2 = 37.98 yuans (accurate up to 2 decimal places).

Input

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input

1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1

Sample Output

T T W 37.98

题解:

#include"iostream"
#include "algorithm"
#include<iomanip>//注意关于小数数位的头文件
using namespace std;

int main()
{
float a[3][3];
int b[3],t=0,temp;
float max,sum=1;
for(int i=0;i<3;i++)
{
max=0;
for(int j=0;j<3;j++)
{
cin >> a[i][j];
if(max<=a[i][j])
{
max = a[i][j];
temp = j;
}
}
b[t++]=temp;
sum *=max;
}
for(int j=0;j<t;j++)
{
if(b[j]==0)
cout<<"W"<<" ";
else if(b[j]==1)
cout<<"T"<<" ";
else
cout<<"L"<<" ";
}
cout<<setiosflags(ios::fixed);//如果为cout<<setiosflags(ios::fixed)<<cout.precision(2);则会输出一个6
cout.precision(2);//设置小数点后为两位
cout<<((sum*0.65-1)*2)<<endl;

return 0;
}

最新文章

  1. 使用do{ } while(0)的好处
  2. Android开发学习之路-提升用户体验小技巧
  3. HLOI2016滚粗记
  4. JQuery data API实现代码分析
  5. 42.Android之ListView中ArrayAdapter简单学习
  6. bzoj 3234: [Ahoi2013]立方体
  7. 采用Json字符串,往服务器回传大量富文本数据时,需要注意的地方,最近开发时遇到的问题。
  8. org.hibernate.service.jndi.JndiException: Error parsing JNDI name []
  9. PHP截取带有汉字的字符串,将汉字按两个字节计算
  10. socket error:10053
  11. springboot vue简单整合
  12. linux五种I/O模型
  13. Eclipse安装Git插件及简单操作
  14. Eclipse 重构
  15. Oozie分布式工作流——从理论和实践分析使用节点间的参数传递
  16. Scala学习笔记——类型
  17. 小程序swiper效果高宽设置(微信小程序交流群:604788754)
  18. 【校招面试 之 C/C++】第32题 C++ 11新特性(三)之for关键字
  19. python(29)----时间模块
  20. Rectangles(第七届ACM省赛原题+最长上升子序列)

热门文章

  1. idea svn 更新覆盖了本地代码
  2. express 4.x 文件上传
  3. DUIlib使用Fastreport--自定义的数据
  4. Qt 打开指定的文件
  5. openstack私有云布署实践【17 配置文件部份说明】
  6. socket编程之TCP/UDP
  7. 《Javascript权威指南》
  8. 《Intel汇编第5版》 汇编调用子过程
  9. html绑定
  10. double hashing 双重哈希