BestCoder Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 271    Accepted Submission(s): 112

Problem Description
Mr Potato is a coder.

Mr Potato is the BestCoder.



One night, an amazing sequence appeared in his dream. Length of this sequence is odd, the median number is M, and he named this sequence as Bestcoder Sequence.



As the best coder, Mr potato has strong curiosity, he wonder the number of consecutive sub-sequences which are bestcoder sequences in a given permutation of 1 ~ N.
 
Input
Input contains multiple test cases. 

For each test case, there is a pair of integers N and M in the first line, and an permutation of 1 ~ N in the second line.



[Technical Specification]

1. 1 <= N <= 40000

2. 1 <= M <= N
 
Output
For each case, you should output the number of consecutive sub-sequences which are the Bestcoder Sequences
 
Sample Input
1 1
1
5 3
4 5 3 2 1
 
Sample Output
1
3
Hint
For the second case, {3},{5,3,2},{4,5,3,2,1} are Bestcoder Sequence.
 

题目意思是  再给出的全排列(1~n每一个数字仅仅出现一次)中,找到一个奇数个的子串,要求子串的中位数(大小排序后正中间的数), 为M;

求这样的子串有多少.

首先要把M这个数左边的串预处理下,  假设 遇到大于M的数ji++,然后记录在data[当前位置的奇偶][当前记录的ji]  ,假设当前位置的数小于M的数,ji--; 由于ji记录在数组里,所以ji 要价格50000 以保证不会出现负数的情况.

然后再处理右边的串,ji 又一次计数,

ans+data[位置奇偶, 假设两个位置奇偶同样,代表这条串有奇数个元素][-ji  加个符号,找到前面处理过的左串中,能够互补的串,达到大于M的数和小于M的数 一样多];

相同加个ji取负数后  相同加个 50000,和前面保存一致

#include<stdio.h>
#include<string.h>
int big(int a)
{
return a+50000;
}
int a[50000],ji,data[2][200000];
int main()
{
int n,m,i,j,wei;
int ans;
while(scanf("%d%d",&n,&m)!=EOF)
{
ans=0;
for(i=1;i<=n;i++)
{
scanf("%d",&a[i]);
if(a[i]==m)
wei=i;
}
ji=0;
memset(data,0,sizeof(data));
for(i=wei;i>=1;i--)
{
if(a[i]<m)
ji--;
if(a[i]>m)
ji++;
if(i&1)
data[1][big(ji)]++;
else
data[0][big(ji)]++;
}
ji=0;
for(i=wei;i<=n;i++)
{
if(a[i]<m)
ji--;
if(a[i]>m)
ji++;
if(i&1)
ans+=data[1][big(-ji)];
else
ans+=data[0][big(-ji)];
}
printf("%d\n",ans);
}
return 0;
}

版权声明:本文博客原创文章。博客,未经同意,不得转载。

最新文章

  1. MySql数据源配置
  2. C#强力粉碎文件代码分享,升级中用到
  3. mfs-用户
  4. poj 1556 The Doors(线段相交,最短路)
  5. oracle授权另外一个用户访问自己创建的数据对象
  6. SQL条件表达式
  7. java:利用数组实现将古诗词纵向输出
  8. .net MVC 中“MvcPager” 插件的简单使用。
  9. Java8之旅(七) - 函数式备忘录模式优化递归
  10. 安装CentOS7
  11. JavaScript的事件、DOM模型、事件流模型以及内置对象详解(三)
  12. spark概念、编程模型和模块概述
  13. hihocoder #1236 Scores (15北京赛区网络赛J) (五维偏序,强制在线,bitset+分块)
  14. 让div固定在顶部不随滚动条滚动【转】
  15. js中获取时间new date()的用法和获取时间戳
  16. XHR简介
  17. PDO中的预处理
  18. CSS 小结笔记之伸缩布局 (flex)
  19. Day22-Django之缓存
  20. 【费用流】BZOJ1927-[Sdoi2010]星际竞速

热门文章

  1. SRM 583 Div Level Two:IDNumberVerification
  2. Re-installation failed due to different application signatures.
  3. 5款帮助简化的HTML5 Audio开发的Javascript类库
  4. dwz框架---(2)表单回调函数
  5. C嵌入汇编
  6. Lucene.Net 2.3.1开发介绍 —— 四、搜索(一)
  7. HDU 4166 &amp; BNU 32715 Robot Navigation (记忆化bfs)
  8. [置顶] Ftp客户端概要设计
  9. Android代码混淆和项目宣布步骤记录器
  10. Indy的评价