To the Max

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 49351   Accepted: 26142

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1 8 0 -2

Sample Output

15

题意:

求矩阵中和最大的子矩阵。

思路:

把题目转化成一维的最大连续子段和。

枚举起始行i和终止行j,将i~j行的数对应相加,求解最大连续子段和。

代码:

#include<iostream>
using namespace std;
const int maxn = 105;
int grap[maxn][maxn], sum[maxn][maxn];
int main()
{
int n, tmp, ans=-0x3f3f3f3f;
cin>>n;
for(int i=1; i<=n; ++i)
{
for(int j=1; j<=n; ++j)
{
cin>>grap[i][j];
sum[i][j]=sum[i-1][j]+grap[i][j];
}
}
for(int i=1; i<=n; ++i)
{
for(int j=i; j<=n; ++j)
{
tmp=0;
for(int k=1; k<=n; ++k)
{
if(tmp<=0)
tmp=sum[j][k]-sum[i-1][k];
else
tmp+=sum[j][k]-sum[i-1][k];
ans=max(ans, tmp);
}
}
}
cout<<ans<<endl;
return 0;
}

最新文章

  1. TCP/IP详解 笔记十三
  2. 弹出框二 之 bootbox.js
  3. hibernate基于注解的维护权反转:@OneToMany(mappedBy=)
  4. IDL中histogram的应用
  5. Mybatis SQL语句查询
  6. HDU5301
  7. Ubuntu apache 禁止目录浏览
  8. Linux命令(持续更新ing)
  9. EntityFramework、Dapper vs 草根框架性能
  10. 域名注册商namesilo价格便宜,赠送whois保护,最新优惠码:geekradio
  11. anaconda安装加速镜像问题解决
  12. U-Boot启动过程
  13. dubbo基本信息
  14. java基础知识三 流
  15. MRPT 安装使用
  16. python使用requests请求的数据乱码
  17. hadoop的核心思想【转】
  18. [golang note] 协程基础
  19. 系统日志查看logrotate 工具
  20. 设计模式 - 命令模式(command pattern) 撤销(undo) 具体解释

热门文章

  1. 关于java基础知识的面试题(一)
  2. apche编译安装
  3. P4742 【[Wind Festival]Running In The Sky】
  4. Laravel Model查询结果的3种存储格式内存占用对比
  5. 安装了高版本OS X 之后无法使用MacPorts的port命令
  6. lamda表达式与Stream 流操作,reduce,flatMap,groupingBy等
  7. webservice了解一下!!
  8. 【代码审计】JAVA代码审计
  9. Matlab中界面和注释---中英文切换问题
  10. 结合实体框架(代码优先)、工作单元测试、Web API、ASP. net等,以存储库设计模式开发示例项目。NET MVC 5和引导