Fence Repair
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 33114   Accepted: 10693

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤
50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made;
you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will
result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks 

Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 

The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into
16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

FJ想要把一段木头锯成他理想中的N段,每一段长度已知。但是锯每一段木头的开销就是木头的长度,我锯长度为21的木头,开销就是21,问想要锯成这样的N段,最小开销是多少?

优先队列,每次都取最小的两个值合并,然后再把改值放入队列中。不断循环,得到结果。

代码:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <queue>
#include <string>
#include <cstring>
#pragma warning(disable:4996)
using namespace std; int N; class cmp
{
public:
bool operator()(int x, int y)
{
return x > y;
}
}; int main()
{
//freopen("i.txt","r",stdin);
//freopen("o.txt","w",stdout); int i, temp1, temp2;
long long ans = 0;
priority_queue<int, vector<int>, cmp>qu; cin >> N;
for (i = 1; i <= N; i++)
{
cin >> temp1;
qu.push(temp1);
}
while (qu.size() != 1)
{
temp1 = qu.top();
qu.pop(); temp2 = qu.top();
qu.pop(); ans = ans + temp1 + temp2;
qu.push(temp1 + temp2);
} cout << ans << endl;
return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

最新文章

  1. JavaScript权威设计--JavaScript表达式与运算符(简要学习笔记五)
  2. fedora22命令useradd,groupadd等命令不能自动补全
  3. webservice MaxReceivedMessageSize :已超过传入消息(65536)的最大消息大小配额
  4. JQuery Validate使用总结
  5. 使用IntersectionObserver更高效的监视某个页面元素是否进入了可见窗口
  6. NGUI系列教程八(监听NGUI的事件方法)
  7. iOS开发系列--打造自己的“美图秀秀”
  8. linux命令:rsync, 同步文件和文件夹的命令
  9. 《精通android网络开发》--使用Socket实现数据通信
  10. 数组的迭代方法(every、filter、forEach、map、some)
  11. 前端入门18-JavaScript进阶之作用域链
  12. 在windows 7上安装TensorFlow
  13. 概率DP自学
  14. python3 文件和流
  15. [Swift]正则表达式工具类
  16. parent对象
  17. iOS开发-Block回调
  18. 11-[CSS]-标准文档流,display,浮动,清除浮动,overflow
  19. MT【131】$a_{n+1}\cdot a_n=\dfrac 1n$
  20. 基于非比較的排序:计数排序(countSort),桶排序(bucketSort),基数排序(radixSort)

热门文章

  1. 「POI2015」KIN
  2. ROS-2 : ROS系统层级结构
  3. 留学生想要搞定Reading List?只需这三步即可
  4. 简单模拟IOC容器:返回对象并能抛出异常
  5. LeetCode347:返回频率前K高的元素,基于优先队列实现
  6. 吴裕雄--天生自然JAVA数据库编程:JDBC操作步骤及数据库连接操作
  7. 使用 Doxygen 生成文档 (以FFmpeg 4.1.1 为例)
  8. WireShark 之抓包QQ协议
  9. sizeof strlen 求char*字符串的长度
  10. 0106 springMVC REST风格