内容:

    Ancient Roman empire had a strong government system with various departments, including a secret service department. Important documents were sent between provinces and the capital in encrypted form to prevent eavesdropping. The most popular ciphers in those times were so called substitution cipher and permutation cipher.
Substitution cipher changes all occurrences of each letter to some other letter. Substitutes for all letters must be different. For some letters substitute letter may coincide with the original letter. For example, applying substitution cipher that changes all letters from 'A' to 'Y' to the next ones in the alphabet, and changes 'Z' to 'A', to the message "VICTORIOUS" one gets the message "WJDUPSJPVT".
Permutation cipher applies some permutation to the letters of the message. For example, applying the permutation <2, 1, 5, 4, 3, 7, 6, 10, 9, 8> to the message "VICTORIOUS" one gets the message "IVOTCIRSUO".
It was quickly noticed that being applied separately, both substitution cipher and permutation cipher were rather weak. But when being combined, they were strong enough for those times. Thus, the most important messages were first encrypted using substitution cipher, and then the result was encrypted using permutation cipher. Encrypting the message "VICTORIOUS" with the combination of the ciphers described above one gets the message "JWPUDJSTVP".
Archeologists have recently found the message engraved on a stone plate. At the first glance it seemed completely meaningless, so it was suggested that the message was encrypted with some substitution and permutation ciphers. They have conjectured the possible text of the original message that was encrypted, and now they want to check their conjecture. They need a computer program to do it, so you have to write one.
Input
Input contains two lines. The first line contains the message engraved on the plate. Before encrypting, all spaces and punctuation marks were removed, so the encrypted message contains only capital letters of the English alphabet. The second line contains the original message that is conjectured to be encrypted in the message on the first line. It also contains only capital letters of the English alphabet.
The lengths of both lines of the input are equal and do not exceed 100.
Output
Output "YES" if the message on the first line of the input file could be the result of encrypting the message on the second line, or "NO" in the other case.
Sample Input JWPUDJSTVP
VICTORIOUS Sample Output YES

刚开始理解错了题意,好不容易弄明白。。。

题目大意:

给出了两行有大写字母组成的字符串,问能否将第一行经过替换和置换得到第二行。

替换指将该字符串每个字母加上一个相同的数后得到

置换指将字符串顺序调换

所以只要按此逆序来查看就可以,可以将字母按大小排序,再看出现频率是否相同也行。

思路:实际只要统计两个字符串中各字符出现的次数是否一样即可,即分别统计两个字符串中各字符的出现次数,再由小到大排序,比较即可,若全相同,则输出“YES”,若不同,则直接输出“NO”

代码:

#include<iostream>
#include<string>
#include<cstring>
#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
string s,b;
int a[50],w[50];
memset(a,0,sizeof(a));
memset(w,0,sizeof(w));
cin>>s;
getchar();
cin>>b;
int m;
m=s.size();
for(int i=0;i<m;i++)
{
a[s[i]-'A']++;
w[b[i]-'A']++;
}
sort(a,a+26);
sort(w,w+26);
int p=0;
for(int i=0;i<26;i++)
{
if(a[i]!=w[i])
{
p=1;
break;
}
cout<<a[i]<<" "<<w[i]<<endl;//该行要去掉,只是为了清楚比较
}
if(p==1)cout<<"NO"<<endl;
else
cout<<"YES"<<endl;
}

结果显示:

最新文章

  1. TWRP基于omnirom 6.0.1编译教程
  2. 密钥文件snk
  3. javascript 简单加解密
  4. [Bootstrap]7天深入Bootstrap(2)整体架构
  5. 转:关于Apache与Nginx的优势比较(经典)
  6. JTable单元格放自定义控件(一)-如何在JTable的单元格放JPanel
  7. CentOS下modelsim 10.2c install &amp; crack
  8. SysErrorMessage 函数和系统错误信息表
  9. Unity3D手游-横版ACT游戏完整源代码下载
  10. 集合-TreeSet-Comparable
  11. hdu_1030(数学题+找规律)
  12. mtd-utils交叉编译安装
  13. 关于mpi的理论知识以及编写程序来实现数据积分中的梯形积分法。
  14. 1053. Path of Equal Weight (30)
  15. Java 6- Java 运算符
  16. BLE 4.1 和 BLE 4.2
  17. Django快速创建博客,包含了整个框架使用过程,简单易懂
  18. Tomcat8 配置APR模式
  19. HDU4681_String
  20. PAT 1014 Waiting in Line (模拟)

热门文章

  1. 整理之Java容器
  2. 剑指 Offer 33. 二叉搜索树的后序遍历序列
  3. Mysql force index和ignore index 使用实例
  4. Windows系统一些好用的办公工具
  5. Windows Server安装MySQL
  6. Linux - 解决使用 apt-get 安装 yum 的时耗报 E: Unable to locate package yum 的错误
  7. Activiti 学习(二)—— Activiti 流程定义和部署
  8. SpringBoot-自动配置分析-图解
  9. C语言学习笔记---2.C语言数据类型
  10. Windows 10 之 WSL 2