Improving the GPA

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 606 Accepted Submission(s): 451

Problem Description

Xueba: Using the 4-Point Scale, my GPA is 4.0.

In fact, the AVERAGE SCORE of Xueba is calculated by the following formula:

AVERAGE SCORE = ∑(Wi * SCOREi) / ∑(Wi) 1<=i<=N

where SCOREi represents the scores of the ith course and Wi represents the credit of the corresponding course.

To simplify the problem, we assume that the credit of each course is 1. In this way, the AVERAGE SCORE is ∑(SCOREi) / N. In addition, SCOREi are all integers between 60 and 100, and we guarantee that ∑(SCOREi) can be divided by N.

In SYSU, the university usually uses the AVERAGE SCORE as the standard to represent the students’ level. However, when the students want to study further in foreign countries, other universities will use the 4-Point Scale to represent the students’ level. There are 2 ways of transforming each score to 4-Point Scale. Here is one of them.

The student’s average GPA in the 4-Point Scale is calculated as follows:

GPA = ∑(GPAi) / N

So given one student’s AVERAGE SCORE and the number of the courses, there are many different possible values in the 4-Point Scale. Please calculate the minimum and maximum value of the GPA in the 4-Point Scale.

Input

The input begins with a line containing an integer T (1 < T < 500), which denotes the number of test cases. The next T lines each contain two integers AVGSCORE, N (60 <= AVGSCORE <= 100, 1 <= N <= 10).

Output

For each test case, you should display the minimum and maximum value of the GPA in the 4-Point Scale in one line, accurate up to 4 decimal places. There is a space between two values.

Sample Input

4

75 1

75 2

75 3

75 10

Sample Output

3.0000 3.0000

2.7500 3.0000

2.6667 3.1667

2.4000 3.2000

Hint

In the third case, there are many possible ways to calculate the minimum value of the GPA in the 4-Point Scale.

For example,

Scores 78 74 73 GPA = (3.0 + 2.5 + 2.5) / 3 = 2.6667

Scores 79 78 68 GPA = (3.0 + 3.0 + 2.0) / 3 = 2.6667

Scores 84 74 67 GPA = (3.5 + 2.5 + 2.0) / 3 = 2.6667

Scores 100 64 61 GPA = (4.0 + 2.0 + 2.0) / 3 = 2.6667

Author

SYSU

Source

2014 Multi-University Training Contest 9

Recommend

We have carefully selected several similar problems for you: 5363 5362 5361 5360 5359

#include <map>
#include <set>
#include <list>
#include <cmath>
#include <queue>
#include <stack>
#include <vector>
#include <string>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
using namespace std;
#define eps 1e-9
#define LL long long
#define PI acos(-1.0)
#define INF 0x3f3f3f3f
#define CRR fclose(stdin)
#define CWW fclose(stdout)
#define RR freopen("input.txt","r",stdin)
#pragma comment(linker,"/STACK:102400000")
#define WW freopen("output.txt","w",stdout) const int Max = 160000; double Trans(int s)
{
if(s>=85)
{
return 4;
}
else if(s>=80)
{
return 3.5;
}
else if(s>=75)
{
return 3;
}
else if(s>=70)
{
return 2.5;
}
else
{
return 2;
}
} int main()
{
int T;
int n,m;
int sum;
double high,low;
scanf("%d",&T);
while(T--)
{
high=0;
low=0;
scanf("%d %d",&m,&n);
sum=n*m-n*60;
for(int i=0;i<n;i++)
{
if(sum>=25)
{
sum-=25;
high+=4;
}
else
{
high+=Trans(sum+60);
sum=0;
}
}
sum=n*m-n*69;
for(int i=0;i<n;i++)
{
if(sum>=31)
{
sum-=31;
low+=4;
}
else
{
low+=Trans(sum+69);
sum=0;
}
}
printf("%.4f %.4f\n",low/n,high/n);
} return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

最新文章

  1. 错误:document.getElementById(&quot;userForm&quot;).submit();Object is not a function
  2. innerText在谷歌、火狐浏览器下的使用
  3. maxscript,MAXScript Listener下输入print &quot;hi&quot;为什么输出两次
  4. 使用avalon 实现一个订座系统
  5. SQL Server 2008空间数据应用系列六:基于SQLCRL的空间数据可编程性
  6. 全方位分析Objcetive-C Runtime 分类: ios技术 2015-03-11 22:29 77人阅读 评论(0) 收藏
  7. 解决Tomcat: Can&#39;t load IA 32-bit .dll on a AMD 64-bit platform 问题
  8. http 状态表
  9. 自动添加菜品,加入运行中遇到的异常,生成日志文件...&lt;工作中场景...&gt;
  10. [转][C#]Environment 类
  11. vue的全局引用
  12. Linux中Postfix邮件安装Maildrop(八)
  13. HDU 2492 树状数组
  14. Linux-C语言标准输入输出
  15. 44 道 JavaScript 难题(JavaScript Puzzlers!)
  16. 王者荣耀交流协会互评Beta版本及答复功能改进建议、Bug修正
  17. linux下如何挂接(mount)光盘镜像文件、移动硬盘、U盘、Windows网络共享和NFS网络共享
  18. Pyhton网络爬虫实例_豆瓣电影排行榜_BeautifulSoup4方法爬取
  19. 问题BeanFactory not initialized or already closed - call &#39;refresh&#39; before access
  20. C# 自定义控件摘记

热门文章

  1. (Builder)创建者模式
  2. transient关键字的含义
  3. 遇到could not find developer disk image 问题怎么解决
  4. Codeforce Round #227 Div2
  5. C++的STL在C#中的应用
  6. 利用Hudson持续集成来执行Android自动化测试(转)
  7. 关于 static 的用途
  8. python2.7使用ansible
  9. Android 发送短信与接收短信
  10. 转:V$SQL,V$SQLAREA,V$SQLTEXT