Y2K Accounting Bug
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 11222   Accepted: 5655

Description

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc.


All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how
many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost
sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite.




Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

Input

Input is a sequence of lines, each containing two positive integers s and d.

Output

For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

Sample Input

59 237
375 743
200000 849694
2500000 8000000

Sample Output

116
28
300612
Deficit
对于这个题,只要分几种情况就行了
(1):当d>4*s时则十二个月最大盈利为ssssdssssdss
(2):当2*d>3*s时十二个月最大盈利为sssddsssddss
(3):当3*d>2*s时十二个月最大盈利为ssdddssdddss
(4):当4*d>s时十二个月最大盈利为sddddsddddsd
(5):当5*d>s时十二个月最大盈利为dddddddddddd
#include <cctype>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <cstdlib>
#include <iostream> using namespace std; int main()
{
int s,d;
while(~scanf("%d %d",&s,&d))
{
int sum=-1;
if(d>4*s)
{
sum=10*s-2*d;
}
else if(2*d>3*s)
{
sum=8*s-4*d;
}
else if(3*d>2*s)
{
sum=6*s-6*d;
}
else if(4*d>s)
{
sum=3*s-9*d;
}
if(sum<0)
{
cout<<"Deficit"<<endl;
}
else
{
cout<<sum<<endl;
}
}
return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

最新文章

  1. Mac OS X上编写 ASP.NET vNext(一)KRE环境搭建
  2. 如此清除sql server 2008 记住的用户名
  3. JS设置cookie、读取cookie、删除cookie
  4. 关于CCSprite不能及时显示的问题
  5. .net 设置导航的当前状态
  6. 在server 2008/2003中 取消对网站的安全检查/去除添加信任网站
  7. 关于ztree异步加载的问题(二)
  8. iOS -Swift 3.0 -UIButton属性大全
  9. ACM之Java速成(4)
  10. eclipse部署Tomcat6 : The server does not support version 3.0 of the JEE Web module specification
  11. ubuntuy用户切换和密码修改
  12. Linux dd——备份命令
  13. HDU-3790 最短路径问题
  14. .NET设计模式(9):桥接模式(Bridge Pattern)
  15. c++连接数据库 在vc6.0
  16. 后端开发者的Vue学习之路(四)
  17. 真tm郁闷
  18. T4设计时模板调试
  19. Java servlet 实现的简易购物车
  20. oracle巡检脚本备份

热门文章

  1. Lintcode: Minimum Adjustment Cost
  2. C++向量(Vector)
  3. paper 4:支持向量机系列一: Maximum Margin Classifier —— 支持向量机简介。
  4. ios学习笔记(一)Windows7上使用VMWare搭建iPhone开发环境(转)
  5. SSAS中角色(Role)定义需要注意的两个地方
  6. linux端口
  7. Android NDK 开发(三)--常见错误锦集合Log的使用【转】
  8. iOS发布条款检查表
  9. iOS录音加播放.
  10. JVM学习笔记(四)------内存调优【转】