Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways
so that it will be possible to drive between any pair of towns without leaving the highway system.




Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town
that is located at the end of both highways.



The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.

Input

The first line of input is an integer T, which tells how many test cases followed.

The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between
village i and village j. There is an empty line after each test case.

Output

For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.

Sample Input

1

3
0 990 692
990 0 179
692 179 0

Sample Output

692

题意: 先输入T,有T组数据。再输入有N个点。N行N列 每一个数据代表I点到J点的距离。求完毕一个 最小生成树种 的  最大边。


#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
#define q 505
int fa[q];
int map[q][q];
struct node{
int x,y,l;
}q[q*q/2];
int find(int x)
{
return x==fa[x]? x:find(fa[x]);
}
int cmp(node a,node b)
{
return a.l<b.l;
}
int main()
{
int k,t,n,i,j,max1;
scanf("%d",&t);
while(t--)
{
max1=0;
k=0;
scanf("%d",&n);
for(i=1;i<=n;i++)
{
fa[i]=i;
for(j=1;j<=n;j++)
{
scanf("%d",&map[i][j]);
if(i<j) // 优化:去掉重边还有中间的0
{
k++; //不知道有多少边。这样统计
q[k].x=i;
q[k].y=j;
q[k].l=map[i][j];
}
}
}
sort(q+1,q+1+k,cmp); //依据每条边的距离排序
for(i=1;i<=k;i++)
{
if(fa[find(q[i].x)]!=fa[find(q[i].y)]) //并查集思想。。 {
fa[find(q[i].x)]=find(q[i].y);
if(q[i].l>max1)
max1=q[i].l;
}
}
cout<<max1<<endl;
}
return 0;
}

Kruskal 模板。。

最新文章

  1. 深入理解URL
  2. 【读书笔记】iOS网络-测试与操纵网络流量
  3. IEquatable 的Equals 代替 object 的Equals
  4. Fault Tolerance —— Storm的故障容错性
  5. Android源码编译
  6. Linux命令之WC
  7. delphi 读网页线程TReadHtmlThread
  8. 基于visual Studio2013解决C语言竞赛题之1064互质数差1验证
  9. 腾讯公司数据分析岗位的hadoop工作 线性回归 k-means算法 朴素贝叶斯算法 SpringMVC组件 某公司的广告投放系统 KNN算法 社交网络模型 SpringMVC注解方式
  10. 在Pythonanywhere上部署Django
  11. C#、C++用GDAL读shp文件(转载)
  12. http之head请求(转)
  13. DataPipeline联合Confluent Kafka Meetup上海站
  14. ASP.Net Core项目在Mac上使用Entity Framework Core 2.0进行迁移可能会遇到的一个问题.
  15. Nginx系列一:正向代理和反向代理、Nginx工作原理、Nginx常用命令和升级、搭建Nginx负载均衡
  16. 使用GraphHttpClient调用Microsoft Graph接口 - GET
  17. 如何为已有的类没有生成toString的方法增强生成toString方法
  18. ecshop ueditor实现百度编辑器
  19. Gym 101334E Exploring Pyramids(dp+乘法原理)
  20. 30_java之DButils工具类

热门文章

  1. CircuitBreaker design pattern---reference
  2. ASP.NET中的&lt;%%&gt;介绍
  3. 6.13---example
  4. [ POI 2010 ] Antisymmetry
  5. re.S解析
  6. PHP开发心得二
  7. iOS中ARC和非ARC混用
  8. nginx报错:Permission denied
  9. CAD把一个dwg文件,或者图像文件当着一个背景导入(com接口VB语言)
  10. python队列的实现