Eddy's research I

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7537 Accepted Submission(s): 4579

Problem Description
Eddy's interest is very extensive, recently he is interested in prime number. Eddy discover the all number owned can be divided into the multiply of prime number, but he can't write program, so Eddy has to ask intelligent you to help
him, he asks you to write a program which can do the number to divided into the multiply of prime number factor .


Input
The input will contain a number 1 < x<= 65535 per line representing the number of elements of the set.
Output
You have to print a line in the output for each entry with the answer to the previous question.
Sample Input
11
9412
Sample Output
11
2*2*13*181
Author
eddy
Recommend
JGShining | We have carefully selected several similar problems for you:

pid=1215">1215

pid=1211">
1211

pid=1299">
1299

pid=1163">
1163
1128


#include<stdio.h>
int main(){
int x,i;
while(~scanf("%d",&x)){
i=2;
while(1){
if(i==x) {
printf("%d\n",i);
break;
}
if(x%i==0) {
printf("%d*",i);
x/=i;
}
else {
++i;
} }
}
return 0;
}

刚開始不明确为什么可以直接进行++i,而不再考虑 i 是否为质数,之后才明确过来: 由于从2開始分解,一直分解到剩下的因子不再可以被2整除为止,才进行对下一个数的分解,而 对于合数。它总可以分解为几个素数的乘积;然而此合数的素数因子已经在之前都被全然提取出来了,所以对于x 是合数的情况。不可能再找到 x%i==0 (注意:此处的X已经不是最開始输入的那个x了),另外:每一个素数之间又没有什么关系,先去分解哪个质数,其终于得到的质因子是全然一样的,所以也不用操心前面的分解结果会对后面的分解造成影响。!!

最新文章

  1. MySQL4.0命令操作学习笔记
  2. MySQL效能监控工具mysqlreport安装和中文说明
  3. Asp.net MVC JsonResult 忽略属性
  4. SQL中 Left Join 与 Right Join 与 Inner Join 与 Full Join的区别
  5. jquery ajax给外部变量赋值 async: false
  6. c++中string类型用下标初始化后str.size()为0 输出string值为空
  7. C#多字符分割
  8. Java学习----类的组织(包)
  9. Android学习笔记--存储方案(SharedPreference、文件IO)
  10. 处理PHP中字符串的常用操作及函数
  11. Python 面向对象基础知识
  12. RB-Tree删除详解
  13. 10. Firewalls (防火墙 2个)
  14. 关于css 的兼容设置 ----笔记
  15. composer阿里云短信服务不支持传参为数值--为2017年短信接口,2018阿里云有更新http://www.cnblogs.com/q1104460935/p/8916096.html
  16. 2017-9-17-MDIO信号线串联小电阻作用【转】
  17. Centos开机自启动脚本的制作
  18. leetcode-algorithms-2 Add Two Numbers
  19. dede调用多级导航的方法
  20. HDU 4920 Matrix multiplication(矩阵相乘)

热门文章

  1. const char *初值赋值以及文件读取
  2. springMVC小项目实例
  3. c traps and pitfalls reading note(1)
  4. Centos6.6 系统优化
  5. 企业级URL检测脚本
  6. (52)KeyError错误
  7. Visual Studio 2013 无法创建MVC项目,系统找不到指定的文件.(Exception from HRESULT:08x0070002)
  8. poj 2337 Catenyms 【欧拉路径】
  9. [MST] Remove Model Instances from the Tree
  10. hdu 4771 求一点遍历全部给定点的最短路(bfs+dfs)