Grandpa is Famous
Time Limit: 2000MS  Memory Limit: 30000K
Total Submissions: 7256  Accepted: 3670

Description

The whole family was excited by the news. Everyone knew grandpa had been an extremely good bridge player for decades, but when it was announced he would be in the Guinness Book of World Records as the most successful bridge player ever, whow, that was astonishing!
The International Bridge Association (IBA) has maintained, for several years, a weekly ranking of the best players in the world. Considering that each appearance in a weekly ranking constitutes a point for the player, grandpa was nominated the best player ever because he got the highest number of points.
Having many friends who were also competing against him, grandpa is extremely curious to know which player(s) took the second place. Since the IBA rankings are now available in the internet he turned to you for help. He needs a program which, when given a list of weekly rankings, finds out which player(s) got the second place according to the number of points.
Input

The input contains several test cases. Players are identified by integers from 1 to 10000. The first line of a test case contains two integers N and M indicating respectively the number of rankings available (2 <= N <= 500) and the number of players in each ranking (2 <= M <= 500). Each of the next N lines contains the description of one weekly ranking. Each description is composed by a sequence of M integers, separated by a blank space, identifying the players who figured in that weekly ranking. You can assume that:

in each test case there is exactly one best player and at least one second best player,

each weekly ranking consists of M distinct player identifiers.

The end of input is indicated by N = M = 0.
Output

For each test case in the input your program must produce one line of output, containing the identification number of the player who is second best in number of appearances in the rankings. If there is a tie for second best, print the identification numbers of all second best players in increasing order. Each identification number produced must be followed by a blank space.
Sample Input

4 5
20 33 25 32 99
32 86 99 25 10
20 99 10 33 86
19 33 74 99 32
3 6
2 34 67 36 79 93
100 38 21 76 91 85
32 23 85 31 88 1
0 0
Sample Output

32 33
1 2 21 23 31 32 34 36 38 67 76 79 88 91 93 100
Source

题意:爷爷打桥牌很厉害,拿得冠军。但是他还想知道,除了他,那些选手是第二(或者并列第二)。现已知每场比赛,有名次的选手的编号,请根据获得名次的次数的多少判定选手的排名,求第二(或者并列第二)的选手的编号。

#include <stdio.h>
#define MAX_LEN 10100
int sz[MAX_LEN];
int main()
{
 int n,m;
 while(scanf("%d %d",&n,&m),n||m)
 {
  int i,j,a,b=0;  
  memset(sz,0,sizeof(sz));
  for(i=0;i<n;i++)
  for(j=0;j<m;j++)
  {
   scanf("%d",&a);
   sz[a]++;
  }
  for(i=1;i<MAX_LEN;i++)
  {
   if(sz[i]==0)
   continue;
   else if(sz[i]>sz[0])
   sz[0]=sz[i];
  }
  for(i=1;i<MAX_LEN;i++)
  {
   if((sz[i]==sz[0])||(sz[i]==0))
   continue;
   else if(sz[i]>b)
   b=sz[i];
  }
  for(i=1;i<MAX_LEN;i++)
  {
   if(sz[i]==b)
   printf("%d ",i);
  }
  printf("\n");
 }
 return 0;
}

最新文章

  1. Quartz2.0以上版本的单机和集群
  2. ORA-12523: TNS: 监听程序无法找到适用于客户机连接的例程
  3. sql之left join、right join、inner join的区别
  4. Jetty使用教程(四:24-27)—Jetty开发指南
  5. hdu 5122
  6. NOIP模拟赛 行走
  7. HttpLuaModule 获取Get和Post参数
  8. MySql 5.6 查询日志
  9. [转]JavaScript 的同源策略
  10. windows 配置host
  11. JS通用表单验证函数,基于javascript正则表达式
  12. C语言内存对齐(2)
  13. 201521123111《Java程序设计》第14周学习总结
  14. jupyter 安装、配置及使用笔记
  15. UOJ#395. 【NOI2018】你的名字 字符串,SAM,线段树合并
  16. @Component注解的解析
  17. python 全栈开发,Day57(响应式页面-@media介绍,jQuery补充,移动端单位介绍,Bootstrap学习)
  18. 转载:&lt;context-param&gt;与&lt;init-param&gt;的区别与作用
  19. Iterator(迭代器)
  20. 初拾Java(问题三:乱码问题)

热门文章

  1. Android 系统开机logo的修改【转】
  2. 讲一讲WiFi快连、SmartConfig、SmartConnect
  3. 最小割板子题——[USACO5.4]奶牛的电信
  4. bzoj 1093 [ ZJOI 2007 ] 最大半连通子图 —— 拓扑+DP
  5. HTML中的文本框textarea标签
  6. Area(pick定理)
  7. Django day08 多表操作 (一) 多表模型创建
  8. go 条件语句if
  9. PHP无限级分类实现(递归+非递归)
  10. 编写linux 命令行实用工具 shell命令