[POJ1984]Navigation Nightmare

试题描述

Farmer John's pastoral neighborhood has N farms (2 <= N <= 40,000), usually numbered/labeled 1..N. A series of M (1 <= M < 40,000) vertical and horizontal roads each of varying lengths (1 <= length <= 1000) connect the farms. A map of these farms might look something like the illustration below in which farms are labeled F1..F7 for clarity and lengths between connected farms are shown as (n):

           F1 --- (13) ---- F6 --- (9) ----- F3

| |

(3) |

| (7)

F4 --- (20) -------- F2 |

| |

(2) F5

|

F7

Being an ASCII diagram, it is not precisely to scale, of course.

Each farm can connect directly to at most four other farms via roads that lead exactly north, south, east, and/or west. Moreover, farms are only located at the endpoints of roads, and some farm can be found at every endpoint of every road. No two roads cross, and precisely one path 
(sequence of roads) links every pair of farms.

FJ lost his paper copy of the farm map and he wants to reconstruct it from backup information on his computer. This data contains lines like the following, one for every road:

There is a road of length 10 running north from Farm #23 to Farm #17 
There is a road of length 7 running east from Farm #1 to Farm #17 
...

As FJ is retrieving this data, he is occasionally interrupted by questions such as the following that he receives from his navigationally-challenged neighbor, farmer Bob:

What is the Manhattan distance between farms #1 and #23?

FJ answers Bob, when he can (sometimes he doesn't yet have enough data yet). In the example above, the answer would be 17, since Bob wants to know the "Manhattan" distance between the pair of farms. 
The Manhattan distance between two points (x1,y1) and (x2,y2) is just |x1-x2| + |y1-y2| (which is the distance a taxicab in a large city must travel over city streets in a perfect grid to connect two x,y points).

When Bob asks about a particular pair of farms, FJ might not yet have enough information to deduce the distance between them; in this case, FJ apologizes profusely and replies with "-1".

输入

* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Each line contains four space-separated entities, F1,

F2, L, and D that describe a road. F1 and F2 are numbers of

two farms connected by a road, L is its length, and D is a

character that is either 'N', 'E', 'S', or 'W' giving the

direction of the road from F1 to F2. * Line M+2: A single integer, K (1 <= K <= 10,000), the number of FB's

queries * Lines M+3..M+K+2: Each line corresponds to a query from Farmer Bob

and contains three space-separated integers: F1, F2, and I. F1

and F2 are numbers of the two farms in the query and I is the

index (1 <= I <= M) in the data after which Bob asks the

query. Data index 1 is on line 2 of the input data, and so on.

输出

* Lines 1..K: One integer per line, the response to each of Bob's

queries. Each line should contain either a distance

measurement or -1, if it is impossible to determine the

appropriate distance.

输入示例

   E
E
S
N
W
S

输出示例

-

数据规模及约定

见“试题描述

题解

带权并查集,把每个关系中的位移转换成向量,然后这些向量是可以叠加的,于是就像子树权值加那样打一下懒标记搞一搞就好了。

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cctype>
#include <algorithm>
using namespace std; int read() {
int x = 0, f = 1; char c = getchar();
while(!isdigit(c)){ if(c == '-') f = -1; c = getchar(); }
while(isdigit(c)){ x = x * 10 + c - '0'; c = getchar(); }
return x * f;
} struct Vector {
int x, y;
Vector() {}
Vector(int _, int __): x(_), y(__) {}
Vector operator + (const Vector& t) const { return Vector(x + t.x, y + t.y); }
Vector operator += (const Vector& t) { *this = *this + t; return *this; }
Vector operator - (const Vector& t) const { return Vector(x - t.x, y - t.y); }
int dis() const { return abs(x) + abs(y); }
}; #define maxn 40010
#define maxq 10010 struct Que {
int u, v, k, id;
Que() {}
Que(int _1, int _2, int _3, int _4): u(_1), v(_2), k(_3), id(_4) {}
bool operator < (const Que& t) const { return k < t.k; }
} qs[maxq];
int ans[maxq]; struct Edge {
int f1, f2;
Vector Mov;
Edge() {}
Edge(int _1, int _2, Vector _3): f1(_1), f2(_2), Mov(_3) {}
} es[maxn]; int fa[maxn];
Vector tag[maxn];
int findset(int x) {
if(x == fa[x]) return x;
int t = findset(fa[x]);
tag[x] += tag[fa[x]];
return fa[x] = t;
} int main() {
int n = read(), m = read();
for(int i = 1; i <= m; i++) {
int u = read(), v = read(), l = read();
char dir[2];
scanf("%s", dir);
Vector Mov;
if(dir[0] == 'N') Mov = Vector(-l, 0);
if(dir[0] == 'S') Mov = Vector(l, 0);
if(dir[0] == 'W') Mov = Vector(0, -l);
if(dir[0] == 'E') Mov = Vector(0, l);
es[i] = Edge(u, v, Mov);
} int q = read();
for(int i = 1; i <= q; i++) {
int u = read(), v = read(), k = read();
qs[i] = Que(u, v, k, i);
}
sort(qs + 1, qs + q + 1); for(int i = 1; i <= n; i++) fa[i] = i, tag[i] = Vector(0, 0);
for(int i = 1, j = 1; i <= q; i++) {
while(j <= m && j <= qs[i].k) {
int u = findset(es[j].f1), v = findset(es[j].f2);
if(u != v) {
tag[v] = tag[es[j].f1] + es[j].Mov - tag[es[j].f2];
fa[v] = u;
}
j++;
}
int u = findset(qs[i].u), v = findset(qs[i].v);
if(u != v) ans[qs[i].id] = -1;
else ans[qs[i].id] = (tag[qs[i].u] - tag[qs[i].v]).dis();
} for(int i = 1; i <= q; i++) printf("%d\n", ans[i]); return 0;
}

最新文章

  1. js中参数不对应问题
  2. virtualBox 打开旧的ubuntu虚拟机镜像时找不到网卡的解决方法
  3. http://www.cnbeta.com/articles/306769.htm
  4. Scala 深入浅出实战经典 第39讲:ListBuffer、ArrayBuffer、Queue、Stack操作代码实战
  5. soap base64 调用
  6. [工作积累] android 中添加libssl和libcurl
  7. 【转】linux设备驱动程序之简单字符设备驱动
  8. 理解hadoop的Map-Reduce数据流(data flow)
  9. spring-mvc.xml配置文件出错
  10. 关于PowerShell中的命令的别名
  11. 读书笔记之《深入理解Java虚拟机》不完全学习总结
  12. C# winForm 窗口跳转后关闭上一个窗口的方法
  13. Web前端开发标准规范
  14. 计算几何总结(Part 1~2)
  15. CocosCreator资源工作流程
  16. HTML解析库Gumbo简单使用记录
  17. django HttpResponse的用法
  18. 获取SQL数据库表空间结构
  19. Google地图开发
  20. vRealize 7中部署blueprint如果失败,如何不让已经被provision的虚机被删掉?

热门文章

  1. RHEL6.5---LVS(IP-TUN)
  2. client系列、offset系列、scroll系列
  3. 【学习笔记】深入理解js原型和闭包(14)——从【自由变量】到【作用域链】
  4. sc服务查询
  5. 关于bin和obj文件夹。debug 和release的区别(转)
  6. 洛谷 P1216 [USACO1.5]数字三角形 Number Triangles(水题日常)
  7. Netbeans Makefile: recipe for target 'XXX' failed 运行failed(退出值 -1073741511 找不到C/C++库文件,关键字
  8. windows快捷键cmd中
  9. (转载)RedHat Enterprise Linux 5 安装GCC
  10. xls表格 拼接字段 拼json =CONCAT(&quot;{ code:&#39;&quot;,A2,&quot;&#39;,&quot;,&quot;codeName: &#39;&quot;,B2,&quot;&#39;,&quot;,&quot;flag: &#39;&quot;,C2,&quot;&#39;},&quot;)