Problem Description
There is a hill with n holes around. The holes are signed from 0 to n-1.

A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.

 
Input
The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).
 
Output
For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.
 
Sample Input
2
1 2
2 2
 
Sample Output
NO
YES
 
Author
weigang Lee
 
Source
 
Recommend
Ignatius.L
 #include <stdio.h>
#include <math.h>
#include <queue>
#include <vector>
#include <stack>
#include <map>
#include <string>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
int gcd(int a,int b){
return b==?a:gcd(b,a%b);
}
int main()
{
int n,m,t;
scanf("%d",&t);
while(t--){
scanf("%d%d",&n,&m);
if(gcd(n,m)==){
printf("NO\n");
}
else{
printf("YES\n");
}
}
return ;
}

最新文章

  1. arcgis server10.2.2发布地图基础服务的具体步骤
  2. C#动态编译代码,执行一个代码片段,或者从指定文件中加载某个接口的实现类
  3. 自增长主键Id的另类设计
  4. Python语法二
  5. Xcode插件VVDocumenter Alcatraz KSImageNamed等安装
  6. 添加Java文档注释
  7. BEvent_客制化Event Agent通道(案例)(待整理)
  8. 6-Highcharts曲线图之带标识
  9. IE浏览器打开 「兼容性视图」
  10. [转]控制反转(IOC)和依赖注入(DI)
  11. j2ee面试宝典翻译(1)
  12. Two 观察者 observer pattern
  13. 使用 eclipse 的常用操作
  14. Redis学习笔记(5)——Redis数据持久化
  15. tomcat体系结构
  16. Markdown基础(内含:锚点使用,使用HTML,新页面跳转,目录生成)
  17. ffplay源码分析5-图像格式转换
  18. TCP 流量控制、拥塞控制
  19. linux配置路径PATH问题
  20. 编写.info文件

热门文章

  1. ORACLE Install (10g r2) FOR Red Hat Enterprise Linux Server release 5.5 (64 bit) (转)
  2. Android搜索芽发展clientVersion1.0结束(过程和结果显示)
  3. Make a dent in the universe
  4. ios 动态设置Cell高低
  5. 【YouVersion】 The Bible 圣经App
  6. java nio 网络框架实现(转)
  7. POJ 3691 DNA repair 基于AC自己主动机DP
  8. etl工具,kettle实现了周期
  9. codeigniter 该脚本在运行300s超时退
  10. ProducerConsumerDemo