ACfun




Time Limit: 2000/1000MS (Java/Others)Memory Limit: 128000/64000KB (Java/Others)

Problem Description

As a former ACMer, "AC" is a special abbreviated word which can bring much pleasure to me. Sometimes it means everything.

This problem is about "AC".

One day, I write a long string S on the paper which contains "A" and "C". Now I want to find a lexicographic minimum string T satisfied that T is distinct with all substring of S.

Input

The first line of input file contains an integer T indicating the number of case.

In each test case:

Input a string S consist of "A" and "C". The length of S is not large than 100.

Output

For each test case:

You should output the string T meet the condition.

Sample Input

1
ACAC

Sample Output

AA

题意是要输出最小的字典序。且不是原字符串的的子串。。找到最长连续A子串。

由于要不属于原字符串所以再在其后加一A就可以。

在给些数据吧。

5

A

C

AACAAA

ACACA

CCCAA

AA

A

AAAA

AA

AAA

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<vector>
#include<queue> using namespace std; int main()
{
char str[108];
int ans;
int t;
scanf("%d", &t);
while( t-- )
{
scanf("%s", str);
int num=0;
ans=0;
for(int i=0; i<strlen(str); i++)
{
if(str[i]=='A')
num++;
for(int j=i+1; j<strlen(str); j++)
{
if(str[j]=='A')
num++;
if(str[j]!='A')
break;
}
if(ans<num)
ans=num;
num=0;
}
for(int i=1; i<=ans+1; i++)
cout<<"A";
cout<<endl;
} return 0;
}

版权声明:本文博主原创文章,博客,未经同意不得转载。

最新文章

  1. python中global 和 nonlocal 的作用域
  2. ReactiveCocoa源码拆分解析(七)
  3. Signing Data
  4. mysql动态行转列
  5. bash shell命令(1)
  6. android中实现简单的播放
  7. 在html页,使用ctrl,shift多选表格行
  8. gmail
  9. CSharp设计模式读书笔记(24):访问者模式(学习难度:★★★★☆,使用频率:★☆☆☆☆)
  10. 【MS SQL】通过执行计划来分析SQL性能
  11. Intelli IDEA 使用教程
  12. week5
  13. ReentrantLock(重入锁)的使用
  14. 4.数码相框-freetype多行显示,居中显示
  15. HDU 5961 传递
  16. 使用VSTS进行单元测试练习
  17. 使用客户端软件向服务端php程序发送post数据,php接受三种方法
  18. C# 在程序中控制IIS服务或应用程序池关闭重启
  19. Linux下配置镜像源
  20. 修改ligerui 默认确认按钮

热门文章

  1. C#基础总结之Attribute
  2. 【剑指offer】旋转数组的最小值
  3. BNUOJ34973Liserious战队
  4. cocos2d-x ndk adt mac 路径配置
  5. 辛星与您使用CSS导航条
  6. 抢车位中的排名bug(比較使用了无符号数)
  7. 矩形旋转碰撞,OBB方向包围盒算法实现
  8. slider使用TickPlacement获得游标效果
  9. ES6箭头函数和它的作用域
  10. 【夸QT十一】外来物品:通用脚本帮助Web运行基础Linux命令