Pseudo-Random Numbers 

Computers normally cannot generate really random numbers, but frequently are used to generate sequences of pseudo-random numbers. These are generated by some algorithm, but appear for all practical purposes to be really random. Random numbers are used in many applications, including simulation.

A common pseudo-random number generation technique is called the linear congruential method. If the last pseudo-random number generated was L, then the next number is generated by evaluating (  , where Z is a constant multiplier, I is a constant increment, and M is a constant modulus. For example, suppose Z is 7, I is 5, and M is 12. If the first random number (usually called the seed) is 4, then we can determine the next few pseudo-random numbers are follows:

As you can see, the sequence of pseudo-random numbers generated by this technique repeats after six numbers. It should be clear that the longest sequence that can be generated using this technique is limited by the modulus, M.

In this problem you will be given sets of values for ZIM, and the seed, L. Each of these will have no more than four digits. For each such set of values you are to determine the length of the cycle of pseudo-random numbers that will be generated. But be careful: the cycle might not begin with the seed!

Input

Each input line will contain four integer values, in order, for ZIM, and L. The last line will contain four zeroes, and marks the end of the input data. L will be less than M.

Output

For each input line, display the case number (they are sequentially numbered, starting with 1) and the length of the sequence of pseudo-random numbers before the sequence is repeated.

Sample Input

7 5 12 4
5173 3849 3279 1511
9111 5309 6000 1234
1079 2136 9999 1237
0 0 0 0

Sample Output

Case 1: 6
Case 2: 546
Case 3: 500
Case 4: 220
#include<stdio.h>
int main(void)
{
int z,i,m,l[10005],count=0,f;
while(scanf("%d%d%d%d",&z,&i,&m,&l[0])==4)
{
if(!z&&!i&&!m&&!l[0]) break;
count++;
int t=0,j,k;
while(1)
{
t++;
l[t]=(z*l[t-1]+i)%m;
for(j=0;j<t;j++)
if(l[t]==l[j])
goto print;
}
print: printf("Case %d: %d\n",count,t-j);
}
return 0;
}

最新文章

  1. Numpy Python
  2. CSS3-border-radius的兼容写法大全
  3. uml面向对象建模基础总结
  4. IPhone 设备状态、闪光灯状态
  5. Dining
  6. C++ —— 类的基础
  7. UNIX发展史(BSD,GNU,linux)
  8. Codeforces #541 (Div2) - E. String Multiplication(动态规划)
  9. vue父子组件之间互相获取data值&amp;调用方法(非props)
  10. React条件渲染
  11. 增加一台web机注意事项
  12. 四 分析easyswoole源码(启动服务&amp;Cache组件原理)
  13. hdu 3038 给区间和,算出多少是错的
  14. CSS属性级Hack
  15. SQLAllocHandle
  16. js--未来元素
  17. 使用EntityManager批量保存数据
  18. Locks Set by Different SQL Statements in InnoDB
  19. Spring Boot 在IDEA中debug时的hot deployment(热部署)
  20. SP_OACreate提权经验

热门文章

  1. Perl基础(1)chop与chomp的区别
  2. 安装Windows操作系统的驱动程序(驱动精灵版) - 进阶者系列 - 学习者系列文章
  3. NYOJ 58 步数最少 【BFS】
  4. C#中IList&lt;T&gt;与List&lt;T&gt;的区别
  5. SVN服务器搭建(2)
  6. SVN服务器搭建(1)
  7. Spring.Net+Nhibernate+Asp.Net Mvc 框架
  8. C# 中参数验证方式
  9. SignalR 2.0 系列: SignalR简介
  10. android通过程序收起通知栏