题目

A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range. Now given the map of the city and several candidate locations for the gas station, you are supposed to give the best recommendation. If there are more than one solution, output the one with the smallest average distance to all the houses. If such a solution is still not unique, output the one with the smallest index number.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: N (<= 103), the total number of houses; M (<= 10), the total number of the candidate locations for the gas stations; K (<= 10^4), the number of roads connecting the houses and the gas stations; and DS, the maximum service range of the gas station. It is hence assumed that all the houses are numbered from 1 to N, and all the candidate locations are numbered from G1 to GM. Then K lines follow, each describes a road in the format

P1 P2 Dist

where P1 and P2 are the two ends of a road which can be either house numbers or gas station numbers, and Dist is the integer length of the road.

Output Specification:

For each test case, print in the first line the index number of the best location. In the next line, print the minimum and the average distances between the solution and all the houses. The numbers in a line must be separated by a space and be accurate up to 1 decimal place. If the solution does not exist, simply output “No Solution”.

Sample Input 1:

4 3 11 5

1 2 2

1 4 2

1 G1 4

1 G2 3

2 3 2

2 G2 1

3 4 2

3 G3 2

4 G1 3

G2 G1 1

G3 G2 2

Sample Output 1:

G1

2.0 3.3

Sample Input 2:

2 1 2 10

1 G1 9

2 G1 20

Sample Output 2:

No Solution

题意

加油站选址,有m个位置可供选择,取离城市中最近的住房距离最远的位置,若有多个满足条件的位置,取到所有住房的平均距离最短的位置

题目分析

已知图的n个顶点、边、边权,提供另外m个顶点位置,寻找到这n个顶点最近顶点的距离最短的位置,若有多个,取到n个顶点平均距离最短的位置,打印该位置距n个顶点最近的点的距离,和到n个顶点的平均距离,精确到小数点后1位

解题思路

1 dijkstra求出每个供选择顶点到n个顶点的最近距离mindis,取所有最近距离中距离最远的位置,并记录最小距离和平均距离

易错点

1 每次个供选择的顶点位置dijkstra计算最短距离时,需要重置已访问标记数组

Code

#include <iostream>
#include <vector>
#include <algorithm>
#include <string>
using namespace std;
const int maxn=1020, INF=999999999;
int n,m,k,ds,g[maxn][maxn];
int dist[maxn],col[maxn];
void dijkstra(int u) {
fill(dist,dist+1020,INF);
fill(col,col+1020,0); //每次统计需要重置col已访问标记数组
dist[u]=0;
for(int i=1; i<=n+m; i++) {
int min=-1,mind=INF;
for(int j=1; j<=n+m; j++) {
if(col[j]==0&&dist[j]<mind) {
mind=dist[j];
min = j;
}
}
if(min==-1)break;
col[min]=1;
for(int j=1; j<=n+m; j++) {
if(g[min][j]==0||col[j]==1)continue;
if(dist[j]>dist[min]+g[min][j]) { //==说明路径相同但是顶点更多,则平均值更小 ||dist[j]==dist[min]+g[min][j]
dist[j]=dist[min]+g[min][j];
}
}
}
}
int main(int argc,char * argv[]) {
scanf("%d %d %d %d",&n,&m,&k,&ds);
string a,b;
int ia,ib,d;
for(int i=0; i<k; i++) {
cin>>a>>b>>d;
if(a[0]=='G')ia=n+stoi(a.substr(1));
else ia=stoi(a);
if(b[0]=='G')ib=n+stoi(b.substr(1));
else ib=stoi(b);
g[ia][ib]=g[ib][ia]=d; //边权
}
// 求每个位置的最短路径
int ansid=-1; // dist[n]中最小值对应的顶点--离加油站最近的顶点
double ansdis=-1,ansavgd=INF; // dist[n]中最小值 --- 距加油站最近的顶点的距离
for(int i=1; i<=m; i++) {
dijkstra(n+i);
//求平均值
double avgd=0,mindis=INF; // avgd 边权平均值; mindis加油站到所有顶点距离的最小值
for(int j=1; j<=n; j++) {
if(dist[j]>ds) {
mindis=-1;
break;
}
if(dist[j]<mindis)mindis=dist[j]; //取所有位置中离城市中最近的住宅最远的加油站位置
avgd+=(1.0*dist[j]); //记录边权
}
if(mindis==-1)continue;
avgd=avgd/n; //距离平均值
if(mindis>ansdis) {
//取离加油站最近城市最远的位置 若相等 取编号最小者
//更新路径信息
ansid=i;
ansdis=mindis;
ansavgd=avgd;
} else if(mindis==ansdis&&avgd<ansavgd) {
ansid=i;
ansavgd=avgd;
}
}
// 打印
if(ansid == -1)
printf("No Solution");
else
printf("G%d\n%.1f %.1f", ansid, ansdis, ansavgd);
return 0;
}

最新文章

  1. javascript中的浮点数运算
  2. eclipse自动补全的设置
  3. Jetty使用教程(一)——开始使用Jetty
  4. JQuery 上传文件插件 Uploadify1
  5. MYSQL双主故障解决实例。
  6. Android网络框架源码分析一---Volley
  7. 黑马程序员——【Java基础】——正则表达式
  8. Spring MVC设计模式
  9. mysql启动错误
  10. 类似NL的update更新
  11. HTTP协议(超文本传输协议)
  12. ORACLE聚合函数细节
  13. eclipse汉化教程,新手神器
  14. 【43】Activity的几种LaunchMode及使用场景
  15. python参数
  16. dom4j 通过 org.dom4j.XPath 设置命名空间来支持 带namespace 的 xpath
  17. java tomcat linux 环境变量设置
  18. 2.5 C++类class和结构体struct区别
  19. MATLAB GUI图片添加背景
  20. JS学习笔记5_DOM

热门文章

  1. HashMap ( Java 8)
  2. 夯实Java基础(十五)——Java中Comparable和Comparator
  3. RabbitMq学习笔记——MingW编译RabbitMQ C
  4. 题解:luogu P3909
  5. Android之系统自带的文字外观设置及实际显示效果图
  6. JQuery--jQuery对象与DOM对象
  7. ABC154 E - Almost Everywhere Zero
  8. zabbix4.4安装 centos7+mysql+Nginx
  9. POJ 3685:Matrix 二分
  10. Docker 学习之镜像导入导出及推送阿里云服务器(三)