The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.

Output Specification:

For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

Sample Input 2:

2
aaa -9999

Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

题目大意:

给出几个字符串,对符合条件的:

  • [−1000,1000] 之间
  • 精确度最多两位

的字符串表示的数字求均值

题解需要使用的两个新鲜函数:sscanfsprintf

sscanf

int sscanf ( const char * s, const char * format, ...);

Read formatted data from string

从字符串中读取数据

例如:

/* sscanf example */
#include <stdio.h>

int main ()
{
  char sentence []="Rudolph is 12 years old";
  char str [20];
  int i;

  sscanf (sentence,"%s %*s %d",str,&i);
  printf ("%s -> %d\n",str,i);

  return 0;
}

输出是:

Rudolph -> 12

sprintf

int sprintf ( char * str, const char * format, ... );

Write formatted data to string

将格式化的数据写到字符串中

/* sprintf example */
#include <stdio.h>

int main ()
{
  char buffer [50];
  int n, a=5, b=3;
  n=sprintf (buffer, "%d plus %d is %d", a, b, a+b);
  printf ("[%s] is a string %d chars long\n",buffer,n);
  return 0;
}

输出是:

[5 plus 3 is 8] is a string 13 chars long

所以题解是:

#include <iostream>
#include <string>
#include <cstdio>
#include<string.h>
using namespace std;

int main() {
    int N;
    cin >> N;
    int cnt = 0;
    char a[50], b[50];
    double temp, sum = 0.0;
    for (int i = 0; i < N; i++) {
        scanf("%s", a);
        sscanf(a, "%lf", &temp);
        sprintf(b, "%.2f", temp);
    	int flag = 0;
    	for (int j = 0; j < strlen(a); j++)
        	if (a[j] != b[j]) flag = 1;
    	if (flag || temp < -1000 || temp > 1000) {
        	printf("ERROR: %s is not a legal number\n", a);
        	continue;
    	}
    	else {
        	sum += temp;
        	cnt++;
    	}
}
    if(cnt == 1)
        	printf("The average of 1 number is %.2f", sum);
    else if(cnt > 1)
        	printf("The average of %d numbers is %.2f", cnt, sum / cnt);
    else
        	printf("The average of 0 numbers is Undefined");
    return 0;
}

最新文章

  1. C# 给PDF文件添加水印
  2. PHP, LDAPS and Apache
  3. 一个空行引起的阿里云负载均衡上部署https证书的问题
  4. 浅析 mondrian 模式文件 Schema
  5. freemarker 直接使用List来遍历set集合,可能会报错
  6. PAT乙级 1021. 个位数统计 (15)
  7. GreenPlum简单性能测试与分析
  8. 实战SQL Server 2005镜像配置全过程
  9. 转 关于ruby gem无法连接到rubygems.org的解决方案
  10. rubymine配置 rspec
  11. [JavaEE] Eclipse中web-inf和meta-inf文件夹的信息
  12. Win7显示隐藏文件,隐藏文件夹怎么显示?如何查看?
  13. 【ARM】S5PV210芯片中的BL0的作用
  14. 使用for循环输出空心的菱形的思路-还是没有办法理解
  15. session的一些方法
  16. 点击截图功能 js canvas
  17. socket粗解
  18. jetty 6.1 笔记
  19. lwip编译选项
  20. opengl摄像机

热门文章

  1. GitHub 网站上不去/加载慢/加载不全 解决办法
  2. 《新标准C++程序设计》1.1-1.6(C++学习笔记1)
  3. Python风格规范分享
  4. 吴裕雄--天生自然 PHP开发学习:echo 和 print 语句
  5. 深入理解Canvas Scaler
  6. 记录一道神仙CTF-wtf.sh-150
  7. contos7 共享文件夹开机自动挂载
  8. 小程序使用wxs 解决wxml保留2位小数问题
  9. pywin32获得tkinter窗口句柄,并在上面绘图
  10. javaweb02