描述

Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycles are the physical, emotional, and intellectual cycles, and they have periods of lengths 23, 28, and 33 days, respectively. There is one peak in each period of a cycle. At the peak of a cycle, a person performs at his or her best in the corresponding field (physical, emotional or mental). For example, if it is the mental curve, thought processes will be sharper and concentration will be easier.
Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give the number of days to the next occurrence of a triple peak.

输入

You will be given at most 1000000 cases. The input for each case consists of one line of four integers p, e, i, and d. The values p, e, and i are the number of days from the beginning of the current year at which the physical, emotional, and intellectual cycles peak, respectively. The value d is the given date and may be smaller than any of p, e, or i. All values are non-negative and at most 365, and you may assume that a triple peak will occur within 21252 days of the given date. The end of input is indicated by a line in which p = e = i = d = -1

输出

For each test case, print the number of days to the next triple peak, in the form:

样例输入

0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1

样例输出

21252
21152
19575
16994
8910
10789

学信安的我表示学过中国剩余定理但是做题还是不会…..

还要看别人博客才知道要用到中国剩余定理,妈卖批!!!

中国剩余定理:

基本公式为:x+d=M1*y1*p+M2*y2*e+M3*y3*i

x+d=p(mod 23);

x+d=e(mod 23);

x+d=i(mod 23);

M=23*28*33=21252,M1=924,M2=759,M3=644;

924y1=1(mod 23);

644y3=1mod 33);

(这个是由Mk*yk=1(mod mk 可以知道 至于为 什么 我还是从一 篇别人的博客里知道的 至于原因 也没有写)

可以得出来:y1=6,y2=19,y3=2;

进而:x+d=(5544*p+14421*e+1288*i)%21252;

注意:x不能是负数,所以修改为x=(5544*p+14421*e+1288*i-d+21252)%21252;

#include<cstdio>
using namespace std;
int main()
{
int p, e, i, d, icase = 0, x;
while (scanf("%d%d%d%d", &p, &e, &i, &d), ~p)
{
x = (5544 * p + 14421 * e + 1288 * i - d + 21252) % 21252;
if (x == 0)
x = 21252;
printf("%d\n",x);
}
return 0;
}

最新文章

  1. 并发包的线程池第一篇--ThreadPoolExecutor执行逻辑
  2. linux 复 带进度条
  3. (.text+0x12): undefined reference to `rpl_fprintf&#39;
  4. 实现基于Task的异步模式
  5. 也来谈谈wap端瀑布流布局
  6. linux修改密码的几种方法
  7. Java xml object 互转
  8. 20145225《Java程序设计》 实验三 &quot;敏捷开发与XP实践&quot;
  9. sql语句什么时候用双引号或者单引号
  10. iOS - OC NSNull 空值
  11. Android 操作系统的内存回收机制
  12. iOS Foundation框架 -4.NSDate类的简单用法
  13. UI进阶 KVO
  14. MaterialDialog的用法:
  15. 新项目架构从零开始(三)------基于简单ESB的服务架构
  16. Redis 高可用集群
  17. 使用d3.v5实现条形图
  18. Asp.Net任务Task和线程Thread
  19. 【mongodb】如何在mac上安装mongoDB
  20. xshell访问Ubuntu16.04显示乱码(即使在xshell设置了utf8)解决方案

热门文章

  1. Centos下Mysql密码忘记解决办法
  2. C++获取系统时间的方法
  3. HashMap 、LinkedHashMap、HashTable、TreeMap 和 Properties 的区别
  4. Linux 内核同步之自旋锁与信号量的异同【转】
  5. wait函数
  6. defconfig file 的 位置
  7. linux===Ubuntu 上安装 Node.js
  8. 【bzoj4530】大融合(LCT的子树维护)
  9. canvas画画板,canvas画五角星,canvas制作钟表、Konva写钟表
  10. [New learn]GCD的基本使用