描述

ensokyo is a world which exists quietly beside ours, separated by a mystical border. It is a utopia where humans and other beings such as fairies, youkai(phantoms), and gods live peacefully together. Shameimaru Aya is a crow tengu with the ability to manipulate wind who has been in Gensokyo for over 1000 years. She runs the Bunbunmaru News - a newspaper chock-full of rumors, and owns the Bunkachou - her record of interesting observations for Bunbunmaru News articles and pictures of beautiful danmaku(barrange) or cute girls living in Gensokyo. She is the biggest connoisseur of rumors about the girls of Gensokyo among the tengu. Her intelligence gathering abilities are the best in Gensokyo!

During the coming n days, Aya is planning to take many photos of m cute girls living in Gensokyo to write Bunbunmaru News daily and record at least Gx photos of girl x in total in the Bunkachou. At the k-th day, there are Ck targets, Tk1Tk2, ..., TkCk. The number of photos of target Tki that Aya takes should be in range [LkiRki], if less, Aya cannot write an interesting article, if more, the girl will become angry and use her last spell card to attack Aya. What's more, Aya cannot take more than Dk photos at the k-th day. Under these constraints, the more photos, the better.

Aya is not good at solving this complex problem. So she comes to you, an earthling, for help.

Input

There are about 40 cases. Process to the end of file.

Each case begins with two integers 1 <= n <= 365, 1 <= m <= 1000. Then m integers, G1G2, ..., Gm in range [0, 10000]. Then n days. Each day begins with two integer 1 <= C <= 100, 0 <= D <= 30000. Then C different targets. Each target is described by three integers, 0 <= Tm, 0 <= L <= R <= 100.

Output

For each case, first output the number of photos Aya can take, -1 if it's impossible to satisfy her needing. If there is a best strategy, output the number of photos of each girl Aya should take at each day on separate lines. The output must be in the same order as the input. If there are more than one best strategy, any one will be OK.

Output a blank line after each case.

Sample Input

2 3
12 12 12
3 18
0 3 9
1 3 9
2 3 9
3 18
0 3 9
1 3 9
2 3 9 2 3
12 12 12
3 18
0 3 9
1 3 9
2 3 9
3 18
0 0 3
1 3 6
2 6 9 2 3
12 12 12
3 15
0 3 9
1 3 9
2 3 9
3 21
0 0 3
1 3 6
2 6 12

Sample Output

36
6
6
6
6
6
6 36
9
6
3
3
6
9 -1

题意:

大致是说一个男生要个其他女生拍照,总共拍N天,总共有M个女生,

接下来一行是说M个女生,每个女生至少要拍照的数量

然后每天都有自己的拍照计划,给多少女生拍照,今天拍照的总数量

接下来一行是对于女生x,这一天拍照的上限L和下限R

题解:

有源汇上下界最大流,先建图,首先源点和每天连线,上届是这一天拍照总数,下界是0,每一天再和当天拍照的女生建边,上下界是L,R,每个女生和汇点建边,上下界是INf,和给这个女生拍照的最少数量。

然后转换为无源汇上下界最大流,建立超级源点和汇点,跑最大流看是否满流,是则,再跑一遍,求出最大流,否输出-1

#pragma GCC optimize(2)
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
#define inf 0x3f3f3f3f
#define ll long long
#define MAXN 30000
using namespace std;
int n,m;//点数、边数
int sp,tp;//原点、汇点
struct node
{
int v,next;
ll cap;
}mp[MAXN*10];
int pre[MAXN],dis[MAXN],cur[MAXN];//cur为当前弧优化,dis存储分层图中每个点的层数(即到原点的最短距离),pre建邻接表
int cnt=0;
void init()//不要忘记初始化
{
cnt=0;
memset(pre,-1,sizeof(pre));
}
void add(int u,int v,int w)//加边
{
mp[cnt].v=v;
mp[cnt].cap=w;
mp[cnt].next=pre[u];
pre[u]=cnt++;
mp[cnt].v=u;
mp[cnt].cap=0;
mp[cnt].next=pre[v];
pre[v]=cnt++;
}
bool bfs()//建分层图
{
memset(dis,-1,sizeof(dis));
queue<int>q;
while(!q.empty())
q.pop();
q.push(sp);
dis[sp]=0;
int u,v;
while(!q.empty())
{
u=q.front();
q.pop();
for(int i=pre[u];i!=-1;i=mp[i].next)
{
v=mp[i].v;
if(dis[v]==-1&&mp[i].cap>0)
{
dis[v]=dis[u]+1;
q.push(v);
if(v==tp)
break;
}
}
}
return dis[tp]!=-1;
}
ll dfs(int u,ll cap)//寻找增广路
{
if(u==tp||cap==0)
return cap;
ll res=0,f;
for(int &i=cur[u];i!=-1;i=mp[i].next)
{
int v=mp[i].v;
if(dis[v]==dis[u]+1&&(f=dfs(v,min(cap-res,mp[i].cap)))>0)
{
mp[i].cap-=f;
mp[i^1].cap+=f;
res+=f;
if(res==cap)
return cap;
}
}
if(!res)
dis[u]=-1;
return res;
}
ll dinic()
{
ll ans=0;
while(bfs())
{
for(int i=0;i<=tp;i++)
cur[i]=pre[i];
ans+=dfs(sp,inf);
}
return ans;
}
int d[MAXN],a[MAXN];
int g[400][1100];
int st[400][1100];
int main() {
while(scanf("%d%d",&n,&m)!=EOF)
{
init();
memset(d,0, sizeof(d));
int sum=0;
int x;
for (int i = 1; i <=m ; ++i) {
scanf("%d",&x);
add(n+i,n+m+1,inf);
d[n+i]-=x;
d[n+m+1]+=x;
}
int b;
for (int i = 1; i <=n ; ++i) {
scanf("%d%d",&a[i],&b);
add(0,i,b);
int l,r;
for (int j = 0; j <a[i] ; ++j) {
scanf("%d%d%d",&x,&l,&r);
add(i,n+x+1,r-l);
d[i]-=l;
d[n+x+1]+=l;
st[i][j]=l;
g[i][j]=(cnt-2);
}
}
add(n+m+1,0,inf); for (int i = 0 ; i <=n+m+1 ; ++i) {
if(d[i]>0)
{
add(n+m+2,i,d[i]);
sum+=d[i];
}
if(d[i]<0)
{
add(i,n+m+3,-d[i]);
}
}
sp=n+m+2;tp=n+m+3;
if(sum!=dinic())
{
printf("-1\n");
}
else
{
sp=0,tp=n+m+1;
printf("%lld\n",dinic());
for (int i = 1; i <=n ; ++i) {
for (int j = 0; j <a[i] ; ++j) {
printf("%lld\n",mp[g[i][j]+1].cap+(ll)st[i][j]);
}
} }
printf("\n");
}
return 0;
}
//zoj3229
//loj116

  

最新文章

  1. php中的M方法
  2. ArcGIS空间分析工具
  3. 操作系统也谈&quot;算法&quot;
  4. 利用WSCF进行契约先行的Web Services开发
  5. LINUX第五次实验报告
  6. 关于StartCoroutine的简单线程使用
  7. QLineEdit 仿QQ签名框(思路很独特:用QSS::hover显示额外的图片)
  8. 序列化和反序列化,异步调用web/wcf/函数
  9. WCF - 绑定后续之自定义绑定
  10. 编译protobuf-2.5.0中的错误处理
  11. Android源码大全
  12. Sql Server Convert函数转换Datetime类型数据
  13. MySQL 改动用户password及重置rootpassword
  14. awstats 日志分析
  15. MySQL触发器更新和插入操作
  16. Elastic 开发篇(3)
  17. csharp C#数字字符串排序orderby的问题解决
  18. HDU1349 Minimum Inversion Number 2016-09-15 13:04 75人阅读 评论(0) 收藏
  19. Anaconda之常用命令
  20. 【LDAP】LDAP常用命令解析

热门文章

  1. Vue2自定义指令改变DOM值后未刷新data中绑定属性的值
  2. ring0 ShadowSSDTHook
  3. April 2 2017 Week 14 Sunday
  4. April 1 2017 Week 13 Saturday
  5. 2018.9.28 典型for循环特殊理解及其二维数组的理解
  6. ABP问题记录
  7. Hinge Loss
  8. 解决adb devices无法连接夜神模拟器
  9. P2979 [USACO10JAN]奶酪塔Cheese Towers
  10. scala性能测试