时间限制:1 秒

内存限制:32 兆

特殊判题:否

提交:492

解决:219

题目描述:

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where
their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an
odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

For example, 3 games' odds are given as the following:

 W    T    L
1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1*3.0*2.5*65%-1)*2 = 37.98 yuans (accurate up to 2 decimal places).

输入:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

输出:

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

样例输入:
1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1
样例输出:
T T W 37.98

思路:

其实就是一个数学算式。

代码:

#include <stdio.h>
#include <string.h> #define N 3 char mtoc(int m)
{
if (m == 0)
return 'W';
if (m == 1)
return 'T';
return 'L';
} int main(void)
{
int n, i, j;
double a[N][N];
int max[N]; n = N;
while (scanf("%lf", &a[0][0]) != EOF)
{
memset(max, 0, sizeof(max));
for(i=0; i<n; i++)
{
for(j=0; j<n; j++)
{
if (i == 0 && j == 0)
continue;
scanf("%lf", &a[i][j]);
if (a[i][j] > a[i][max[i]])
max[i] = j;
}
} double res = (a[0][max[0]]*a[1][max[1]]*a[2][max[2]]*0.65-1)*2;
printf("%c %c %c %.2lf\n", mtoc(max[0]),
mtoc(max[1]), mtoc(max[2]), res);
} return 0;
}
/**************************************************************
Problem: 1323
User: liangrx06
Language: C
Result: Accepted
Time:0 ms
Memory:912 kb
****************************************************************/

最新文章

  1. 【HTML5&amp;CSS3进阶03】Jser与Csser如何一起愉快的翻新老组件
  2. SSAS:OLE DB 错误: OLE DB 或 ODBC 错误 : Login failed for user &#39;NT Service\MSSQLServerOLAPService&#39;
  3. Session的工作机制详解和安全性问题(PHP实例讲解)
  4. linux yum 命令 详解
  5. Google 推出全新的两步验证机制
  6. 火狐无法访问本机IIS部署的网站,弹出:此地址使用了一个通常用于网络浏览以外目的的端口.出于安全原因,Firefox 取消了该请求 的解决办法
  7. LVM(2)逻辑卷的扩展、缩减、快照卷
  8. 特里-HDOJ-1671
  9. 空间表SpaceList
  10. JAVA的HashSet源码分析
  11. 《Thinking in Java》学习笔记(一)
  12. C# 读取 appconfig文件配置数据库连接字符串,和配置文件
  13. Git设置彩色输出
  14. 【JavaScript】jQuery
  15. 一个网工的Linux学习过程
  16. Apache cxf暴露接口以及客户端调用之WebService初步理解
  17. Aspect实现对方法日志的拦截记录
  18. PNG文件结构
  19. statik golang 静态资源嵌入二进制文件工具使用(docker 构建)
  20. 《沉静领导》读书笔记zz

热门文章

  1. python git log
  2. 一个java调用python的问题
  3. JPEG编码(一)
  4. CentOS7下挂载硬盘笔记
  5. 新装系统(CentOS7.4)环境初始化配置笔记
  6. Win7下nginx默认80端口被System占用,造成nginx启动报错的解决方案
  7. EffectiveJava(21)策略模式多种方式实现字符串比较
  8. C#程序不包含适合于入口点的静态“Main”方法怎么办
  9. 未能加载文件或程序集 MySql.Web
  10. 简单的 nginx 多站点配置