Quicksum

Time Limit: 2000/1000 MS (Java/Others)

Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3516 Accepted Submission(s): 2579

Problem Description

A checksum is an algorithm that scans a packet of data and returns a single number. The idea is that if the packet is changed, the checksum will also change, so checksums are often used for detecting transmission errors, validating document contents, and in many other situations where it is necessary to detect undesirable changes in data.

For this problem, you will implement a checksum algorithm called Quicksum. A Quicksum packet allows only uppercase letters and spaces. It always begins and ends with an uppercase letter. Otherwise, spaces and letters can occur in any combination, including consecutive spaces.

A Quicksum is the sum of the products of each character’s position in the packet times the character’s value. A space has a value of zero, while letters have a value equal to their position in the alphabet. So, A=1, B=2, etc., through Z=26. Here are example Quicksum calculations for the packets “ACM” and “MID CENTRAL”:

ACM: 1*1 + 2*3 + 3*13 = 46

MID CENTRAL: 1*13 + 2*9 + 3*4 + 4*0 + 5*3 + 6*5 + 7*14 + 8*20 + 9*18 + 10*1 + 11*12 = 650

Input

The input consists of one or more packets followed by a line containing only # that signals the end of the input. Each packet is on a line by itself, does not begin or end with a space, and contains from 1 to 255 characters.

Output

For each packet, output its Quicksum on a separate line in the output.

Sample Input

ACM

MID CENTRAL

REGIONAL PROGRAMMING CONTEST

ACN

A C M

ABC

BBC

Sample Output

46

650

4690

49

75

14

15

题意分析:

水题。每个英文字母在字符串的的位置乘英文字母在字母表中的位置求和即可。注意空格也算一个字符。

代码:

/*
Title:HDU.2734
Date:2016-9-30
Author:pengwill
Blog: http://blog.csdn.net/pengwill97
*/
#include<stdio.h>
#include<string.h>
int main()
{
int sum= 0;
char ch[300];
while(gets(ch) && ch[0] != '#'){
int len = strlen(ch);
int i;
sum = 0;
for(i = 0;i<len;i++){
if(ch[i] == ' '){
continue;
}else{
sum+=(i+1) * (ch[i] - 64);
}
}
printf("%d\n",sum);
}
return 0;
}

最新文章

  1. AFNetworking 3.0 源码解读(八)之 AFImageDownloader
  2. python27 windows 下三种安装第三方库的办法
  3. Matlab 进阶学习记录
  4. 之三:CAAnimationGroup - 动画组
  5. 简单几何(点与线段的位置) POJ 2318 TOYS &amp;&amp; POJ 2398 Toy Storage
  6. 【NOI2015】荷马史诗
  7. Jar mismatch! Fix your dependencies
  8. Java Day 04
  9. TCP 滑动窗口和 拥塞窗口
  10. Project Euler 92:Square digit chains 平方数字链
  11. jQuery Callback 方法
  12. redis在Java web项目的简单应用(转载)
  13. Monkey学习笔记&lt;四&gt;:Monkey服务器命令
  14. 如何更改Java括号中的默认对齐
  15. Spring集成RabbiMQ-Spring AMQP新特性
  16. C#中委托和事件的区别
  17. 武汉软件开发:一看就会的wpf入门教程
  18. centos 7 vim 保存文件 root 权限 及 使用
  19. centos下配置DNS
  20. nxn随机矩阵乘以概率向量依旧是概率向量

热门文章

  1. java中i=i++的解析
  2. 怎样安装Android Studio
  3. laravel 的DB::raw() 语法使用
  4. Elasticsearch 相同内容文档,不同score(评分)的奇怪问题
  5. 七:HDFS Permissions Guide 权限
  6. 事后分析报告(M2阶段)
  7. Huffuman树
  8. oracle数据库之存储函数和过程
  9. 福大软工1816:Alpha(5/10)
  10. ALPHA-3