Shortest Prefixes
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 15574   Accepted: 6719

Description

A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem, but every non-empty string
is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word the shortest prefix that
uniquely identifies the word it represents. 



In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo". 



An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list
that begins with "car". 

Input

The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.

Output

The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.

Sample Input

carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate

Sample Output

carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car
carbonate carbona

看完题后,感慨:简直不能忍,这么裸的字典树。接下来就是无脑式敲 Trie 树了。这个题目能够拿来练练手速~。另外。一时没到比較合适的函数名,望 勿喷

题解就略了,容我贴下代码~

/****************************>>>>HEADFILES<<<<****************************/
#include <cmath>
#include <queue>
#include <vector>
#include <cstdio>
#include <string>
#include <cstring>
#include <iomanip>
#include <iostream>
#include <sstream>
#include <algorithm>
using namespace std;
/****************************>>>>>DEFINE<<<<<*****************************/
//#pragma comment(linker, "/STACK:1024000000,1024000000")
#define FIN freopen("input.txt","r",stdin)
#define FOUT freopen("output.txt","w",stdout)
#define rep(i,a,b) for(int i = a;i <= b;i++)
#define rep1(i,a) for(int i = 1;i <= a;i++)
#define rep0(i,a) for(int i = 0;i < a;i++)
#define MP(a,b) make_pair(a,b)
#define PB(a) push_back(a)
#define fst first
#define snd second
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
/****************************>>>>>>DEBUG<<<<<<****************************/
#define out(x) cout<<x<<""
/****************************>>>>SEPARATOR<<<<****************************/
const int maxk = 26;
const int maxl = 20+5;
int N,M;
struct Node
{
int cnt;
Node* pNext[maxk];
Node() : cnt(0)
{
rep0(i,maxk) pNext[i] = NULL;
}
};
struct Trie
{
Node* const pRoot;
Trie() : pRoot(new Node()) {}
void AddWord(const char str[],int len);
// int FindPredix(const char str[],int len);
void Query(const char str[],int len);
void Release(const Node *p);
}dic;
void Trie::AddWord(const char str[],int len)
{
Node* ptr = pRoot;
for(int i = 0;i < len;i++)
{
int nPos = str[i] - 'a';
if(ptr->pNext[nPos] == NULL) ptr->pNext[nPos] = new Node();
ptr->cnt++;
ptr = ptr->pNext[nPos];
}
ptr->cnt++;
}
void Trie::Release(const Node* p)
{
for(int i = 0;i < maxk;i++) if(p->pNext[i] != NULL) Release(p->pNext[i]);
delete p;
}
void Trie::Query(const char str[],int len)
{
Node* ptr = pRoot;
for(int i = 0;i < len;i++)
{
int nPos = str[i] - 'a';
if(ptr->pNext[nPos] == NULL) return;
if(ptr->cnt == 1) return;
putchar(str[i]);
ptr = ptr->pNext[nPos];
}
}
char buf[1005][maxl];
int main()
{
//FIN;
int cnt = 0;
while(~scanf("%s",buf[cnt]))
dic.AddWord(buf[cnt],strlen(buf[cnt])),cnt++;
for(int i = 0;i < cnt;i++)
{
printf("%s ",buf[i]);
dic.Query(buf[i],strlen(buf[i]));
puts("");
}
dic.Release(dic.pRoot);
return 0;
}

最新文章

  1. [Python] Create a Django project in Pycharm
  2. ASP.NET获取客户端IP/用户名等信息
  3. js中event.keyCode用法及keyCode对照表
  4. MATLAB plot画线的颜色设定
  5. C++中不常用关键字
  6. CentOS 7学习笔记(二)之Nginx安装
  7. C#设计模式学习资料--观察者模式
  8. C++编译器函数模版机制剖析 - 函数模版的本质
  9. Ubuntu 12安装Virtualbox
  10. javascript中算术运算符规则
  11. Windows Phone 8初学者开发—第17部分:Coding4Fun工具包简介
  12. 第一个asp.net MVC5+ExtJS6入门案例项目
  13. 【tomcat】Web环境(tomcat)下新增一个访问路径(虚拟路径)
  14. 【网络编程1】网络编程基础-TCP、UDP编程
  15. jQuery插件实践之轮播练习(一)
  16. PHP 将大量数据导出到 Excel 的方法
  17. SDRAM初识
  18. 《HTTP权威指南》学习笔记——URL和资源
  19. react-native 相关问题
  20. pandas基础整理

热门文章

  1. CentOS下安装netcat
  2. home.php
  3. BZOJ-3190 [JLOI2013]赛车
  4. [HNOI2011][bzoj 2329] 括号修复 [splay+前缀和]
  5. Cmake——CMake+SVN或Hg生成版本号
  6. val
  7. 刷题总结——次小生成树(bzoj1977 最小生成树+倍增)
  8. Java面试题之Integer.valueOf(String s);采用了什么设计模式
  9. 【bzoj2400】Spoj 839 Optimal Marks 按位最大流
  10. 第一个nodejs爬虫:爬取豆瓣电影图片