Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

Input Specification:

Each input file contains one test case. Each case is given in the following format:

N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
... ...
name[N] ID[N] grade[N]
grade1 grade2

where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade's interval. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student's name and ID, separated by one space. If there is no student's grade in that interval, output NONE instead.

Sample Input 1:
4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100
Sample Output 1:
Mike CS991301
Mary EE990830
Joe Math990112
Sample Input 2:
2
Jean AA980920 60
Ann CS01 80
90 95
Sample Output 2:
NONE
思路
  • 用结构体数组存储数据,一次排序之后+一次遍历输出符合条件的人的信息就好了
代码
#include<bits/stdc++.h>
using namespace std;
struct student
{
string name, id;
int grade;
}a[10010]; bool cmp(student a, student b)
{
return a.grade < b.grade;
} int main()
{
int n;
cin >> n;
for(int i=0;i<n;i++)
cin >> a[i].name >> a[i].id >> a[i].grade;
sort(a, a+n, cmp);
int l, r;
bool finded = false; //表示是否至少有一个输出
cin >> l >> r;
if(l > r) swap(l,r);
for(int i=n-1;i>=0;i--) //题目要求的是分数按高到低排,所以倒过来遍历
{
if(a[i].grade >= l && a[i].grade <= r)
{
finded = true;
cout << a[i].name << " " << a[i].id << endl;
}
}
if(!finded)
cout << "NONE";
return 0;
}
引用

https://pintia.cn/problem-sets/994805342720868352/problems/994805383929905152

最新文章

  1. 一起学微软Power BI系列-官方文档-入门指南(2)获取源数据
  2. C#基础系列——反射笔记
  3. 设置float之后vertical-align失效
  4. 如何让C#像JavaScript一样编程
  5. django view
  6. HTML报表日期格式不对 导致报错ORA-01861: 文字与格式字符串不匹配
  7. [原]1856-More is better-基础并查集
  8. SecureCRTPortable的安装和使用
  9. C#中的委托用法
  10. thinkphp连接mysql5.5版本数据库
  11. Android 通过HTTP GET请求互联网数据
  12. Asp.net Mvc4默认权限详细(上)
  13. PAT (Advanced Level) 1105. Spiral Matrix (25)
  14. memset库函数
  15. Python day 4
  16. MVC与单元测试实践之健身网站(七)-添加计划
  17. Scala学习笔记2 (带着问题学习, 逐渐扩展。理解吃透scala.)
  18. 原来Github上的README.md文件这么有意思——Markdown语言详解(sublime text2 版本)
  19. [EWS]查找 文件夹
  20. VMware vCenter Server 6.5.0 U1g

热门文章

  1. Maven手动将jar导入本地仓库
  2. Codeforces Round #346 (Div. 2) C题
  3. Mac出现程序闪退的解决方案
  4. 微信小程序填坑之旅(1)-app.js中用云开发获取openid,在其他页上用app.globaldata.openid获取为空
  5. java new一个对象的过程中发生了什么
  6. 第一次尝试学习java 安装jdk 与配置环境变量 写第一个java程序 并运行
  7. ACM之路(14)—— 线段树的日常(上)
  8. async for 在爬虫中的使用例子
  9. Vbox中多台虚拟机搭建简单子网
  10. LeetCode 229. 求众数 II(Majority Element II )