Ignatius and the Princess II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 4865    Accepted Submission(s): 2929
Problem Description
Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if
you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."



"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once
in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"

Can you help Ignatius to solve this problem?
 
Input
The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of
file.
 
Output
For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.
 
Sample Input
6 4
11 8
 
Sample Output
1 2 3 5 6 4
1 2 3 4 5 6 7 9 8 11 10
 

注意:由于1000的阶乘太大,并且M小于等于10000,所以我们仅仅须要算到阶乘大于10000的为就能够了,也就是8。。之后推断是不是第八位的特殊推断就可以。

代码:

#include <stdio.h>
#include <string.h>
int a[9] = {1, 1, 2, 6, 24, 120, 720, 5040, 40320};
int vis[1005];
int main(){
int n, m;
while(scanf("%d%d", &n, &m) == 2){
memset(vis, 0, sizeof(vis));
m -= 1;
int cou, temp = 1;
while(temp < n){
if((n - temp) <= 8){
int s = m/a[n-temp];
int p = m%a[n-temp];
int c = 0;
for(int i = 1; i <= n; i ++){
if(!vis[i]) ++c;
if((c-1) == s){
printf("%d ", i);
vis[i] = 1; break;
}
}
m = p;
}
else{
for(int i = 1; i <= n; i ++){
if(!vis[i]) {
vis[i] = 1;
printf("%d ", i); break;
}
}
}
++temp;
}
for(int i = 1; i <= n; i ++){
if(!vis[i]) printf("%d\n", i);
}
}
return 0;
}

最新文章

  1. PHP 版本判断 version_compare() 函数
  2. iOS-网络处理
  3. python基础2(数据类型、数据运算、for循环、while循环、列表)
  4. 初次使用并安装express
  5. ios安装cocoaPods
  6. :selected
  7. IOS6屏幕旋转详解(自动旋转、手动旋转、兼容IOS6之前系统)
  8. 策略模式c++【转】
  9. 转载 Javascript继承两种形式详解
  10. risc与cisc
  11. 怒刷DP之 HDU 1029
  12. 剖析magento中关于Email模板的设置
  13. urlretrieve
  14. WinForm下的loading框实现
  15. java模拟链表
  16. 【重学计算机】机组D8章:输入输出系统
  17. React 记录(5)
  18. Git 分支合并:合并某次提交
  19. loadrunner函数解密之web_reg_find
  20. C#代码覆盖率实践-vsinstr和OpenCover

热门文章

  1. tarfile模块可以方操作tar归档文件
  2. Eureka集群试验的一点总结
  3. 转:Windows消息机制要点
  4. 执行Android项目时指定特定的AVD进行測试
  5. JavaScript-event参数传递详解
  6. XP系统下建立WIFI热点让手机、电脑能上网
  7. oc set/get方法
  8. 关于父进程和子进程的关系(UAC 绕过思路)
  9. apache主机(网站)配置,port监听,文件夹訪问权限及分布式权限
  10. CodeForces 550A Two Substrings(模拟)