链接:



Arbitrage
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 13067   Accepted: 5493

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French
franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 



Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear.
The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency.
Exchanges which do not appear in the table are impossible. 

Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar 3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar 0

Sample Output

Case 1: Yes
Case 2: No

Source



题意:


      判断是否存在使得汇率增多的环

    【任意一个点的汇率增多都可以】

算法:bellman_ford 判断“正环”

注意:

          这里的松弛操作要循环 N 次才能过,

       书上的松弛操作一直都是 N-1 次

       对于为什么是 N 或者 N-1 次一直没有理解清楚

code:

2240 Accepted 224K 110MS C++ 1781B

/*******************************************************
题意:判断是否存在使得汇率增多的环
【任意一个点的汇率增多都可以】
算法:bellman_ford 判断正环
注意:这里的松弛操作要循环 N 次才能过,
书上的松弛操作一直都是 N-1 次
对于为什么是 N 或者 N-1 次一直没有理解清楚
********************************************************/
#include<stdio.h>
#include<string.h>
#include<string>
#include<map>
#include<algorithm>
#include<iostream>
using namespace std; const int maxn = 40;
double d[maxn];
int n,m; struct Edge{
int u,v;
double r;
}edge[maxn*maxn];
map<string, int> mp; bool bellman_ford(int s)
{
memset(d,0,sizeof(d));
d[s] = 1;
for(int i = 1; i <= n; i++)
{
for(int j = 0; j < m; j++)
{
int u = edge[j].u;
int v = edge[j].v;
double r = edge[j].r;
if(d[v] < d[u]*r)
d[v] = d[u]*r;
}
}
if(d[s] > 1.0) return true;
else return false;
} int main()
{
int kcase = 0;
while(scanf("%d", &n) != EOF)
{
if(n == 0) break;
mp.clear(); string s;
for(int i = 1; i <= n; i++)
{
cin>>s;
mp[s] = i;
} scanf("%d", &m);
string s1,s2;
double rat;
for(int i = 0; i < m; i++)
{
cin>>s1>>rat>>s2;
edge[i].u = mp[s1];
edge[i].v = mp[s2];
edge[i].r = rat;
} bool flag = false;
for(int i = 1; i <= n; i++)
{
if(bellman_ford(i))
{
flag = true;
break;
}
}
printf("Case %d: ", ++kcase);
if(flag) printf("Yes\n");
else printf("No\n");
}
return 0;
}



还是用 floyd 简单方便了Orz

 /*******************************************************
题意:判断是否存在使得汇率增多的环
【任意一个点的汇率增多都可以】
算法:floyd 简单变形
w[i][j] = max(w[i][j], w[i][k]*w[k][j]) ********************************************************/
#include<stdio.h>
#include<string.h>
#include<string>
#include<map>
#include<algorithm>
#include<iostream>
using namespace std; const int maxn = 40;
double d[maxn];
int n,m; double w[maxn][maxn];
map<string, int> mp; void floyd()
{
for(int k = 1; k <= n; k++)
for(int i = 1; i <= n; i++)
for(int j = 1; j <= n; j++)
w[i][j] = max(w[i][j], w[i][k]*w[k][j]);
} int main()
{
int kcase = 0;
while(scanf("%d", &n) != EOF)
{
if(n == 0) break;
mp.clear(); string s;
for(int i = 1; i <= n; i++)
{
cin>>s;
mp[s] = i;
w[i][i] = 1; //自己到自己的汇率为 1, 注意这个初始化必须写在下面建图前面。。。
} scanf("%d", &m);
string s1,s2;
double rat;
for(int i = 0; i < m; i++)
{
cin>>s1>>rat>>s2;
w[mp[s1]][mp[s2]] = rat;
} floyd(); int flag = 0;
for(int i = 1; i <= n; i++)
{
if(w[i][i] > 1.0)
{
flag = 1; break;
}
}
printf("Case %d: ", ++kcase);
if(flag) printf("Yes\n");
else printf("No\n");
}
return 0;
}





最新文章

  1. JVM大端判断
  2. Python列表
  3. Hibernate5.2之一对一外键关联(五)
  4. Java 分页通用
  5. socket阻塞与非阻塞,同步与异步
  6. 给深度学习入门者的Python快速教程 - numpy和Matplotlib篇
  7. js中日历的代码
  8. iOS学习笔记---C语言第三天
  9. linux oracle profile配置
  10. cxGrid使用汇总1
  11. [面试题] for() while() 条件判断 赋值问题
  12. iOS网络通信类库
  13. 五毛的cocos2d-x学习笔记01-创建项目
  14. 剑指offer ------ 刷题总结
  15. 关于项目刚才还能运行的,重启Myeclipse就不能运行(报错)的解决方法
  16. 装 ubuntu + win10 出现 grub rescue 并处理之
  17. 使用Docker for Windows初体验
  18. 最全的MonkeyRunner自动化测试从入门到精通(4)
  19. CF741D Arpa’s letter-marked tree and Mehrdad’s Dokhtar-kosh paths
  20. Linux 查看文件编码

热门文章

  1. windows 开启端口
  2. iOS10.0 &amp; Swift 3.0 对于升级项目的建议
  3. cesium图形上加载图片
  4. 移动端meta 解释
  5. 从头认识java-16.5 nio的数据转换
  6. 深入分析JavaWeb Item43 -- Struts2开发入门
  7. PHP-006
  8. 【RF库Collections测试】Get Index From List
  9. SaltStack 如何自定义 grains 信息
  10. XMPP HTTP