题目链接:

http://poj.org/problem?id=2524

Ubiquitous Religions
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 39369   Accepted: 18782

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7

Hint

Huge input, scanf is recommended.
分析:
裸的并查集(我觉得叫查并集更好)
代码如下:
#include<stdio.h>
#include<iostream>
using namespace std;
#define max_v 50005
int pa[max_v];//pa[x] 表示x的父节点
int rk[max_v];//rk[x] 表示以x为根结点的树的高度
int n,ans;
void make_set(int x)
{
pa[x]=x;
rk[x]=0;//一开始每个节点的父节点都是自己
}
int find_set(int x)//带路径压缩的查找
{
if(x!=pa[x])
pa[x]=find_set(pa[x]);
return pa[x];
}
void union_set(int x,int y)
{
x=find_set(x);//找到x的根结点
y=find_set(y);
if(x==y)//根结点相同 同一棵树
return ;
ans--;
if(rk[x]>rk[y])
{
pa[y]=x;
}else
{
pa[x]=y;
if(rk[x]==rk[y])
rk[y]++;
}
}
int main()
{
int n,m,j=0;
while(~scanf("%d %d",&n,&m))
{
if(m+n==0)
break;
for(int i=1;i<=n;i++)
{
make_set(i);
}
ans=n;
for(int i=0;i<m;i++)
{
int x,y;
scanf("%d %d",&x,&y);
union_set(x,y);
}
printf("Case %d: %d\n",++j,ans);
}
return 0;
}

  

最新文章

  1. c#常用方法
  2. linux 命令笔记
  3. Linux 中断处理浅析
  4. Android学习笔记——button_activity
  5. CMS如何提供XML格式的接口
  6. jquery 连写注释;siblings() 方法;jQuery 的3种滑动方法;slideUp()向上滑动;slideDown()向下滑动;slideToggle()来回滑动
  7. 小改动,大作为——C# 4.0中的微小改动
  8. 基于visual Studio2013解决C语言竞赛题之1048打印矩阵
  9. 第m个全排列
  10. 【Hibernate步步为营】--映射合集汇总
  11. POJ1182--食物链(经典并查集)并查集看不出来系列2
  12. Raid类型
  13. Ditto在教学上的应用
  14. Element-ui使用技巧
  15. [物理学与PDEs]第5章习题4 广义 Hookean 定律的张量的对称性
  16. vue2项目结构搭建
  17. Redis(转)
  18. python:函数初始
  19. delphi ios info.plist
  20. java 爬虫

热门文章

  1. .NET 垃圾回收浅解
  2. jQuery bind()与delegate()的区别
  3. laravel之注册中间件
  4. prince2的市场使用规模有多大?
  5. centos7 安装 maven 和ant git 以及 rocketmq 4.2安装过程(安装成功,调用失败)
  6. vim常用快捷汇总
  7. 如何解决MSSQL中文数据乱码问题
  8. Python 装饰器的总结
  9. Django 简单教程(入门级)
  10. 实战:Nginx如何让用户通过用户名和密码认证访问WEB站点