Best Cow Line
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 30684   Accepted: 8185

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD

题意:N个字符,要求将这N个字符按照字典序排序输出,每行80个字符

思路参考白书44页

#include<stdio.h>
#include<string.h>
const int maxn=1e6+10;
char ch[maxn];
int main()
{
int n;
char c;
scanf("%d",&n);
memset(ch,0,sizeof(ch));
for(int i=0;i<n;i++)
{
getchar();
scanf("%c",&c);
ch[i]=c;
}
int a=0,b=n-1;
int k=0;
while(a<=b)
{
int flag=0;
for(int i=0;i+a<=b;i++)
{
if(ch[a+i]>ch[b-i])
{
flag=0;
break;
}
else if(ch[b-i]>ch[a+i])
{
flag=1;
break;
}
}
if(!flag) printf("%c",ch[b--]);
else printf("%c",ch[a++]);
k++;
if(k%80==0) printf("\n");
}
printf("\n");
return 0;
}

百度上找的一个,忘了网址了

#include<bits/stdc++.h>
using namespace std;
int compa(char c[],int i,int j){
if(c[i]<c[j]) return 0;
if(c[i]>c[j]) return 1;
if(j-i<3) return 0;
return compa(c,i+1,j-1);
}
int main(){
int N;
cin>>N;
char* c;
c=(char*)std::malloc(N*sizeof(char));
for(int i=0;i<N;i++) cin>>c[i];
int i=0,j=N-1,k=1;
while(j!=i){
if(compa(c,i,j))cout<<c[j--];
else cout<<c[i++];
if(!(k++%80)) cout<<endl; //题目要求隔80个换行输出
}
cout<<c[i];
return 0;
}

最新文章

  1. a error of misunderstanding
  2. OpenGL学习笔记2——顶点数组
  3. mysql批量更新
  4. LoadRuner性能测试之内存分析方法及步骤(Windows)
  5. css 梯形标签页
  6. 10个值得我们关注的python博客
  7. [BNUZOJ1261][ACM][2016北理校赛]方块消除(栈,字符串)
  8. 查找git ignore的追踪
  9. 前序遍历构造已知二叉树(Java)
  10. win10优化工具哪个好
  11. 19.职责链模式(Chain of Responsibility Pattern)
  12. MySQL 使用profile分析慢sql,group left join效率高于子查询
  13. Java与编码问题串讲之二–如何理解java采用Unicode编码
  14. Tracing mysqld Using DTrace
  15. docker基于commit命令创建支持ssh服务的镜像
  16. PyQt5系列教程(五)制作fastboot烧写器
  17. 【bzoj2300】[HAOI2011]防线修建 离线+STL-set维护凸包
  18. 用PL/pgSQL写postgreSQL的存储过程[转]
  19. 【[ZJOI2008]骑士】
  20. [Elasticsearch2.x] 多字段搜索 (三) - multi_match查询和多数字段 &lt;译&gt;

热门文章

  1. Python下尝试实现图片的高斯模糊化
  2. 关于Floyd求解最小环的问题
  3. UVA-10118 Free Candies (DP、记忆化搜索)
  4. mysql判断表记录是否存在,不存在则插入新纪录
  5. 72. Edit Distance *HARD*
  6. quartz---springmvc的配置文件正合
  7. 一篇关于oracle psu的文章(转)
  8. 简话Angular 08 Angular ajax
  9. spring cloud 学习(二)关于 Eureka 的学习笔记
  10. oracle增加表空间