(置顶,复习)A + B Again

链接:http://acm.hdu.edu.cn/showproblem.php?pid=2057

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 35905    Accepted Submission(s):
14614

Problem Description
There must be many A + B problems in our HDOJ , now a
new one is coming.
Give you two hexadecimal integers , your task is to
calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it
!
 
Input
The input contains several test cases, please process
to the end of the file.
Each case consists of two hexadecimal integers A and
B in a line seperated by a blank.
The length of A and B is less than
15.
 
Output
For each test case,print the sum of A and B in
hexadecimal in one line.
 
Sample Input
+A -A
+1A 12
1A -9
-1A -12
1A -AA
 
Sample Output
0
2C
11
-2C
-90
 
Author
linle
 
注:
此题就是利用Long.parseLong()和Long.toHexString()的
replaceAll("\\+",""),是去除其中的‘+’,因为进制计算不支持带“+”的某一进制的数字字符串,‘-’可以,同时还需要判断正数负数,从而利用Long.toHexString()。
 
Java代码:

import java.util.Scanner;

public class Main {
public static void main(String[] args) {
Scanner inScanner = new Scanner(System.in);
while(inScanner.hasNext()) {
long l = Long.parseLong(inScanner.next().replaceAll("\\+", ""),16)
+ Long.parseLong(inScanner.next().replaceAll("\\+", ""),16);
if(l<0) {
System.out.println("-" + Long.toHexString(-l).toUpperCase());
}
else
{
System.out.println(Long.toHexString(l).toUpperCase());
}

}
}
}
 

最新文章

  1. iOS学习30之UITableView编辑
  2. Android--TextView 文字显示和修改
  3. Data Binding in WPF
  4. LR参数化设置(转)
  5. 使用OLEDB读取不同版本Excel数据的连接字符串设置
  6. log4j输出信息到mongodb
  7. Headfirst设计模式的C++实现——工厂方法(Factory Method)
  8. BZOJ 1216: [HNOI2003]操作系统( 优先队列 )
  9. 201521123019 《Java程序设计》第11周学习总结
  10. while100以内的偶数
  11. --save-dev 和 --save的区别
  12. FFmpeg备忘录
  13. zepto与jquery冲突的解决
  14. Socket通信例子
  15. leetcode python 037 求解数独
  16. codeforces478C
  17. 解决Python安装模块出错 ImportError: No module named setuptools
  18. 前后端分离springmvc和RESTful理解
  19. vue.js开发SPA常见问题及解决方法
  20. css中背景的应用

热门文章

  1. SVG辅助标签
  2. load加载层-layui
  3. POJ 3322 Bloxorz(算竞进阶习题)
  4. 【XSY1537】五颜六色的幻想乡 数学 生成树计数 拉格朗日插值
  5. MT【275】拉格朗日中值定理
  6. Spring学习记录
  7. 【Linux命令】linux一次性解压多个.gz或者.tar.gz文件
  8. 【Loj116】有源汇有上下界最大流(网络流)
  9. 【Luogu2664】树上游戏(点分治)
  10. 0-1背包 VIOJ1025