Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix.

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area.

Input

The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter integers according to the following table. 

The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3.

Table size: 1 * 1 <= S * S <= 1024 * 1024 
Cell value V at any time: 0 <= V <= 32767 
Update amount: -32768 <= A <= 32767 
No of instructions in input: 3 <= U <= 60002 
Maximum number of phones in the whole table: M= 2^30 

Output

Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.

Sample Input

0 4
1 1 2 3
2 0 0 2 2
1 1 1 2
1 1 2 -1
2 1 1 2 3
3

Sample Output

3
4
解题思路:
二维树状数组,直接用一维板子改成二维就行了,要注意的是询问区间的时候两个区间的差值并不能直接减,而且还要考虑边界的问题。
所以最后两个区间的差值由 (x2,y2)-(x1-1,y2)-(x2,y1-1)+(x1-1,x2-1);
数组是从0开始的,坐标必须加一
实现代码:
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define lowbit(x) ((x)&(-(x)))
const int N = ;
int m;
int c[N][N];
inline void update(int x,int y,int date){
for(int i=x;i<=m;i+=lowbit(i))
for(int j=y;j<=m;j+=lowbit(j))
c[i][j] += date;
} inline int sum(int x,int y){
int ans = ;
for(int i=x;i>;i-=lowbit(i))
for(int j=y;j>;j-=lowbit(j))
ans += c[i][j];
return ans;
}
int main()
{
int n,k,x,y,d,x1,x2,y1,y2;
while(scanf("%d%d",&n,&m)!=EOF){
memset(c,,sizeof(c));
while(scanf("%d",&k)){
if(k==){
scanf("%d%d%d",&x,&y,&d);
x++;y++;
update(x,y,d);
//cout<<sum(x,y)<<endl;
}
else if(k==){
scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
x1++;y1++;x2++;y2++;
//cout<<sum(x2,y2)<<endl;
printf("%d\n",sum(x2,y2)-sum(x1-,y2)-sum(x2,y1-)+sum(x1-,y1-));
}
else
break;
}
}
return ;
}

最新文章

  1. 几款主流 NoSql 数据库的对比
  2. 使用git svn clone迁移svn仓库
  3. c#委托(1)
  4. Linq世界走一走
  5. 2014多校第二场1011 || HDU 4882 ZCC Loves Codefires (贪心)
  6. yii2源码学习笔记(十六)
  7. pthread_setcanceltype 线程取消
  8. JavaScript版排序算法
  9. Xamarin 后台持续定位与提示
  10. HTML知识点总结
  11. crm 一级菜单排序,二级菜单选中并且展开,非菜单权限的归属,权限粒度控制到按钮级别
  12. vue动态添加路由addRoutes之不能将动态路由存入缓存
  13. 使用Spring+MySql实现读写分离(三)主从复制
  14. Codeforces 830D Singer House 动态规划
  15. 应用程序连接hbase报错:java.net.SocketTimeoutException: callTimeout=60000
  16. 【PyQt5-Qt Designer】工具箱(QToolBox)用法讲解
  17. HTML中嵌套的子frame如何访问父页面中的函数?
  18. Windows入侵问题排查
  19. o(1)取b &gt; a,且b的二进制中1的个数等于a二进制中1的个数,且使b最小
  20. mod_pagespeed

热门文章

  1. Luogu4768 NOI2018 归程 最短路、Kruskal重构树
  2. React-简书视频学习总结
  3. (原创)odoo在docker环境下无法备份
  4. 搭建SpringBoot+dubbo+zookeeper+maven框架(二)
  5. layer.conifrm 非阻塞执行 ztree删除节点 问题
  6. (7)学习笔记 ) ASP.NET CORE微服务 Micro-Service ---- 利用Polly+AOP+依赖注入封装的降级框架
  7. 记录网件r6220路由器登录配置
  8. 个人作业——final
  9. 第七周linux内核分析
  10. 递归拼装Tree结构数据