Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

This problem requires that you write a program to compute the exact value of R nwhere R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592 9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201
代码:
import java.math.BigDecimal;
import java.util.Scanner; public class Main {
public static void main(String[] args) {
Scanner s = new Scanner(System.in);
while(s.hasNext()){
BigDecimal b = s.nextBigDecimal();
BigDecimal ans = BigDecimal.valueOf(1);
int n = s.nextInt();
while(n-- > 0)
ans = ans.multiply(b);
String string = ans.stripTrailingZeros().toPlainString().toString();
if(string.startsWith("0."))
string = string.substring(1);
System.out.println(string);
}
s.close();
}
}
知识点总结
1、stripTrailingZeros() ,返回类型为BigDecimal的小于此数的但除去尾部的0的数值。
2、toPlainString(),返回BigDecimal类型的String类型字符串。
3、startsWith(),确定此实例的开头是否与指定的字符串匹配。
4、substring(),返回一个新的字符串,它是此字符串的一个子字符串。该子字符串始于指定索引处的字符,一直到此字符串末尾。

最新文章

  1. MAC下apache+php
  2. ArrayList转成HashMap再转成LinkedHashMap 自己的解决方案
  3. MacBook 配置
  4. HDU 1264 Counting Squares(线段树求面积的并)
  5. regular expressions
  6. EFDC_EE如何设置自适应时间步长
  7. Careercup - Google面试题 - 5680330589601792
  8. hdu 1301 Jungle Roads 最小生成树
  9. freemaker自定义分页控件实现
  10. JS中escape 方法和C#中的对应
  11. 【LeetCode】4Sum 解题报告
  12. Python3中的模块
  13. jar包和war包的介绍和区别
  14. Comet OJ - Contest #0
  15. Forth 词典和词汇
  16. update set where exists 多表更新 在mssql、MySQL、Oracle中分别用法
  17. Java中的==符号与equals()的使用(测试两个变量是否相等)
  18. ioctl参数cmd=2错误
  19. django rest_framework 框架的使用02
  20. python request 获取cookies value值的方法

热门文章

  1. Docker-compose实战
  2. MySQL回顾
  3. CSS页面布局与网格(上)
  4. c++萌新到大牛,要看哪些书?
  5. 2020-07-09:mysql如何开启慢查询?
  6. 2020-03-27:JDK1.8中在数据结构上,对HashMap做了什么样的改进?为什么?
  7. 01 树莓派4B—C语言编程——GPIO
  8. Java的注解浅析
  9. Linux命令--vi/vim复制一行,粘贴
  10. 实现图像的二值化(java+opencv)